Lightroom CC 2015.9 GPU not available on Windows 10 + NVIDIA GTX Titan X Pascal

  • 1
  • Problem
  • Updated 1 year ago
  • Solved
LR 6.9 doesn't allow me to switch on Performance GPU mode, even though I do have highend GPU with latest drivers.

Graphics Processor Info:Check OpenGL support: Failed
Vendor: NVIDIA Corporation
Version: 3.3.0 NVIDIA 378.66
Renderer: TITAN X (Pascal)/PCIe/SSE2
LanguageVersion: 3.30 NVIDIA via Cg compiler


Whole system info: http://pastebin.com/WQhfTzEc
Photo of Jarno Heikkinen

Jarno Heikkinen

  • 26 Posts
  • 6 Reply Likes

Posted 1 year ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 3170 Posts
  • 516 Reply Likes
Jarno, 

Can you post a screenshot of your Preferences>Performance Tab?
Photo of Jarno Heikkinen

Jarno Heikkinen

  • 26 Posts
  • 6 Reply Likes
Sorry, I was perhaps a bit vague in my wording, it does say errors, but it would help a lot if there was a log file telling what was the issue.

Photo of Jarno Heikkinen

Jarno Heikkinen

  • 26 Posts
  • 6 Reply Likes
Same story on Camera RAW plugin, but as far as I can tell, Photoshop itself is using OpenCL accelleration.

Photo of Robert Frost

Robert Frost

  • 392 Posts
  • 51 Reply Likes

It's probably not supported yet; it's a new card, right?

Bob Frost

Photo of Jarno Heikkinen

Jarno Heikkinen

  • 26 Posts
  • 6 Reply Likes
There was new driver (378.78) installed today, I've installed it with clean option checked and now it's working!  I don't know if it actually was the driver or the clean install option.

The card is already 6 months old and I've used it with Lightroom before.