Lightroom CC 2015.8: Stops working during photo browsing on Sierra 10.12

  • 1
  • Problem
  • Updated 2 years ago
  • (Edited)
Browsing a catalog with 11K+ photos (jpeg only) cause Lightroom CC 2015.8 to stop working.
Keep saying "loading" to render a picture but never end and have to kill lightroom.

Had the same issue with Lightroom 5.7.1, I thought it was because of the old version, but still do the same with the latest.

Any idea of the root cause?

thanks
Photo of Daniele Garofalo

Daniele Garofalo

  • 7 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Michel DELFELD

Michel DELFELD

  • 247 Posts
  • 33 Reply Likes
what is the size of your file?
Photo of Just Shot Me

Just Shot Me

  • 233 Posts
  • 61 Reply Likes
11,000+ images is nothing. Your problem is related to your system.
What OS are you running, be specific.
How many processes are running.
Photo of Michel DELFELD

Michel DELFELD

  • 247 Posts
  • 33 Reply Likes
I do agree with Just Shot Me
Photo of Daniele Garofalo

Daniele Garofalo

  • 7 Posts
  • 0 Reply Likes
Hi,
I'm using macOs sierra 10.12 (as said in the post title).
It doesn't happen on a specific file as it changes from ine session to another.
The issue started appearing once I upgraded from El Capitan to Sierra.

Jpg files are quite small, not above 5Mb.

Also it doesn't seem to be related to the number of processes, as it happens even with just Lightroom running.

Memory allocation is also ok with 6Gb of free memory.

Dan
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1496 Posts
  • 477 Reply Likes
Is the slowness happens while you are walking images in the library module? Try 1) reset the Lr preferences; 2) build the standard previews ahead of time.

Are there any changes to your display resolution?
Photo of Daniele Garofalo

Daniele Garofalo

  • 7 Posts
  • 0 Reply Likes
Thanks Simon,

all done, unfortunately no improvements.
I'm using the same laptop and same resolution.

thanks
Photo of Michel DELFELD

Michel DELFELD

  • 247 Posts
  • 33 Reply Likes
What type of graphic card is running on your Mac?
Can you check the free memory during running LR
To do that, run the app Activity monitor to be found in the utility folder
Photo of Daniele Garofalo

Daniele Garofalo

  • 7 Posts
  • 0 Reply Likes
Hi Michel,

I don't quite understand how that can be related as it was working perfectly with the El Capitan.
Free memory already posted, 6GB.

It's not a matter of slowness, Lightroom hangs and the only way to resume is killing it.

Thanks
Photo of Michel DELFELD

Michel DELFELD

  • 247 Posts
  • 33 Reply Likes
A change of OS version may always generate problems with one or an other app.
For instance, in LR CC, the X key doesn't work any more. Normally Adobe must have fix for that but, this not yet the case.
But, I must say until now this the only bug i met after OS change

May be there is an app that create bad sort of shortcut between LR and the OS. It may be programs that is running during the use of LR or a program that has generated somme .plist file that disturb LR.
The point is to determine from where the situation starts. Best to do is to call Adobe after sales and perhaps Apple after sales.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4500 Posts
  • 1689 Reply Likes
The X bug is non-English language versions and is found in 2015.8. It should be fixed in the next update.
Photo of Michel DELFELD

Michel DELFELD

  • 247 Posts
  • 33 Reply Likes
Thanks to know Victoria, and I must say for Adobe, it's a very light bug! But for the one using European keyboards it's hell when we want to select pictures.
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1496 Posts
  • 477 Reply Likes
When Lightroom hangs, are you in the library module or the develop module? If you are in the develop module, try turn off the GPU acceleration in the Performance panel of the Lightroom preference dialog.
(Edited)
Photo of Daniele Garofalo

Daniele Garofalo

  • 7 Posts
  • 0 Reply Likes
Hi Simon,
Library mode, unfortunately.

Dan
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1496 Posts
  • 477 Reply Likes
Please post your Lightroom System Info text here. Also, when Lightroom hangs, do a sample of the running Lightroom process (see example http://help.dayoneapp.com/sample-process-in-activity-monitor/), save the text and post it here as well.

What is your screen resolution? What is your standard preview size as shown in your 
Lightroom catalog settings dialog (under Lightroom>Catalog Settings...>File Handling). If you set your loupe zoom level to 1:4, 1:8 (depends on your image size w.r.t. the your screen resolution), would that be helpful?
Photo of Daniele Garofalo

Daniele Garofalo

  • 7 Posts
  • 0 Reply Likes
All,
I believe I found the issue. Moving from El Capitan to Sierra my NTFS driver stopped working allowing access in read-only mode. I've updated the driver and it seems now all OK.

Thank you for your help
Dan
Photo of Michel DELFELD

Michel DELFELD

  • 247 Posts
  • 33 Reply Likes
good point!
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1496 Posts
  • 477 Reply Likes
Dan, thanks for the update. In your case, the catalog happens to be on the read-only NTFS drive? 
Photo of Daniele Garofalo

Daniele Garofalo

  • 7 Posts
  • 0 Reply Likes
correct
Photo of Michel DELFELD

Michel DELFELD

  • 247 Posts
  • 33 Reply Likes
Hi Daniele,

As you, I am using Sierra.

My main LR catalog is having more than 35.000 pictures. In it the majority of the pictures are in PSD, DNG,  .TIFF 16 bits having more than 100Mb. There are also many intelligent collections. All things are running perfectly. Some times there is a slow down when I make heavy changes in intelligent collections or in picture key words. This slow down may be solved by waiting until the computer task is finished, You may also "optimise" the catalogue.

I am also using LLR and Sierra on a MBP. On this MBP, speed is clearly low. But it work without any problem.

Based on my experience, I must confirm that LR is not at the origin of your "stops". This should have to do with your computer and may be certain choices you made within LR. The only LR bug I met (as every body in european keyboard) is about the X key that only work combined with the shift key.

Last possibility may be relative the use of an app. that create on a instability within LR. For that, try to stop one after the other all app running during the use of LR.

Normally, LR is using thumbnails specially in the library module. In this module there is no heavy demand to the graphic card.

But several things may drastically slowdown your computer. When you import pictures in LR, you can decide thumbnails size. See the dump screen. The best is to stay at "Standard" size, you may also use the "Minimum " size but this will give you low quality thumbnails. May be did you asked to create thumbnails at "1:1" size this give a very good quality but may easily slowdown your computer if you have many of them.

You may also choose for creating/displaying "dynamic thumbnails" this will also slow down your computer.


Perhaps it would be good to give us the technical information regarding your computer. Very easy to do: go to the "apple" button and clic on "About this Mac" and display us the dump screen of these data.

I suppose you know that several apple computer may use Sierra, but will suffer about speed. have a look there: https://techsviewer.com/macos-sierra-slow-fixes/