Lightroom CC 2015.6 import error after OSX 10.11.6 upgrade solved (maybe)

  • 1
  • Problem
  • Updated 2 years ago
  • (Edited)
There are many posts relating to import issues but I'm posting this as new because
(a) it doesn't involve LR freezing and 
(b) it doesn't involve the LR 5.6 upgrade,
both of which seem to have caused problems.

I recently upgraded LR CC to 2015.6.  No problems.  The other day I took the OSX upgrade from 10.11.5 to 10.11.6.  Today I connected my 5D III to import a batch of pics and got

The following files were not imported because they could not be read. (23)

where 23 is the number of pictures, being all that was on the card.

I restarted LR and the camera, same error
I shut down and restarted the Mac (and camera), same error
I imported the pictures into the Mac Photos app without problem
Back to LR, same error
I connected the camera to my Ubuntu laptop and copied (and checked) the pictures without problem
At this point I can say it isn't the camera per se and it isn't the Mac per se, so I'm suspecting an interaction between LR and the upgraded OS
On a hunch I exported three pictures from Photos to a folder and from there imported them into LR without problem.  I then removed the new pics from the LR catalog and restarted LR, then reconnected the camera.  Imported all pics from the camera without problem.
To check, I then erased the card, shot some fresh test shots and imported them.  No problem.

So if you are recently (and especially after a recent OS or LR upgrade) getting the "files were not imported" error, try importing some files from disk (maybe any old photo files but mine were ones I'd already failed to import directly from the camera) and then restarting.  Good luck!
Photo of gobbagpete

gobbagpete

  • 2 Posts
  • 0 Reply Likes
  • Bemused but relieved

Posted 2 years ago

  • 1
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4306 Posts
  • 1569 Reply Likes
In most cases, that error message actually means "file can't be written" due to a folder permissions issue on the destination folder. I'm not entirely sure how exporting the pictures from Photos could have unstuck that, but thanks for sharing your experience!
Photo of gobbagpete

gobbagpete

  • 2 Posts
  • 0 Reply Likes
Thanks Victoria. A little light googling prompted me to check folder permissions at an early stage and it wasn't that. Like you, I doubt it was the export from Photos that did it: I suspect that I could have imported any old image file into LR and it was something about the successful import that unset some flag. I have no hard evidence for that, however, and no way of doing further tests now (thankfully!) If the problem should recur, I'll try that approach and report back.
(Edited)