Lightroom: CC 2015.2 User interface extremely sluggish and unusable

  • 9
  • Problem
  • Updated 3 years ago
  • (Edited)
My LR CC 2015.2 / OS X 10.10.5 Library mode was extremely sluggish, to the point of being unusable. I was in grid mode, viewing a published collection with a custom metadata panel open, with 4 columns open in the Filter Bar's Metadata browser. If I changed the most-selected pic, it would take 10 - 45 seconds for the Metadata panel to update. It would take 10 - 60 seconds to expand or collapse the Keyword List.

The option Show Add Photos Screen was unchecked.

I reverted to CC 2015.1.1 as recommended and described here: http://www.lightroomqueen.com/whats-n...
Photo of John R. Ellis

John R. Ellis, Champion

  • 3694 Posts
  • 966 Reply Likes

Posted 3 years ago

  • 9
Photo of P OB

P OB

  • 3 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Lightroom 2015.2 - Performance Issues & Slow Interface on MacOS 10.11.

I'm running a 2011 Mac Pro with 8GB of Memory. OS El Capitan.

Previous version of Lightroom was fast. This version... slow. All dialogue boxes are slow.

The develop panel and the folder panels are sluggish, taking around 20 seconds to respond to open or close.

Viewing Activity Monitor, LR is taking up 85% - 92% of my CPU.

I always have to Force Quit to close it.

Overall, you've killed my workflow. I can't continue to work in the environment. I'm now trialling Capture One.
Photo of John R. Ellis

John R. Ellis, Champion

  • 3690 Posts
  • 963 Reply Likes
See above for how to revert to CC 2015.1.1.
Photo of Benjie Graham

Benjie Graham

  • 2 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Freezing issues after latest update with Lightroom.

Are there reports of performance issues with the latest update in Lightroom? I updated tonight and the new import UI is horrible. It takes forever to load as well as the develop feature is buggy with lots of freezing when trying to edit. This JUST started happening with the latest update. Please address the performance issues
Photo of P OB

P OB

  • 3 Posts
  • 0 Reply Likes
Thank, John. Currently uninstalling and re-installing.
Photo of Robert Glöckner

Robert Glöckner

  • 1 Post
  • 0 Reply Likes
same here in Win 8.1/Xeon E3-1240-E2, 24GB RAM, 256GB SSD - nearly unusable with seconds of waiting after nearly every action - hope for another update soon. PS CC seems to work ok after the update. regards from Germany
Photo of Richard Dunn

Richard Dunn

  • 7 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled LR 6.2 slows down to a snails pace on my Mac. Why?.

I am a 2015CC subscriber and I updated LR 6.1.1 to 6.2 two days ago. I was happy with the new tools on the first day then saw the warning about the import change and looked into this on the next day. Whils't being surprised at the change I could still do what I wanted apart from ejecting automatically.
However when I went into the develop module the hard drive and processor started up big time and ALL functions in the develop module became 100 times slower making usage impossible. I followed advice to reset preferences, switch off the graphics processor and the show add photos in the general tab but these made no difference at all. LR was unusable. I then reverted back to LR 6.1.1 and will await an update to 6.2.
However the Creative cloud app no longer shows that I can update.
What I wanted to know was will I be able to update from CC when a new version is made, and will the slowdown occur again when I update. What was the slowdown due to?
I have a 2011 MBPro with 16Gb ram, 2.7 core i7 and running Yosemite.
Thank you in anticipation
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4296 Posts
  • 1563 Reply Likes
I've put the direct links in my blog post, in case it helps. http://www.lightroomqueen.com/whats-n...

The slow down that has been discovered was due to the new Add Photos screen, and that's (hopefully) been fixed in this CC 2015.2.1 update. It's certainly possible that you were running into other issues, but no one will know that until you try it. There's no risk to rolling back to 6.1.1 again if you have to do so.
Photo of Alan Wake

Alan Wake

  • 2 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Lightroom: CPU freeze Lightroom 2015.2 - 2015.2.1.

Lightroom 2015.1.1 works well
but new version 2015.2 - 2015.2.1problem began after updating on October 6 2015.2 - 2015.2.1.

Having launched the program without any actions in a background of system or in Lightroom in five minutes of CPU boots to 30%. Idle system and 30% :(

Lags simple actions like a crop, etc. of Export of a photo hang up it doesn't influence.

It was the day before yesterday rolled away perfectly works at Lightroom 2015.1.1 and all! But yesterday there was "fixed" 2015.2.1 updating and I thought problems solved. But all the same hangs up in inactivity.

Win 10 x64, GTX 660, i5 3470 - GPU uncheked HELP!
Photo of Richard Dunn

Richard Dunn

  • 7 Posts
  • 0 Reply Likes
Thats really disappointing. I will hang fire on reverted 2015.1.1 until I hear good things about performance.
Photo of Antonio Gómez Rivera

Antonio Gómez Rivera

  • 9 Posts
  • 0 Reply Likes
I have returned to the Lightroom 6
I only use Lightroom on desktop.
Version 6.2 is a damper, that has made us lose much time.
Photo of Antonio Gómez Rivera

Antonio Gómez Rivera

  • 9 Posts
  • 0 Reply Likes
In Lightroom 6.2 using the mouse is very slow, which makes the program unusable.
Any selection of the mouse (for example passing of high lights to shadows) more than 2 seconds.