Lightroom CC 2015.12: Synchronize Folder doesn't complete when "Show Import Dialog" is selected

  • 1
  • Problem
  • Updated 1 year ago

Scenario: Lightroom CC 2015.12, running on Windows 10 v1703, all completely up to date.

 

I have an existing folder hierarchy, and I've added three images into an existing folder that LR knows about.

 

I right click the folder in the Folders panel of the Library module, and choose "Synchronize Folder..."

 

Lightroom correctly identifies that there are three new images to be added:

 

2017-08-01_19-06-44png

 

Notice I have selected "Show import dialog before importing." I want this to be able to add keywords, metadata presets, etc.

 

However, when I choose "Synchronize," I get this blank import dialog. This is disturbingly similar to the very long standing import dialog bug where the thumbnails don't show up until you choose a "Destination." However, in the "Synchronize Folder" scenario, there is no destination tab on the right, because the destination is fixed and we are in "Add" mode:

 

2017-08-01_19-07-22png

 

Notice that any forward progress is completely halted - the "Import" button is greyed out, and there is no possible action other than to cancel the operation.

 

If, during the sync process, I De-Select the "Show Import Dialog" option, the images are imported correctly (but without the ability for me to pick and choose, add metadata and keywords, etc):

 

2017-08-01_19-08-39png

 

Photo of Michael Hoffman

Michael Hoffman

  • 5 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of Kathy Finch

Kathy Finch

  • 16 Posts
  • 0 Reply Likes
This sounds like the same problem I am having. It hasn't been corrected in the last several versions of LR.
Photo of Michael Hoffman

Michael Hoffman

  • 5 Posts
  • 0 Reply Likes
Hi Kathy, I saw your post on folder sync, but it sounds like a different (although maybe related) issue. For me, LR doesn't freeze up or anything, I just don't see the thumbnails, and so the "Import" button remains greyed out as though there were no photos to import.
Photo of Kathy Finch

Kathy Finch

  • 16 Posts
  • 0 Reply Likes
So you don't see the spinning circle under the folder that freezes up? Also, my problem seems to not always occur. I just used Sync Folder to import a video and it worked fine.
Photo of Michael Hoffman

Michael Hoffman

  • 5 Posts
  • 0 Reply Likes
No, I don't get any spinning circle. It behaves as though there are no images to import. Regular import does the same thing until I click "Destination," at which time the thumbs appear and all is well.