Lightroom CC 2015.1.1: Develop module doesn't detect external changes to original file

  • 17
  • Problem
  • Updated 3 years ago
  • Solved
  • (Edited)
When i choose "edit original" in Photoshop then the LR develop module doesn't reload the image after i saved the tif in Photoshop. But the library module DOES refresh. So i end up with different previews in library and develop. Only solution is to restart LR. After the restart i can see the current preview in develop module too.

Steps to reproduce:
- Open your raw file (i use dng) in LR.
- Choose "edit in Adope Photoshop". Make some changes and save. Lightroom will automatically import the created tif file. Switch to develop module in LR
- Now make another change in PS and save.
- LR should detect that change to the tif file and refresh the preview. Maybe you need to switch to the next image and back to have LR refresh the image. But it should work.
- Now close LR and PS.
- Start LR again.
- Select the tif file again, switch to develop module and choose "edit original" in Photoshop.
- Make changes in PS and save.
- LR will not refresh the preview in the develop module! But it will refresh the library module. You will now see different versions of your file in develop and library until you restart LR.

tested with Lightroom: CC 2015.1.1 and PS CC 2015.0.1 on Windows on two different machines.

This is a real pain for me since i often switch between PS and LR!

This worked flawlessly before LR CC.
Photo of Nico Kaiser

Nico Kaiser

  • 24 Posts
  • 1 Reply Like
  • frustrated!

Posted 4 years ago

  • 17
Photo of Clark Kranz

Clark Kranz

  • 12 Posts
  • 0 Reply Likes
I have not seen a problem in any other formats other than tiff, but if I use any external editor call from the LR development module when the file is saved out of that external editor and things return back to LR those changes are not showing up until lightroom is restarted.

Win10 LR CC

Lightroom version: CC 2015.2.1 [ 1046594 ]
License: Creative Cloud
Operating system: Windows 10
Version: 10.0
Application architecture: x64

External editors include Photoshop CC latest current release and DxO Labs filmpack 5. I have reported this bug since moving to LRCC and it appears again that it still has not been addressed. When will this get fixed?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15434 Posts
  • 2277 Reply Likes
Official Response
This issue should be corrected by the Lightroom CC 2015.3/6.3 which is available today.

Details here: http://blogs.adobe.com/lightroomjourn...
Photo of Nico Kaiser

Nico Kaiser

  • 24 Posts
  • 1 Reply Like
Ok. Seems there is a new issue. Now when a file which was edited externally is being imported back there a development settings automatically applied to it?! It seems like some development settings from a previous file/session are stored and applied to the newly imported tiff?!
Photo of Nico Kaiser

Nico Kaiser

  • 24 Posts
  • 1 Reply Like
I can't wait to get home now ;)
Photo of Clark Kranz

Clark Kranz

  • 12 Posts
  • 0 Reply Likes
Well I downloaded this last night and I still have this problem after the upgrade. I have logged in and out of my account many times,and still I have to restart LR to pick up changes...unless I wait for several hours .

When is this thing going to be fixed. It worked fine in LR 5.
Photo of Nico Kaiser

Nico Kaiser

  • 24 Posts
  • 1 Reply Like
Sure you got the LR Update installed?
Works without problems here now...
Photo of Clark Kranz

Clark Kranz

  • 12 Posts
  • 0 Reply Likes
Lightroom version: CC 2015.3 [ 1052427 ]
License: Creative Cloud
Operating system: Windows 10
Version: 10.0
Application architecture: x64
System architecture: x64
Logical processor count: 8
Processor speed: 2.2 GHz
Built-in memory: 12241.7 MB
Real memory available to Lightroom: 12241.7 MB
Real memory used by Lightroom: 855.8 MB (6.9%)
Virtual memory used by Lightroom: 813.6 MB
Memory cache size: 312.4 MB
Maximum thread count used by Camera Raw: 8
Camera Raw SIMD optimization: SSE2,AVX
System DPI setting: 96 DPI
Desktop composition enabled: Yes
Displays: 1) 1920x1080
Input types: Multitouch: No, Integrated touch: No, Integrated pen: No, External touch: No, External pen: No, Keyboard: No

Graphics Processor Info:
GeForce GTX 660M/PCIe/SSE2

Check OpenGL support: Passed
Vendor: NVIDIA Corporation
Version: 3.3.0 NVIDIA 353.54
Renderer: GeForce GTX 660M/PCIe/SSE2
LanguageVersion: 3.30 NVIDIA via Cg compiler

Application folder: C:\Program Files\Adobe\Adobe Lightroom
Library Path: C:\Users\Clark\Pictures\2015\2015-2.lrcat
Settings Folder: C:\Users\Clark\AppData\Roaming\Adobe\Lightroom

Installed Plugins:
1) Canon Tether Plugin
2) Export to Photomatix Pro
3) Facebook
4) Flickr
5) jf SmugMug
6) Leica Tether Plugin
7) Nikon Tether Plugin
8) SmugMug

Config.lua flags: None

Adapter #1: Vendor : 10de
D
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15424 Posts
  • 2272 Reply Likes
Which app or plug-in are you making changes in?

What OS/version are you running on?

Can you go to Help>System Info... and let me know what the first line of text is in that dialog?
Photo of Clark Kranz

Clark Kranz

  • 12 Posts
  • 0 Reply Likes
I am using DxO filmpack 5 and PS CC Win 10 and see my previous for system info
Photo of Clark Kranz

Clark Kranz

  • 12 Posts
  • 0 Reply Likes
I have also no tried completely uninstalling and re-installing and that did not resolve the problem.

Observations:
Filmpack 5 creates and imports a tiff copy of the file when selecting edit with LR adjustments...then opens its program to make alterations and saves out the file back to disk

LR does not refresh the image even though the file on disk is different than the file currently stored in memory. At times the film strip will flash the changes, but when the image is selected it will revert to the in memory version rather then reloading the image from file.

In LR 5 and earlier, these changes were picked up immediately when returning back to LR from the DxO filmpack software.
Photo of Clark Kranz

Clark Kranz

  • 12 Posts
  • 0 Reply Likes
Oh and occasionally when closing LR to pick up changes I get a message about still writing to xmp files which of course should not be occurring when working with tiff files as xmp files are specific to RAW files. The original shots for my images are RAW. I edit in LR then export to PS cc and save back to LR as a PSD. from here I export into filmpack 5 as a tiff and save once changes are complete. I go back to lightroom and the filmpack changes are not visible in LR as they had been in previous versions. Between each export I will often make more minor adjustments in LR to the PSD or tiff file. On occasion if I wait for say an hour, the changes will magically be picked up. not always and in some case the film strip show the changes but not the image view and when clicking on the film strip, the film strip will revert back to the un modified version of the image.
Photo of Manuel Rusch

Manuel Rusch

  • 6 Posts
  • 2 Reply Likes
LR 2015.5 Edited photo in PS doesn't refresh in Develop module, changes only show up in Library module.

:(
Photo of Clark Kranz

Clark Kranz

  • 12 Posts
  • 0 Reply Likes
After a long bit of study and research I found the real solution to this problem. In the catalog settings there is an option to automatically write out changes in the xmp files. If this is checked the changes are not picked up by LR until restarted. I had noticed there was an occasional message about not completing writing out the xmp file and it would complete the next time LR was restarted.

 

Unchecking this option allows the changes to be picked up immediately. Hope this helps someone else having similar problems.

 

Under catalog settings in the file handling tab you will see this option. If it is checked, try unchecking it and see if this allows your edits to be picked up when closing third-party applications work from LR.

Photo of John R. Ellis

John R. Ellis, Champion

  • 4385 Posts
  • 1162 Reply Likes
Which exact version of LR are you running?  (Do Help > System Info.)
Photo of Clark Kranz

Clark Kranz

  • 12 Posts
  • 0 Reply Likes
The latest and greatest.

Lightroom version: CC 2015.6 [ 1078672 ]License: Creative Cloud
Operating system: Windows 10
Version: 10.0
Application architecture: x64
System architecture: x64
Logical processor count: 8
Processor speed: 2.2 GHz
Built-in memory: 12241.7 MB
Real memory available to Lightroom: 12241.7 MB
Real memory used by Lightroom: 1983.9 MB (16.2%)
Virtual memory used by Lightroom: 4801.8 MB
Memory cache size: 3195.5 MB
Maximum thread count used by Camera Raw: 8
Camera Raw SIMD optimization: SSE2,AVX
System DPI setting: 96 DPI
Desktop composition enabled: Yes
Displays: 1) 1920x1080
Input types: Multitouch: No, Integrated touch: No, Integrated pen: No, External touch: No, External pen: No, Keyboard: No

Graphics Processor Info: 
GeForce GTX 660M/PCIe/SSE2

Check OpenGL support: Passed
Vendor: NVIDIA Corporation
Version: 3.3.0 NVIDIA 353.54
Renderer: GeForce GTX 660M/PCIe/SSE2
LanguageVersion: 3.30 NVIDIA via Cg compiler


Application folder: C:\Program Files\Adobe\Adobe Lightroom
Library Path: C:\Users\Clark\Pictures\2016\2016.lrcat
Settings Folder: C:\Users\Clark\AppData\Roaming\Adobe\Lightroom

Installed Plugins: 
1) Canon Tether Plugin
2) Export to Photomatix Pro
3) Facebook
4) Flickr
5) jf SmugMug
6) Leica Tether Plugin
7) Nikon Tether Plugin
8) SmugMug

Config.lua flags: None

Adapter #1: Vendor : 10de
D
Photo of Clark Kranz

Clark Kranz

  • 12 Posts
  • 0 Reply Likes
Sorry its under the metadata handling section where this setting is located.

Catalog settings, metadata tab option to automatically. write changes to xmp file.

If this is checked when the tiff file is resaved from external editing the changes made will NOT be picked up immediately by LR. Generally restarting LR is required to see those changes.

Unchecking this option allows the user to see the changes immediately.
Photo of John R. Ellis

John R. Ellis, Champion

  • 4385 Posts
  • 1162 Reply Likes
Unfortunately, turning off Automatically Write Changes doesn't fix the symptoms I experience, reported in this post earlier in the thread: https://feedback.photoshop.com/photos...
Photo of redchris

redchris

  • 3 Posts
  • 0 Reply Likes
Problem continues with lightroom 2015.7 ; camera raw 9.7
help!