Lightroom Classic: Book module issues - losing book edits

  • 1
  • Problem
  • Updated 1 year ago
  • (Edited)
This seems related to many problems reported in "Lightroom Classic: Book module many problems" and post. These two posts are marked as Solved but the problems do persist in newest version of Lightroom.

Problem with disappearing pages appears in the latest version of Lightroom Classic - 8.3.1 making the book module unusable.

When I add pages to an existing book, upon exiting the book module and entering it back, the added pages disappear.

More detailed description:

I started to create book in version 7.5 in Lightroom Classic on Windows 10.

At some point, after switching to Library and editing some photos and returning to a book, half of my book content was lost. Only pages 1 to 15 remained intact.

I started to add and edit pages again. After few hours of work I exited Lightroom.
When I reopened it again and reopened the book, all the new changes were gone again. Same first 15 pages remained.

I looked through this forum and saw that some people had similar problems. Apparently these problems have been solved with update 8.3.

I updated my Lightroom Classic to version 8.3.1 today.
I opened my book (containing same pages 1 to 15) and started to add new pages. After adding few and populating them with photos I switched to Library module and back to Book module. All newly added pages were gone again.

I tried to replicate the book and see if the same happens with replica. Exactly the same thing.

At this point I am completely unable to add new pages beyond page 15. Everything which I attempt to add will disappear after I exit book module and enter it again.

Any advise will be appreciated.

Photo of Miroslaw Lawczys

Miroslaw Lawczys

  • 18 Posts
  • 5 Reply Likes

Posted 1 year ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7536 Posts
  • 1727 Reply Likes

A Preference File will survive a Lightroom uninstall/reinstall. Sometimes weird behavior is corrected/cured by resetting the preferences. 

Reset Procedure:

1. Close Lightroom.
2. Hold down [Alt/Opt]+[Shift] while restarting Lightroom. 
3. Overwrite the Preferences when prompted by the dialog.
4. Close Lightroom.
5. Restart Lightroom.

Does the behavior continue after resetting the preferences?

Before we involve the engineering team on this, can you verify your LIghtroom version in Help>System Info... 

And confirm you've followed the reset procedure above?
Photo of Miroslaw Lawczys

Miroslaw Lawczys

  • 18 Posts
  • 5 Reply Likes

I did reset Preferences as per procedure above. Followed all 5 steps.

I have Adobe Photoshop Lightroom Classic 8.3.1 Release, Build [201905241238-dcd7e2de]
Windows 10.

The problem as described above persist:
  • Open a book which I created with earlier version of Lightroom (Classic 7.5). Book has 15 pages.
  • Add another page or two and populate with some photos.
  • Switch to Library module.
  • Double click on the book to open it in Book module.
  • After opening I see added pages for split of a second and than they disappear leaving book with 15 pages again.
Duplicating this book and working with duplicate does not help either. Duplicated book exhibits exactly the same problem.

When I create a brand new book, I can add pages and all works OK. But so it did with my other book up to the point were, all of a sudden Lightroom decided to delete most of my pages and leave my book with first 15. 

I also tried to Optimize Catalog just in case something got corrupted. No luck, same behaviour.

It seems that, at some point Lightroom during book creation, may corrupt a book. The problem is, that there are no backups offered by Lightroom so older version before corruption happened cannot be restored. 

The following steps led to this situation:
  • I was editing a book freely switching between Library and Book modules.
  • At some point I decided that one of the photos need editing.
  • I switched to Library module, selected the photo and edited it in Develop module.
  • Upon switching back to Book module all edited pages but first 15 were gone.
  • Since this moment I cannot add any more pages to this book

Photo of Prabal Ghosh

Prabal Ghosh, Computer Scientist

  • 41 Posts
  • 11 Reply Likes
Hi Miroslaw,

It is possible to share the catalog with us.This would help us debugging the issue better.Looks like the issue is specific to the book that you created during Lightroom Classic 7.5 time.
You can share catalog via dropbox and share the details at

Thank you.

~Prabal Kumar Ghosh
Photo of Miroslaw Lawczys

Miroslaw Lawczys

  • 18 Posts
  • 5 Reply Likes
Unfortunately I cannot share my catalogue with you due to privacy concerns.

I was able to create a new book from scratch and I did not experience the same problem. My mode of operation was to replicate the book every half an hour or so and rename replicas to be treated as backups in case of corruption.

I believe, it is advisable for Adobe to include automatic backups as a feature. Right now if a book in catalogue gets corrupted, like mine was, there is no way to go back to last good version (unless I do manual external backups of entire catalague or manual replicas).

Unfortunately my trust in Lightroom is shaken and I know there is a serious problem there, or perhaps multiple serious problems where users can loose their work.

Periodical auto backups are norm in the industry. Adobe should follow the suit and do it. Loosing work is the most critical bug you may have and, unfortunately, it seems Lightroom suffers from such issue.


Photo of Prabal Ghosh

Prabal Ghosh, Computer Scientist

  • 41 Posts
  • 11 Reply Likes

Hi Miroslaw,

We understand your privacy concerns.In that case, we need additional help from you to debug the issue.

Please locate config.lua under


And add the following line

loggers["LayoutModule"]= { logLevel='error',action = "logfile" }

and then launch Lightroom 8.3.1.

If you are unable to locate the config.lua in above path, then you can create the config.lua in the above mentioned path and paste the above mentioned line and launch Lightroom 8.3.1.

Then click on the book which is causing the issue.Make some changes in book by adding pages and then switch to library module and back to book module.In your case, as you are saying, new pages are lost.If this happens, some error logs will be generated in a log file(LayoutModule.log) under your “Documents” folder.Please share the log file with us in above mentioned mail.

Prabal Kumar Ghosh
Photo of Miroslaw Lawczys

Miroslaw Lawczys

  • 18 Posts
  • 5 Reply Likes
Hi Prabal,

I followed the steps you described and indeed the LayoutModule.log file was created when I added pages, switched to the Library module and switched back to the book. Added pages disappeared.

The content of the LayoutModule.log file is just two lines:

06/18/2019 20:34:29 ERROR loadLayout() threw error: (unknown C++ exception) 
06/18/2019 20:35:18 ERROR loadLayout() threw error: (unknown C++ exception)

Since I have noticed that there are two entries with slightly different times I tried to figure out when each was added. This is what I did.

1. I exited Lightroom 8.3.1 while the book I have problems with was opened.
2. I deleted LayoutModule.log file.
3. I started Lightroom again.
4. I have noticed that LayoutModule.log file was recreated and it had only one entry:
  06/18/2019 20:41:00 ERROR loadLayout() threw error: (unknown C++ exception)
5. I added new page to the book and checked the log file - no change.
6. I exited to the Library module and checked the log file - no change.
7. I entered book module again and added page disappeared. I checked log file and new entry appeared:
  06/18/2019 20:45:35 ERROR loadLayout() threw error: (unknown C++ exception)
8. I switched to Library module and opened different book which does not have this problem. Checked the log file - no change.
9. I quit Lightroom. No change in log file 
10. I opened Lightroom again which automatically opened good book. No change in log file.

Every time book module is opened with a bad book, whether it is from Library module or by starting Lightroom with a bad book, one line is added to the log file. This line is always identical and indicates C++ code exception when loading bad book layout.
[Date] [Time] ERROR loadLayout() threw error: (unknown C++ exception).

Thank you for looking into this issue.