Lightroom Classic 8.0: Crashes on Launch

  • 4
  • Problem
  • Updated 2 weeks ago
  • Acknowledged
  • (Edited)
Lightroom Classic 8.0 has suddenly started crashing shortly after startup, again! This problem really needs to be fixed. I send in crash reports, but get nothing back. Each time this has happened I've been left to fix it myself. On previous occasions I tried various methods to recover and eventually got Lr going again with no real knowledge of what actually fixed the problem. I just tried what appeared to fix it last time, but it didn't work this time. It would be very nice to hear back from Adobe. It would be great to have Adobe tell me they have identified the problem. It would be even better if Adobe told me they have fixed the problem. Meanwhile, I'm paying for a product that doesn't work! Lr Classic 8.0 is broken and needs fixing. As you can see, Lr hasn't even opened a catalogue before crashing.

Note: This conversation was created from a reply on: Lightroom Classic 8 crashing on launch.
Photo of Anthony Blackett

Anthony Blackett

  • 177 Posts
  • 53 Reply Likes

Posted 10 months ago

  • 4
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5882 Posts
  • 1290 Reply Likes
Official Response
Anthony, I was able to find your crash report and we do have a bug logged in our system for this issue. I've forked this to a different thread because the crashes reported in that thread are unrelated to your crash. 

Does this occur occasionally or every time you launch?
Photo of Anthony Blackett

Anthony Blackett

  • 177 Posts
  • 53 Reply Likes
Thanks Rikk, I wasn't sure about posting as a new topic or not, as it seemed to be the same issue that happened to me before.

Yesterday, Lr crashed every time I started it. I uninstalled it, rebooted my computer, reinstalled Lr, but it still crashed about 15 seconds after starting. I just left it over night, hibernating my PC.

This morning, after waking my PC from its sleep and reading your reply, I tried Lr again. So far, it hasn't crashed. All that has changed from yesterday is the time and I turned off my modem and turned it back on this morning, meaning my IP address has changed.

There doesn't seem to be any logic to this. I would love to know what precipitates the issue and why it comes and goes like this.

Thanks for your help, it is most appreciated.

Photo of Prabal Ghosh

Prabal Ghosh, Computer Scientist

  • 35 Posts
  • 9 Reply Likes
Hi Anthony,

Are still facing this crash in 8.2.1 Lightroom Classic.
Can you make sure if no devices are connected before launching lightroom.

Thanks,Prabal
Photo of Anthony Blackett

Anthony Blackett

  • 177 Posts
  • 53 Reply Likes
Hi Prabal,

I don't know if this crash reported for Lr 8.0 five months ago is the same as the one I experienced two weeks ago with Lr 8.2.1. The latest crash report that I submitted indicated the problem was with a device plugged into my computer. I isolated this to my Samsung Galaxy Tab S 10.5.

See https://feedback.photoshop.com/photoshop_family/topics/lightroom-classic-crashes-on-launch-again

If I have the tablet plugged in before launching Lr, then Lr crashes within about two minutes.

If I launch Lr first and wait for it to be ready, then connect my tablet, Lr doesn't crash. If I open the Import dialog, then Lr crashes almost immediately.

Now knowing what causes this problem, I can easily avoid it for now.

Tony
Photo of Prabal Ghosh

Prabal Ghosh, Computer Scientist

  • 35 Posts
  • 9 Reply Likes
Hi Anthony,
Does this crash happen with other peripheral devices connected ?

~Prabal Kumar Ghosh
Photo of Anthony Blackett

Anthony Blackett

  • 177 Posts
  • 53 Reply Likes
Hi Prabal,

I also have a Samsung Galaxy S4 Mini phone. When this is connected to my computer (on the same USB port as I use for the tablet), Lr 8.2.1 doesn't crash when launching it after connecting the phone nor does it crash when Lr is already running before the phone is connected. I can also open the Import dialog without Lr crashing with the phone connected. I find this a little strange since it appears to me that the phone and tablet use the same Samsung mobile device driver.

As for other devices like USB memory devices, SD cards and portable hard drives, none of these cause any problems.
Photo of Carlos Cardona

Carlos Cardona

  • 499 Posts
  • 104 Reply Likes
Please give your Mac the "once over"! Run the free Onyx (https://www.titanium-software.fr/en/o...), reboot. (In Onyx just run everything in the Automation tab). Run Disk Warrior if you can ($120), (https://www.alsoft.com), reboot. If you can’t do Disk Warrior, at least run First Aid from Disk Utility. Also just doing a "Safe Boot" can clear out caches (restart, hold down shift until you see "Safe Boot" on the screen, then reboot normally.

If that doesn’t work try launching Lightroom from your other (admin or test) account, with a new catalog, as a test. Does it run OK? If it does it may be a corrupted preference in your Username/Library folder. Check The Lightroom Queen site for instructions on how to reset your preferences (https://www.lightroomqueen.com).
Photo of Carlos Cardona

Carlos Cardona

  • 499 Posts
  • 104 Reply Likes
Could be a corrupt cache or application state.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 5103 Posts
  • 1996 Reply Likes
Er, this is Windows Carlos.
Photo of Carlos Cardona

Carlos Cardona

  • 499 Posts
  • 104 Reply Likes
Oops, the background fooled me! Thanks!
Photo of Jeremy Alderton

Jeremy Alderton

  • 15 Posts
  • 9 Reply Likes
This reply was created from a merged topic originally titled Lightroom CC Classic crashes constantly.

Lightroom Classic CC is constantly crashing since last update.  I initially suspected that it was the graphics card acceleration so I finally managed to turn that off (took numerous tries since it kept crashing out and not saving my preferences).  I can now start LR without it crashing every time, but if I try to import or develop photos it still crashes out. 

I've uninstalled an reinstalled LR.  Installed the previous version.  Updated all drivers and applied all Windows 10 updates.  Scanned all drives for errors.  Disabled Skylum plugins.

I've run out of things to try.  I'm working on a project that needs to be completed by Monday (5 days!) and I'm starting to panic.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5835 Posts
  • 1275 Reply Likes
Jeremy, I located your crash reports and they reference this known bug. I will escalate it to the engineering team. 
Photo of Roelof Moorlag

Roelof Moorlag

  • 198 Posts
  • 58 Reply Likes
Jeremy, for this moment perhaps the best option is to go back to the previous version so you can finish your project.
Photo of Jeremy Alderton

Jeremy Alderton

  • 15 Posts
  • 9 Reply Likes
I ended up with LR 6 (2015) but it can't read my catalogue because it's too new.  Kind of screwed here.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5835 Posts
  • 1275 Reply Likes
Jeremy, can you revert to any version of 7.x by going to the Down Arrow > Manage >Other versions in the Creative Cloud App?
Photo of Jeremy Alderton

Jeremy Alderton

  • 15 Posts
  • 9 Reply Likes
No.  I have options for versions 8.3.1, 8.3 or 6.0.  The first two crash, the last one can't read my catalogue.  "Find More Versions" link brings up v 6.0.
Photo of Roelof Moorlag

Roelof Moorlag

  • 198 Posts
  • 58 Reply Likes
But 8.3.1 is one version back and 8.3 two. Did you try them?
Photo of Jeremy Alderton

Jeremy Alderton

  • 15 Posts
  • 9 Reply Likes
Yes - all crash except v6, which won't open my catalogue.
Photo of Jeremy Alderton

Jeremy Alderton

  • 15 Posts
  • 9 Reply Likes
I'm now using Bridge as a work-around. Wonder if I'll get a credit from Adobe since my subscription doesn't work?
Photo of Anthony Blackett

Anthony Blackett

  • 168 Posts
  • 51 Reply Likes
Jeremy, my crash problem turned out to be my Samsung Tablet plugged into a USB port. Removed the tablet and no more crashes.

Do you have any devices plugged into your computer?
Photo of Jeremy Alderton

Jeremy Alderton

  • 15 Posts
  • 9 Reply Likes
Just my external hard drives. Need them - they're where my photos are.
Photo of Anthony Blackett

Anthony Blackett

  • 168 Posts
  • 51 Reply Likes
My external drive was fine, just the tablet. My Samsung phone didn't cause the problem either. Adobe know about it, but no fix yet.

Have you tried making a copy of your preferences file, then deleting it from its normal location so that a default one is recreated?
Photo of Jeremy Alderton

Jeremy Alderton

  • 15 Posts
  • 9 Reply Likes
Just tried this and it seems to be working!  Awesome... thanks for your help.  It's been up and running now for almost 4 hours, which is about 3 hours and 58 minutes longer than I was getting before.

Still don't trust it though.
Photo of Jeremy Alderton

Jeremy Alderton

  • 15 Posts
  • 9 Reply Likes
For those suffering from the same issue that I was, i. e. LR crashing ALL the time, here's what I did to resolve it.  Can't guarantee that it will work for you, but it seems to have worked for me (2 days without a crash):

1. Uninstalled LR and chose to remove all settings
2. Reinstalled an earlier version of LR (8.2.1 in my case)
3. Went to my preferences folder (in LR open Preferences/Presets/Show Lightroom Develop Presets) which will open File Explorer)
4. Close Lightroom
5. Double click the Lightroom folder, then double click the Preferences folder
6. Rename all of the files (should be 4).  I simply added ".old" to the end of each file name
7. Reboot the computer
8. Start LR

This got LR up and running and it seemed stable.  After it remained running for a day without an issue I opened Adobe Creative Cloud and updated my version of LR to the latest version.  It's been up and running overnight with nary a problem.

Thanks to Anthony Blackett for setting me on the right path.  However, I can't help but feel that if Adobe is charging me $14+/month (US-Canada exchange rate) I should have software that isn't buggy.  Which leads me to my next rant...

Not everyone uses a Mac - in fact, there are more Windows users than there are Mac users.  Can we all please get over the idea that serious users only use Mac hardware?  It's great that Adobe runs well on Mac systems, but let's not forget that most users are on Windows and software updates need to be tested on both Mac and Windows systems before being released.  I cancelled my Kelby One subscription when Scott Kelby opined that Macs were better looking computers and therefore more suited for artistic endeavours.  I swear I'll cancel my Adobe subscription if they try the same crap.

Here endeth my rant.  Good luck.
Photo of Anthony Blackett

Anthony Blackett

  • 168 Posts
  • 51 Reply Likes
Jeremy, it is good that you have been able to get Lr 8.3.1 running again, but neither you nor any of us should have to go through all this angst. It seems to me that the development team have a very poor record regarding fixing known bugs with some still outstanding after years of being reported.

It might be helpful, maybe, to send your old preferences files to Adobe to see if they can find what is wrong and hopefully get it fixed.

Tony