Lightroom Classic 7.3: Pandora's box of bugs

  • 6
  • Problem
  • Updated 2 years ago
  • (Edited)
I am a professional photographer and rely on Lightroom to make a living as my main raw converter and DAM.

However the 7.3 update has been a nightmare. Several of the issues and problems I'm having are already brought up in other threads so I won't repeat.

Another issue I'm having daily is that when I click a develop preset for an image, it gets applied only a long as I keep the curser on the develop preset tab. Once I hover back to the image, the applied preset that was just clicked, is gone.

Sometimes I have to restart Lightroom for the issue to go away temporarily, then it come back again.

All in all, 7.3 is a total mess. It is even slower than 7.1, so a big backward step. 

Is there an ETA for 7.4 and when all these bugs are squashed? I'm spending almost twice as much time on Lightroom as I should - and that is time I won't get paid for.

This rubbish is unacceptable.

MacOS, MacBook Pro, 16Gb RAM, 30% free SSD space.
Photo of Thomassen Blik

Thomassen Blik

  • 12 Posts
  • 9 Reply Likes
  • hating adobe

Posted 2 years ago

  • 6
Photo of sangean

sangean

  • 26 Posts
  • 32 Reply Likes
I just read the release notes of 7.3.1 and first headline is ‘fix customer issues’

To be clear, there are no ‘customer issues’. These are ALL Adobe issues, created by adobe themselves, not the customers.

Yet to install 7.3.1 but i can’t see any mention of the problems I’m having being solved.