Lightroom Classic 7.3: Sony a7III Camera Profiles are Broken

  • 12
  • Problem
  • Updated 1 year ago
  • (Edited)
Hello! Never had a need to post here so hope this is the right place.

I'm the proud owner of Sony's new a7III, so I've been shooting a lot recently putting it through it's paces. Lightroom finally got support for the camera with v7.3, so I've been digging through my RAWs. Very happy except I did notice a few odd artefacts on a few shots, but nothing that caused too much concern... UNTIL NOW!!

Basically, it seems that either my versions of the Camera Profiles or indeed Lightroom's overall are broken. At first I thought it could be to do with compressed vs. uncompressed RAW, but Sony's own RAW viewing software does not exhibit these issues. OBSERVE!

Exhibit A:

This is unprocessed in Lightroom with the Camera Standard profile applied.

Exhibit B:

This is the same shot using the Adobe Color profile. 

All the horrendous image noise/compression/whatever has gone, and the detail and smooth gradients are fine, the same as Sony's software. So, not a camera or RAW issue and this persists across all the profiles marked as Camera Matching... but does not exist in any of Adobe's profiles.

A ploy to try and persuade me to use Adobe colour profiles?! Maybe! But I thought you should be aware of it as clearly, something isn't being processed right by the Camera Matching profiles. I also went back to some of the images I'd spotted artefacts in... they were all fixed by using the Adobe profiles not the Camera Matching ones.

I appreciate it's early days with the new profile system, but if there's anything anyone can suggest I'd be very grateful. Hopefully it's an issue only I'm experiencing, otherwise there's a lot of other unhappy a7III Lightroom users right now!

FYI, I have reinstalled both Lightroom and Photoshop before posting here, and this happens on images of a variety of ISOs and noise levels... it's a software thing and I was just using this night image because of the transition from light pollution to sky (and it's the worst I've seen it). Also, this happens in Photoshop with Camera RAW using the same profiles.

Thanks,
Duncan
Photo of Duncan Birnie

Duncan Birnie

  • 3 Posts
  • 0 Reply Likes
  • hopeful

Posted 2 years ago

  • 12
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2675 Posts
  • 348 Reply Likes

I agree there is a problem.  It would be nice for Adobe to acknowledge such.

Here is a photo of a cat supplied by another user a couple weeks ago, that also demonstrates the issue:

https://drive.google.com/file/d/1Emxq_1nze-nFqQkr6CCh769zTBeBkkPb/view

Here are a couple side-by-side screenshots, the flawed Camera-match profile at the left and the Adobe profile on the right, one for LR and one for the ACR raw plug-in for Photoshop, both showing the issue, so it is profile-related not software-related:


The flaw is most obvious with out-of-focus areas that have a gradient which inexplicably shows hard edges.  Both the Camera-match and the B/W profiles derived from them show the issue, but not the Adobe-prefix profiles.

To help Adobe, I'd suggest also posting a link to your raw file, and any other examples that make the flaw obvious.

Photo of Duncan Birnie

Duncan Birnie

  • 3 Posts
  • 0 Reply Likes
Ah, I Googled but couldn't find any other posts. Good to know I'm not the only one!
Photo of Max Wendt

Max Wendt, Employee

  • 16 Posts
  • 22 Reply Likes
Official Response
We are aware of the issue and are working on a fix. Thanks for reporting!
Photo of Duncan Birnie

Duncan Birnie

  • 3 Posts
  • 0 Reply Likes
Hi Max, thanks for replying! Glad to know Adobe is aware and working on fixing this issue. Presumably it will work retrospectively on past images?
Photo of Eric Chan

Eric Chan, Camera Raw Engineer

  • 631 Posts
  • 133 Reply Likes
Yes, the fix will also work on previously-captured & imported raw files. 
Photo of Cai Denny

Cai Denny

  • 3 Posts
  • 0 Reply Likes
When will the fix be available?
Photo of David Ross

David Ross

  • 2 Posts
  • 0 Reply Likes
When will the correction of this luggage come out ?? Already passed a whole month!
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2675 Posts
  • 348 Reply Likes
Great
Photo of Cai Denny

Cai Denny

  • 3 Posts
  • 1 Reply Like
when will the fix be available?
Photo of Pásztor Tamás

Pásztor Tamás

  • 1 Post
  • 0 Reply Likes
I have discovered the same problem, even though I use RawTherapee instead of Lightroom. Therefore the problem is not with LR or RT, but with the dcp files:
(Edited)
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2675 Posts
  • 348 Reply Likes
I installed the recent Photoshop CC 2018 19.1.4 release, and while the Camera Raw version remained the same at 10.3, the Camera Raw plug-in version of these bad Camera-match profiles for the A7 III were deleted as part of the PS install process, although the LR version of the profiles remain.  Hopefully the next version of the camera raw engine for both PS and LR will fix them.
Photo of Cai Denny

Cai Denny

  • 3 Posts
  • 1 Reply Like
The issue is the same with the a7riii, any updates on this model regarding the yellow cast?
Photo of Todd Shaner

Todd Shaner, Champion

  • 1601 Posts
  • 539 Reply Likes
The A7R III yellow cast issue is discussed at a the below post and being investigated by Adobe Engineer Eric Chan. I suggest adding your 'Me To' vote and 'Follow' there:

https://feedback.photoshop.com/photoshop_family/topics/camera-standard-profile-for-a7r-iii-is-terrib...
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2675 Posts
  • 348 Reply Likes
Cai, do you have an example A7R III raw image you could share that shows the harsh edges in out-of-focus areas like the cat photo, earlier?  I am not seeing such edges in one sample A7R III image I've downloaded.
Photo of Eric Chan

Eric Chan, Camera Raw Engineer

  • 631 Posts
  • 133 Reply Likes
Steve, the issue with the harsh edges in OOF areas is for the A7 III, not the A7R III.
Photo of Torben Lysholm

Torben Lysholm

  • 1 Post
  • 1 Reply Like

Just wanna join in here
and report that I have the same issue.


See these two images (100% crop) of the results of the Camera Neutral and the Adobe Neutral profiles. See the edges of the bottles in the background.





And I have examples of noisy patches in gradient areas similar to the other images here.

I'm hoping for an update soon.

Best regards, 

Torben

Photo of David Ross

David Ross

  • 2 Posts
  • 0 Reply Likes
When will the correction of this luggage come out ?? Already passed a whole month!
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2675 Posts
  • 348 Reply Likes
The fix wasn't in the x.x.1 version that was rushed out to fix some other issues, but you would hope it'll be in the x.4 version whenever that is due.  Usually there are a few months between the .x releases, because they're adding new cameras, new lenses and perhaps new functionality.  This isn't something they'd rush out a fix for just for itself, because the work around is to stay away from the camera-match profiles.
Photo of drmaven

drmaven

  • 2 Posts
  • 1 Reply Like
Thanks for pointing out this issue, I just bought the A7III and was worried that there was some sort of a problem with my camera. I have noticed that it happens especially in the bokeh part of the picture, as demonstrated in the attached pics.

Camera profiles give me much better colors than the Adobe ones, so this is really a big problem for me. Does anyone have any alternatives to get better colors, until the fix is out?


Adobe Vivid


Camera Vivid
Photo of Jeffrey ODonald

Jeffrey ODonald, Program Manager, Camera Raw

  • 45 Posts
  • 12 Reply Likes
The fix for this issue was in Camera Raw 10.4 and Lightroom Classic 7.4, released earlier this week on 6/18. Please check it out and let us know if it is resolved for you. Thanks!
(Edited)
Photo of drmaven

drmaven

  • 2 Posts
  • 1 Reply Like
Thank you, I installed it 10 minutes ago and it seems that everything is working as intended.
Photo of Jeffrey ODonald

Jeffrey ODonald, Program Manager, Camera Raw

  • 45 Posts
  • 12 Reply Likes
Good to hear! Thanks for confirming.
Photo of Torben Lysholm

Torben Lysholm

  • 1 Post
  • 0 Reply Likes
Yes, it certainly was a pain in the butt, but it's fixed now. The noise/gradient issue is gone. Colors are also pretty much spot on as far as I can tell. There's still an "issue" (not a bug, but just a discrepancy) with exposure/shadow/higlights/whites/blacks somehow that still doesn't match the Sony Edit output og even the jpg out of camera, but the camera matching profiles are better than the Adobe profiles in my opinion. Or should I say, at least more true to the way Sony Edit renders them, and I vastly prefer that generally.