Lightroom 6: Under Windows 10 slows to a crawl until restart

  • 1
  • Problem
  • Updated 3 years ago
  • Solved
  • (Edited)
Since I upgraded to Windows 10, Lightroom 6 has become painfully slow. It works perfectly fine at first, but after editing about five photos, it slows to a crawl. If I restart Lightroom, it works quickly again for a few photos, then slows down again.
I have updated my video driver to the latest, and tried turning the graphics acceleration off and on. It makes no difference. System specs below:

Lightroom version: 6.2.1 [ 1046594 ]
License: Perpetual
Operating system: Windows 10
Version: 10.0
Application architecture: x64
System architecture: x64
Logical processor count: 4
Processor speed: 3.0 GHz
Built-in memory: 8153.0 MB
Real memory available to Lightroom: 8153.0 MB
Real memory used by Lightroom: 1467.1 MB (17.9%)
Virtual memory used by Lightroom: 1512.1 MB
Memory cache size: 807.8 MB
Maximum thread count used by Camera Raw: 4
Camera Raw SIMD optimization: SSE2,AVX
System DPI setting: 96 DPI
Desktop composition enabled: Yes
Displays: 1) 1600x1200
Input types: Multitouch: No, Integrated touch: No, Integrated pen: No, External touch: No, External pen: No, Keyboard: No

Graphics Processor Info:
GeForce GT 620/PCIe/SSE2

Check OpenGL support: Passed
Vendor: NVIDIA Corporation
Version: 3.3.0 NVIDIA 358.87
Renderer: GeForce GT 620/PCIe/SSE2
LanguageVersion: 3.30 NVIDIA via Cg compiler

Application folder: C:\Program Files\Adobe\Adobe Lightroom
Library Path: C:\Users\Sara\Pictures\Lightroom\Lightroom Catalog.lrcat
Settings Folder: C:\Users\Sara\AppData\Roaming\Adobe\Lightroom

Installed Plugins:
1) $$$/PerfectEffects/Title=Perfect Effects 9
2) Canon Print Studio Pro
3) Canon Tether Plugin
4) Export to Photomatix Pro
5) Facebook
6) Flickr
7) Leica Tether Plugin
8) LR/Enfuse
9) Magic Export
10) Merge to 32-bit HDR
11) Nikon Tether Plugin
12) ShootProof

Config.lua flags: None

Adapter #1: Vendor : 10de
Device : 1049
Subsystem : 97710de
Revision : a1
Video Memory : 973
Adapter #2: Vendor : 1414
Device : 8c
Subsystem : 0
Revision : 0
Video Memory : 0
AudioDeviceIOBlockSize: 1024
AudioDeviceName: Speakers (Realtek High Definition Audio)
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 44100
Build: Uninitialized
Direct2DEnabled: false
GPUDevice: not available
OGLEnabled: true
Photo of Thomas Winger

Thomas Winger

  • 2 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14147 Posts
  • 1765 Reply Likes
Did it working OK prior to the 6.2.x update? If so, I'd recommend that you roll back to the prior 6.1.1 update until things are reverted and corrected: https://helpx.adobe.com/lightroom/kb/...
Photo of Thomas Winger

Thomas Winger

  • 2 Posts
  • 0 Reply Likes
I don't recall precisely whether I did the 6.2 update before or after the Windows 10 update (about a month ago). But I've done the roll-back as you suggested, and so far it seems to have fixed the problem. Unfortunately at the moment I don't have a new batch of photos to process, so I've just scrolled through an older collection and changed a few things; it seems to stay quick. I'll know for sure after a bit more time working with it. Thanks.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14147 Posts
  • 1765 Reply Likes
Cool. Thanks.
Photo of superkev

superkev

  • 26 Posts
  • 10 Reply Likes
I was experiencing this exact problem after upgrading to Windows 10. Installing the latest update (Lightroom CC 2015.3) solves the problem. Lightroom is a pleasure to use again!