Lightroom 6.4 so slow it is unusable.

  • 1
  • Problem
  • Updated 2 years ago
What I find sad is that many of the listed complaints regarding Lightroom 6 or higher show they are 10 months old. I have been using PS and Lightroom 6.4 for about a month and am experiencing all the slow downs to the point where there is no point in working on the photos. Total waste of time and money. The more editing I do on a specific photo, the slower the software response down to virtually no response. I am amazed that Adobe had the nerve to put out a product that is faulty right from the beginning. And, they make no bones about taking your money.
Apparently this is a huge problem happening to many users and it is sad there is no fix. When I made the move to Photoshop I was so excited that I was finally going from amature editing software to top of the line pro, but not any more.
Photo of roknroll3 .

roknroll3 .

  • 5 Posts
  • 0 Reply Likes
  • Disappointed

Posted 2 years ago

  • 1
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 3822 Posts
  • 1266 Reply Likes
When you say "the more editing I do on a specific photo", are you referring to local adjustments or spot adjustments by any chance? If so, you may be misunderstanding the limitations of a metadata-based editor.
Photo of roknroll3 .

roknroll3 .

  • 5 Posts
  • 0 Reply Likes
Thanks for your reply. Referring to spot removal and adjustment brush.
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2586 Posts
  • 323 Reply Likes
Have you disabled the GPU using LR / Prefs / Performance - uncheck Use Graphics Acceleration?


Does your computer have enough memory or is it using virtual memory on disk that is much slower than RAM?

LR runs ok on my Windows 10 PC with 16GB of RAM and a 1GB NVidia video card.  My older computer has a video card that is too old and I have to disable the GPU on it otherwise it is too slow.
(Edited)
Photo of roknroll3 .

roknroll3 .

  • 5 Posts
  • 0 Reply Likes
Thanks for your reply. I will try that and reply back.
Photo of roknroll3 .

roknroll3 .

  • 5 Posts
  • 0 Reply Likes
your idea definitely helped in that the useful time between normal function and slow has increased but still slows down dramatically after using the spot removal and adjustment brush.
Photo of roknroll3 .

roknroll3 .

  • 5 Posts
  • 0 Reply Likes
This happens 2-3 times per day.
Photo of Paul Plak

Paul Plak

  • 138 Posts
  • 19 Reply Likes
could it be you need more RAM memory ? LR and PS are powerhorse applications. They run well on my PC, but it has 24 GB RAM and a very fast processor.
Photo of Kent Messamore

Kent Messamore

  • 49 Posts
  • 28 Reply Likes
I am running Lightroom 6.4 on my desktop with Windows 7 64 bit with absolutely no speed issue but I have a solid state disk for my C drive and a fast GPU.  However,  I also run it on my laptop which has none of the things that my desktop has.  I don't believe you have a software issue.  I recommend you take a look at your hardware configuration or perhaps something running in the background.  Try MSCONFIG and take a look at what might be running in the background.