Lightroom 6.4: Crash on Mac 10.8.5 (minimum OS required is 10.9.5)

  • 1
  • Problem
  • Updated 2 years ago
  • Not a Problem
  • (Edited)
Help my todays download of Lightroom 6.4 crashed my app. I cannot access Lightroom at all. I am on a Mac 10.8.5, 6.3 worked fine. What should I do??
wayne
Photo of wayne reeves

wayne reeves

  • 2 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1385 Posts
  • 413 Reply Likes
Official Response
Lr 6.x is not supported on Mac OS X 10.8.5. The minimum Mac OS X version required is 10.9.