LIGHTROOM 6.4 - Building thumbnails hangs on my Windows 10 system

  • 1
  • Problem
  • Updated 2 years ago
  • (Edited)
Building thumbnails, in the first phase of looking for thumbnails to (re)build, may hang on certain images. It doesn't appear to cost CPU  time, it's just sitting there, doing jackall, allowing me to cancel it as the only way out.

Then, all I can do, is "guess" which picture is hung on, go to it in grid view, let it generate a thumbnail, and then trying building thumbnails again from the menu. Then, it'll work.

So, something is broken there. Needs fixing.

This happens on Lightroom 6.4 on Windows 10 (at least).
Photo of martijn Saly

martijn Saly

  • 194 Posts
  • 18 Reply Likes

Posted 2 years ago

  • 1
Photo of avinash r

avinash r, Employee

  • 24 Posts
  • 5 Reply Likes
Hi Martijn,

Could you please describe the exact steps that you are doing?.
Also what format of images are you using here ? 
Is it specific to any particular set of images?
Photo of martijn Saly

martijn Saly

  • 194 Posts
  • 18 Reply Likes
Have a large sets of pictures, all of them jpeg. They are coming coming a source I don't control, so there's nothing I can do to get them in a different format. They may be broken, incomplete, corrupt, kaputt, or whatever. LR5 used to crash on them, LR6 does not, but apparently something still causes it to stop.

I just select "build standard-sized previews" from the menu. That's all.

Then it normally goes through 2 phases. It hangs at a certain pictures in phase one. In phase one, it does say which image is currently processing, it just displays a number. So I have no way of knowing which image is causing it to stop.

Like I said, it just stops in the first phase. It just doesn't go any further, it's just stopped in its tracks. It's not frozen, just stopped. It's not using cpu time either. All I can do is cancel the opration in the top bar. It's 100% reproducible.

Letting LR generate thumbnails (i.e. standard-sized previews) by just scrolling through the grid view eventually hits the problem image, generates its preview, and then, and only then, I can give it another try from the menu option. Usually it skips over the problem image and goes on generating previews as normal.
Photo of avinash r

avinash r, Employee

  • 24 Posts
  • 5 Reply Likes
Could you share the sample set of images through dropbox or something?

And I request you to write up the steps in bullet points; starting from the launch covering every step you do. Thanks in advance !!