Lightroom 6.2.1: Video Cache is out of control

  • 31
  • Problem
  • Updated 5 months ago
  • In Progress
  • (Edited)
I recently upgraded to Lightroom 6.2.1 So far there has been a lot of fuss over the import dialog... ok, well sure, it has a few issues, but they can be either worked around or just revert back to 6.1.1

I would like to report and ACTUAL bug in 6.2.1

My D drive recently ran out of space... I tried deleting some stuff I didn't need, but still it kept running out of space... So I finally ran windirstat and had a look at it.. Nearly HALF of my drive was FULL of D:/temp/Adobe Local/Lightroom/caches/video/media Cache Files. Now here's the kicker... NONE of these video files are even on the hard drive that has my catalog on it. My lightroom database is on drive L:\ all my lightroom photos and very few lightroom videos are all on L:\ I have a few scans on drive K:\ that I import to lightroom... but these videos are ALL on Drives E:\ and F:\

here's another thing.. I knew Adobe wasted space caching videos, and I do have a GOPRO and I record a little video,.. .VERY LITTLE, maybe 1 video a year... so I don't really want ANY of the video cached.. I will wait for it to load... SO a long time ago, I set my video cache in Preferences>File Handling to the minimum of 1GB (It's was always a BUG to not allow 0GB) I don't want to cache any videos!!!!!!!!!! but here it is.. NEW BUG It's STILL SET TO 1GB!!!!!!!!!!! How is it gobbling up almost 1TB of space when I have it set to 1GB??????????????? So.... here's another problem... I have Cache files that are 4GB for a movie that only takes up 2GB on my hard drive.. what's up with THAT??????????????? I randomly checked a few, and the worst one was a 5GB cache file for a movie that only takes up 750MB on my hard drive... two things, first of all... you NEVER EVER EVER need to cache an entire movie... caching more than 1 minute of a video is useless... if you're going to watch the video in lightroom, it can just play the video on the hard drive fast enough that it doesn't need further caching.. second... DON'T CACHE THE VIDEO AT ALL!!!! just capture the thumbnail of it so you don't have a blank square on the catalog and call it a day... if someone wants to play the video, it will load and play plenty fast enough, Lightroom Can't work with video files, only play them, so WHY BOTHER TO CACHE THE WHOLE THING?? come on Adobe, some COMMON SENSE please!!!!

so now ANOTHER BUG, it's already set to limit video cache to 1GB, so I figure, the new import thing must have built this RIDICULOUS Cache, so I will just Purge it, that will bring it down to 1GB right??/ WRONG!!! It pops up a message saying "Video cache is being purged, this message will be dismissed when the purge is finished... I wait 5 Seconds, and the message disappears, I have NO hard drive activity, and well... I STILL have 1GB of Video Cache files!!!!!!!!!!! Ok, maybe it didn't take.. let me set it to 2GB, then purge.. NOPE! let me set it back to 1GB then purge, NOPE..

ok, so I suspect how to fix it will be, (I Hope) click import, and select the movies folder and then select Ignore source... by the way, how do I add my E:\scans folder as a legitimate source.. I just removed a source, how do I add a nice shortcut button for a new one? ok, now that source is removed, I hope it won't scan it again... now that it will HOPEFULLY not scan that hard drive again, I'll manually delete the offending Video cache.. ok manual delete complete, Ahh my drive can breathe again.. Lets open light room and see what happens.... ok.. open.. lets open the Import dialog because eventually I'll need to import something... oh-o..... What's this??? Scanning Common Locations... OH-NO!!!!!!!!!! first of all E:\Moves and F:\TV are NOT COMMON LOCATIONS FOR PHOTOS Second, I REMOVED THOSE LOCATIONS.. It has a valid location listed, WHY IS IS LOOKING FOR SOMEWHERE ELSE????? Yes it's now scanning VIDEOS and the only reason for it to be taking so long is it went back to my E and F drive... lets look at the cache folder... oh yes, MediaCache already has 3,876 files in it.... not looking very good. Why is it caching files that are not even imported into lightroom??? and why is the cache for each file taking up more space than the entire video??? If you want to make a video cache.. just cache the THUMBNAIL ONLY!!!!! we don't need or want anything else cached.. a thumbnail is all we need cached for our few relevant videos so we don't have a black square in our catalog.

Crap, I'm going to be FORCED to revert to 6.1.1 even though I had every intention of working around the other 6.2.1 issues. TEST TEST TEST Test your software!!! the monkeys you have testing it are not doing a good enough job! send it to me, I'll test it for you, It needs to be tested on a real computer, one that is used for other things.. that way you would KNOW it's finding stupid things like CD cover art and every movie and tv show on my hard drive. I seem to find glaringly obvious issues within one day of using the product. I've been developing software for the last 28 years, I know how it should be done, and how things should be tested, and this is NOT being done AT ALL. Your programmers are sub-standard and are missing the mark, and your non-existent SQA department is NOT testing even the simplest of functions.
Photo of James Richters

James Richters

  • 73 Posts
  • 32 Reply Likes

Posted 4 years ago

  • 31

There are no replies.