Lightroom 6.1.1: Won't build preview in slideshow module

  • 2
  • Problem
  • Updated 3 years ago
  • (Edited)
I just updated from LR ver 6.0 to 6.1.1 to overcome LR not being able to read the raw files off my new sony 7R mark 2.  That probl;em was solved, HOWEVER I now cant build / play a slide show with any of my jpg files (post Sony and pre Sony), no matter how many images I select , when I press preview or play I just get a message that says "preparing preview for slide #2"  and then nothing else happens!

I have quit LR and reopened it but nothing changes.

Any answers/solutions would be appreciated
Photo of Stewart Watson

Stewart Watson

  • 6 Posts
  • 0 Reply Likes
  • frustrated

Posted 3 years ago

  • 2
Photo of Tom Mickow

Tom Mickow

  • 473 Posts
  • 188 Reply Likes
6.1.1 is pretty old.  6.6.1 is the current version.
Did you have a typo, perhaps?

If not, I'd suggest installing the latest version.
Photo of Stewart Watson

Stewart Watson

  • 6 Posts
  • 0 Reply Likes
no that was not a typo I'm on 6.1.1 and want to update my perpetual licence to the latest version , but every time i try to find a link to download I end up on a cc version site, does anyone have a link to download the latest version of the perpetual??....I'm struggling
Photo of Stewart Watson

Stewart Watson

  • 6 Posts
  • 0 Reply Likes
Ok so i managed to upgrade to 6.6.1 but i still cant get selected images to preview/play, i have tried images in folders that are months old, no joy, new images, i wondered whether there was a file type restirction so i have tried jpgs and raw images, i wondered whether there was a size restriction, so exported some jpgs to much smaller tiles, still no joy?
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 5339 Posts
  • 2113 Reply Likes
Let's start at the top... what are your system specs? Go to Help menu > System Info and paste the contents in a reply.
Photo of Stewart Watson

Stewart Watson

  • 6 Posts
  • 0 Reply Likes
Lightroom version: 6.6.1 [ 1083169 ]License: Perpetual
Operating system: Mac OS 10
Version: 10.10 [5]
Application architecture: x64
Logical processor count: 4
Processor speed: 3.1 GHz
Built-in memory: 12,288.0 MB
Real memory available to Lightroom: 12,288.0 MB
Real memory used by Lightroom: 1,821.4 MB (14.8%)
Virtual memory used by Lightroom: 3,336.3 MB
Memory cache size: 1,541.9 MB
Maximum thread count used by Camera Raw: 4
Camera Raw SIMD optimization: SSE2,AVX
Displays: 1) 2560x1440, 2) 1680x1050

Graphics Processor Info: 
AMD Radeon HD 6970M OpenGL Engine

Check OpenGL support: Passed
Vendor: ATI Technologies Inc.
Version: 4.1 ATI-1.32.25
Renderer: AMD Radeon HD 6970M OpenGL Engine
LanguageVersion: 4.10

Application folder: /Applications/Adobe Lightroom
Library Path: /Users/watson/Pictures/LIghtroom test catalogue /LIghtroom test catalogue-2-2.lrcat
Settings Folder: /Users/watson/Library/Application Support/Adobe/Lightroom

Installed Plugins: 
1) 500px
2) Aperture/iPhoto Importer Plug-in
3) Aurora HDR Pro
4) Canon Tether Plugin
5) Facebook
6) Flickr
7) Focus CK
8) FX Photo Studio CK
9) HDR Efex Pro 2
10) Intensify CK
11) Leica Tether Plugin
12) LR/Enfuse
13) LR/GMail
14) Macphun Creative Kit
15) Nikon Tether Plugin
16) Noiseless CK
17) Snapheal CK
18) Tonality CK

Config.lua flags: None

AudioDeviceIOBlockSize: 512
AudioDeviceName: Built-in Output
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 48000
Build: LR5x102
CoreImage: true
GL_RENDERER: AMD Radeon HD 6970M OpenGL Engine
GL_VENDOR: ATI Technologies Inc.
GL_VERSION: 2.1 ATI-1.32.25
OGLEnabled: true
GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_array_range GL_APPLE_vertex_point_size GL_APPLE_vertex_program_evaluators GL_APPLE_ycbcr_422 GL_ATI_blend_equation_separate GL_ATI_blend_weighted_minmax GL_ATI_separate_stencil GL_ATI_texture_compression_3dc GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_barrier GL_SGI_color_matrix GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod 
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 6292 Posts
  • 1401 Reply Likes
Your GPU is not supported. See this document: .

Slideshow depends upon the GPU. There is a warning dialog that should have appeared notifying you of this. Perhaps you dismissed it and checked the "Do Not Show Again" option?
Photo of John Lund

John Lund

  • 13 Posts
  • 1 Reply Like
Have just run into this issue myself.
Are you saying the Slideshow module will not work at all unless I have an officially supported GPU?
-- edit: testing some more, actually I have been able to export as pdf slideshow, just no preview or play from within LR Slideshow module itself --
I have been hearing of issues trying to use GPUs for years, and thought the program would still function normally if the user disabled GPU acceleration. Had not heard about losing features that way.
Man, wish I had known about this downgrade earlier. In all other respects my gracefully aging MacPro - 32GB RAM, SSDs, OS X 10.5 - runs LR (cc2015.8) & PS (cc2017)  just fine...
So if I want to use Slideshow module am I forced to upgrade my Mac?
Photo of Stewart Watson

Stewart Watson

  • 6 Posts
  • 0 Reply Likes
Thanks Rikk for coming back with this. Prior to getting your reply I had by trial an error overcome my problem. When I was trying to preview a slideshow, I realised that I had several other applications sitting open in the background although not being actively used, and I decided to close them to see if there were potential clashes somehow.

From memory the ones I closed were Affinity Photo, TeamViewer and  Auroroa HDR Pro-3.   So slideshow was back working again, to try and prove my theory I reopened these applications and tried the slideshow again and this time it worked, so very strange.

Other things I found confusing were

- Ive had this AMD RADEON HD 6870M Open GL engine from ATI technologies for years on my imac with no issues, so why now and also the fact that on one of the LR sites you pointed me towards  says that the GPU is only used in the Develop module, whereas I was in the slide show module, so presumably there shouldn't be an issue with the GPU when in the slideshow module.

Do I really need to update my GPU to a supported version, I assume its a new supported software driver (as opposed to hardware) and can you provide me with a link to achieve that, I canbt find a way to do this 
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 6292 Posts
  • 1401 Reply Likes
Referencing GPU and Slideshow see this thread: 

AFAIK, it is a hardware upgrade at this point. I am unaware of any driver change you can make that will enable support of this family of cards in the future. 
Photo of John Lund

John Lund

  • 13 Posts
  • 1 Reply Like
This reply was created from a merged topic originally titled Does Slideshow module not function without supported GPU?.

Suddenly I am finding the Slideshow module in Lightroom cc 2015.8 does not seem to function at all. No Preview, no playing, regardless of what options or settings I use - even the supplied "Simple" or "Widescreen" templates. Clicking on Play or Preview gets no response, no error message.
I saw a post in another thread suggesting that Slideshow "needs" a video card with officially supported GPU - is this true?
I am running an older Mac Pro, OSX 10.10.5, upgraded with 32GB RAM, SSD disks, etc., but with the original nVidia GT120 card (Adobe lists as "unsupported"), so I have unchecked "Use GPU Acceleration" (or whatever it's called) option in Lightroom. Everything else about the app seems to run fine.
I used to use Slideshow quite a bit, but haven't for at least the last few dot-updates of LR. Is there no way to use Slideshow anymore without a supported video card?
Thanks for any enlightenment...
Photo of John Lund

John Lund

  • 13 Posts
  • 1 Reply Like
Rikk, I appreciate that my issue is somewhat similar to this older thread, but when you merged topics, replies to my posting were cut off.

So to the person who replied "If "Zoom to Fit Frame" is checked, try unchecking it." - thanks, but I have tried with it checked & not - no difference.

Another person replied that this issue is not related to GPU support, must be some other issue - thanks, I will follow up.

Also, the Adobe tech note about supported GPUs does mention that the only area that uses GPU acceleration is the Develop module, so I am confused by Rikk's comment that "Slideshow depends on the GPU".

Testing further, I found success with same catalog run on my MacBook Pro (nVidia GT650M card) - Slideshow works normally. But I see that "use graphics processor" is enabled, so maybe that is the issue after all...