Lightroom 5.7.1 Now Available!

  • 2
  • Announcement
  • Updated 3 years ago
We are happy to announce the release of Lightroom 5.7.1.

This update adds further camera and lens support, including the Sony ILCE-A7M2, and bug fixes.

Release details:
Lightroom 5.7.1: http://blogs.adobe.com/lightroomjourn...

Note: Update Lightroom from the Creative Cloud Desktop Application by clicking "Install" next to the Lightroom 5 application listing (it won't show as "update". "Install" is the update process), or choose Help > Check for Updates.
Photo of Pete Green

Pete Green, Customer Advocate

  • 699 Posts
  • 126 Reply Likes

Posted 3 years ago

  • 2
Photo of Julian Watt

Julian Watt

  • 19 Posts
  • 0 Reply Likes
Don't know what it was meant to fix. but I haven't been able to get Lightroom to load since I updated to 5.7.
5.7.1 has the same problem. I have been on hold to Adobe Support for over an hour without anybody answering the phone and the hold music is appalling!
Not happy
Photo of Pete Green

Pete Green, Customer Advocate

  • 687 Posts
  • 115 Reply Likes
Can you start a new thread with the details of your system and the errors you're seeing Julian?
Photo of Julian Watt

Julian Watt

  • 19 Posts
  • 0 Reply Likes
Ok This will be the second time I have done that
Photo of Julian Watt

Julian Watt

  • 19 Posts
  • 0 Reply Likes
Am I able to download an older version of Lightroom (pre 5.7)
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13919 Posts
  • 1649 Reply Likes
I responded to you on your main thread.
Photo of Steven Hayre

Steven Hayre

  • 3 Posts
  • 0 Reply Likes
I updated to lightroom 5.7.1 then after the 1st use it would no longer load/start. I tried contacting adobe two different days, (got a case number each day) but never heard from adobe.......not happy. Finally I deleted 5.7.1 and reloaded 5.7 from my backup hard drive and everything is now fine. ADOBE, FIX 5.7.1 !!!!!!!
Photo of Fabien Dalino

Fabien Dalino

  • 1 Post
  • 0 Reply Likes
Still no support of OpenEXR :-/
Photo of Stan Clay

Stan Clay

  • 3 Posts
  • 0 Reply Likes
I just tried to update to 5.7 Lightroom and it deleted my in thr soft ware from the computer and I could not restore it. I may have to inter my original soft ware from the disk. What a mess. I was able to read my files from another computer.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13919 Posts
  • 1649 Reply Likes
Are you installing the update from the Creative Cloud application?
Photo of Stan Clay

Stan Clay

  • 3 Posts
  • 0 Reply Likes
No but I can not be sure because I have cc Photoshop on the computer too.
I own my own copy of Lightroom 5 and have been using it for some time before I loaded Photoshop. I still have my cd oh Lightroom 5.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13919 Posts
  • 1649 Reply Likes
If you have the perpetual version of LR installed, you should install the update from here:

Mac: http://www.adobe.com/go/lightroom_5_u...
Win: http://www.adobe.com/go/lightroom_5_u...

Installing from CC app should work as well, but it will switch your installed version to CC licensing. You can always reinstall the perpetual version later if you like.
Photo of Stan Clay

Stan Clay

  • 3 Posts
  • 0 Reply Likes
I reloaded using the link you suggested it took over one hour to download. Then went throug the install process. It now works properly. What a mess upgrading the entire soft ware for an update in ever bloating software on all of the products.
Thanks for your assistance it never comes from aadopie
Photo of Jonathan Fong

Jonathan Fong

  • 3 Posts
  • 0 Reply Likes
Hi Pete,

I just wanted to let you know its disappointing that this update doesn't show up as an update! Defeats the purpose of the creative cloud, ya know??

I've been waiting for a while for the 24mm STM lens profile, and wasted time tonight in the forums trying to find out where to ask for it, only to stumble upon realizing its already available in this update.

I'm at version 5.7 and even when I double-checked to see if I was up-to-date, I was led astray. ("Help" menu -> Check for updates).

Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 3093 Posts
  • 483 Reply Likes
Jonathan, have you tried logging out your Creative Cloud app and then logging it back in to see if you can get the 5.7.1 update to show?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13932 Posts
  • 1653 Reply Likes
Note - If the update is available in the CC app, it will say [Install] not update. This is a limitation of the different install technology that Lightroom uses.
Photo of Jonathan Fong

Jonathan Fong

  • 3 Posts
  • 0 Reply Likes
Thanks for the tips, Rikk and Jeffrey. Last night, after seeing the announcement, I ended up going with the "Install" button method using the CC app. I'll give logging in and out of the CC app a try with the next update.

Can I leave feedback that there is room for improvement here? In terms of how I know there's an update available, my options look like:

  • "Help" menu -> check for updates - doesn't work (!)

  • CC App - might work, but no notification or clear UI flag like with PS, AI, etc. Have to counter-intuitively choose "Install"

  • Check forums/here - manual process

  • Wait for announcements to hit more mainstream media (e.g. photography-related blogs) - not reliable for smaller updates like this.

Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13932 Posts
  • 1653 Reply Likes
Yes, it's something we plan to address: http://feedback.photoshop.com/photosh...
Photo of Greg Wigler

Greg Wigler

  • 4 Posts
  • 0 Reply Likes
Updated to LR 5.7.1 Now it will not open, says catalog is already open in another application. Also says to close other LR application, but there is no other LR application. So now I am stuck with an inoperable LR, that worked fine yesterday.
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2586 Posts
  • 323 Reply Likes
What happens if you reboot? Is there a .lock file in the catalog folder?
Photo of Greg Wigler

Greg Wigler

  • 4 Posts
  • 0 Reply Likes
I did a restart and a complete shut down, made no difference. Yes I see a .lock file
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2586 Posts
  • 323 Reply Likes
As long as LR is not running in any user session on the computer, then you can delete the .lock file.

This file is created when LR starts and is deleted when LR quits normally. This is to prevent a second user session from corrupting the catalog if the first user session hasn't quit LR, yet. In Windows you're allowed to Switch User without logging the previous user off, and this would cause a problem if both sessions tried to start LR and work with it at the same time.

Anyway, in your case it seems that LR was ended without being able to delete this .lock file so any subsequent startup gives an error.
Photo of Greg Wigler

Greg Wigler

  • 4 Posts
  • 0 Reply Likes
Thanks, that seems to have worked, except it went to a Dec backup file and I lost a couple of hundred photos. I see that the imported files are on the computer and will have to re import them to LR
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2586 Posts
  • 323 Reply Likes
Deleting a .lock file should have no effect on the catalog files, themselves, nor does updating LR.

If LR is remembering the last catalog opened, maybe it was one from December, but you should be able to find the more recent catalog file and open it. Search your hard drive for .lrcat files.
Photo of Greg Wigler

Greg Wigler

  • 4 Posts
  • 0 Reply Likes
It backed up the Dec one and lost the current one, but the pictures are still on the computer, just had to re import them. Thanks for the help!
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2586 Posts
  • 323 Reply Likes
Just to be clear for anyone else reading this, the LR 5.7.1 update wouldn't have removed the current catalog, so something else must have happened.
Photo of Michel de Rooij

Michel de Rooij

  • 3 Posts
  • 0 Reply Likes
Installed LR 571 from the CC app and because I bought a new camera decided to add a new catalogue. All my catalogues are stored on drive Y. So i made the new catalogue on that drive as per usual. But the moment I tried to open this catalogue with LR, I got that famous LR 4 message "Couldn't assert catolgue etc..." Restarted LR. Dialogue appears that it is checking catalogue integrity. Finds nothing and crashes. Tried to make another catalogue. Same story.
Reinstalled LR 5.6 and the new catalogue opened without a hitch. Only problem is that LR is now asking for a serial number. And I cannot find a way to hook it up to my CC subscription.
So... can i get a serial number please? I am a paying costumer and 571 should not never have been released.
I can accept small bugs in a program, we are talking about Adobe software, so should expect nothing else. But when it destroys my workflow I am less inclined to accept this kind shoddy coding.
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2579 Posts
  • 323 Reply Likes
There are two different LR flavors, one that is licensed via a serial number and one that is licensed via a CC login. You cannot hook up the serial-number-licensed LR to your CC subscription. All you can do is uninstall it and let the CC Desktop manager download 5.7.1, again, and install that. To get CC to install LR after uninstalling the serial-number-licensed version, you may need to log out of CC and log back in or even reboot.

And then we can work on the "cannot assert catalog" message, which I doubt is exactly those words, either.

And what type of media or location is drive-Y? LR catalogs can only be used on locally-attached drives, not network volumes. A drive letter so far down in the alphabet sounds like a network volume.
Photo of Michel de Rooij

Michel de Rooij

  • 3 Posts
  • 0 Reply Likes
True, "assertion failed" was the message, more or less
Photo of Michel de Rooij

Michel de Rooij

  • 3 Posts
  • 0 Reply Likes
Disk y is an internal disk. I named it thus. For convenience sake.
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2579 Posts
  • 323 Reply Likes
Have you tried all these potential solutions: http://camyx.com/tutorials/2014/04/fi...