Lightroom 2015.7+: Panels and filmstrip black when switching to Develop

  • 80
  • Problem
  • Updated 11 months ago
  • Solved
  • (Edited)
Not sure if this is the right place for a bug report, if not could anyone direct me to the right place please.

Clicking develop module at top right from the Library module opens the photo with film strip and both side bars black empty spaces. Initial few times I had to quit and restart Lightroom but then discovered switching to grid view again and develop keyboard short cut, everything comes back.
Photo of Ramaswamy Ravichandran

Ramaswamy Ravichandran

  • 4 Posts
  • 1 Reply Like

Posted 4 years ago

  • 80
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7535 Posts
  • 1726 Reply Likes
Official Response
This should now work correctly in Lightroom CC2015.10/6.10 or later on macOS Sierra (10.12) or later. Don't hesitate to let us know if you see the issue again on the current macOS, and if you do, what triggers it.  Please update your system and let us know if you have any additional issues. 

Additional information on this update can be found here:
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1738 Posts
  • 601 Reply Likes
Official Response
Hi Steve,

As noted before, this is a bug introduced at the macOS level. Through collaboration with Apple, they have made a fix in the later version of the macOS update. So the right thing to do is to update to the more recent version of macOS when possible.

Having said that, Lr team have done our best to workaround this issue for the cases that we can reproduce for macOS 10.11.6. But there is a limit can Lr can do.

Hope you understand the situation.
Photo of Melissa Rios

Melissa Rios, Lightroom Support Product Manager

  • 104 Posts
  • 26 Reply Likes
Official Response
Hi all,

As Simon and Jeff have already mentioned in this thread, please make sure your macOS is updated to at least macOS Sierra 10.12 and at least Lightroom Classic 7.0 or Lightroom 6.13.

The best combo to avoid this issue is being on macOS High Sierra 10.13 and Lightroom Classic 7.1 or Lightroom 6.13.

The team has worked pretty hard with Apple to get this issue to stop appearing with macOS Sierra 10.12 and macOS High Sierra 10.13. Improvements were made in 10.12 and iterated upon for 10.13.

If you are on macOS High Sierra 10.13 and Lightroom Classic 7.1 or Lightroom 6.13 and you still see this issue, please let us know here with a copy of the System Info from your Lightroom product (Help > System Info > Copy).