Lightroom 2015.2.1 unresponsive with Windows 10

  • 3
  • Problem
  • Updated 3 years ago
A few days ago I upgraded (?!) from Win 7 to windows 10. Lightroom immediately became unusable freezing and crasching ....on this forum I read that I should switch off the "grafics accelerator" ... after that it worked fine ...at least sort of ..I think it was slower than with Win 7 but it was stable and I could keep working.

Yesterday I updated to new Lightroom release ...now I have LR 2015.2.1 and now nothing works again ....it freezez up and is uselessly slow (FYI graffics accel is still in off) .

By the way the import window changed and now it seems I can no longer set imports to 1:1 ..... not that it will help as I can no longer review and classify my images anyway!

Please advice what I shall do I need immediate support as this seriously affects my photobusiness .... I need an immediate cure! Shall I move back to win 7 or what shall I do??
Photo of Sebastian von Wachenfeldt

Sebastian von Wachenfeldt

  • 3 Posts
  • 0 Reply Likes
  • frustrated

Posted 3 years ago

  • 3
Photo of John R. Ellis

John R. Ellis, Champion

  • 3589 Posts
  • 928 Reply Likes
There are numerous problems introduced by CC 2015.2, many of which were not resolved with 2015.2.1. Adobe has apologized for the situation: http://blogs.adobe.com/lightroomjourn.... But meanwhile, if you need to get work done, Victoria Bampton and other experts recommend reverting back to 2015.1.1: http://www.lightroomqueen.com/how-do-.... Wait until Adobe cleans up the mess, and let others do the beta testing.

With the graphics processor disabled, it appears 2015.1.1 runs well for most people on Windows 10.