Lightoom: LR4.4 Facebook publish plugin no longer authorises or retrieves albums or update published collections (OSX 10.8.4)

  • 34
  • Problem
  • Updated 5 years ago
  • Acknowledged
  • (Edited)
LR 4.4, OS X 10.8.4
After the infamous facebook Tuesday night update the Facebook publish plugin no longer works.

LR will not display a fb album list, cannot create albums or publish new photos to existing albums. Editing Collection settings will no longer authorise and returns error "Can't save changes: Authorizing"

Sometimes states error "Cannot retrieve facebook album list", plugin also fails and needs reloading, diagnostics file contains :

Plug-in error log for plug-in at: /Other App Links/Imaging/Adobe Apps/Adobe Photoshop Lightroom 4.app/Contents/PlugIns/Facebook.lrplugin

**** Error 1

An error occurred while attempting to load this plug-in’s portion of the Export dialog.
?:0: attempt to index upvalue '?' (a nil value)

I have reloaded an earlier backup of the plugin to make sure it was not corrupted.

Several users have posted about this error on the Adobe community forum http://forums.adobe.com/community/lig...

Removing authorisation and plugin from fb does and reauthorising does not resolve this problem!

Tested also in LR Beta 5, same problem!!!
Photo of Mark Callf

Mark Callf

  • 4 Posts
  • 1 Reply Like

Posted 7 years ago

  • 34
Photo of Lance Zielinski

Lance Zielinski

  • 1 Post
  • 0 Reply Likes
Started this week. Awaiting update from Adobe for a fix?
Photo of Alan Gross

Alan Gross

  • 3 Posts
  • 0 Reply Likes
I'm also having this same issue, started the fourth or fifth, I think something has changed on the Facebook side.
Photo of Alan Gross

Alan Gross

  • 3 Posts
  • 0 Reply Likes
For the record I've removed authorization and reauthorized several times, it also fails in Lightroom five beta.
Photo of RonBoyd

RonBoyd

  • 3 Posts
  • 0 Reply Likes
Nothing I have tried has helped either. Very irritating.
Photo of John Brassil

John Brassil

  • 2 Posts
  • 0 Reply Likes
I have this same problem, both on my LR 3.2 at work and 4.4 at home - this is definitely on the Facebook side. Publishing through FB directly sucks, let's hope they get this fixed soon.
Photo of Roy Harwood

Roy Harwood

  • 1 Post
  • 0 Reply Likes
This has started happening on Lightroom 5beta this week for me 2 weeks ago it worked fine and now will not. Not happy
Photo of Charlie Robinson

Charlie Robinson

  • 2 Posts
  • 0 Reply Likes
Having the same problem can't even get the facebook publishing service setup as it will not create a album, although I see the newly created album in Facebook Lightroom gets no info back to say it was created.
Photo of Jay Loden

Jay Loden

  • 4 Posts
  • 0 Reply Likes
Same here, I'm guessing something changed in the Facebook API and it's no longer compatible with LightRoom's plugin. Hope this gets fixed soon as I use the Facebook export all the time.
Photo of Chris Swinney

Chris Swinney

  • 5 Posts
  • 0 Reply Likes
Same issue here - Just upgraded to 4.4 and initially had the CryptUnprotectData Error using Facebook Plug-in. Managed to resolved this via editing the preferences file, but now cannot select an album in Lightroom. New Albums are created in Facebook when I hit the "create new Album" button in Lightroom, but I still can't select and album or save changes to my setup.

I have tried removing the Lightroom app from my Facebook, and re-authorising,which all seems to go OK, but still no luck on selecting an album to be able to upload any images.
Photo of Steve Rowland

Steve Rowland

  • 1 Post
  • 0 Reply Likes
I too can no longer upload to FB from Lightroom 4.4. It was Ok last weekend but errors with the message "No Facebook album assigned to collection"
Photo of Amy Olszak

Amy Olszak

  • 1 Post
  • 0 Reply Likes
I am having the same issue. Lightroom says no album is connected when it was previously working fine. It was, however, creating empty albums on Facebook. FB and LR are not talking to each other. Very frustrating. I have spent a couple hours trying to disable, re-enable, etc. I give up and impatiently await someone's resolution.
Photo of Brent Wilson

Brent Wilson

  • 2 Posts
  • 0 Reply Likes
Same problem...creates an album on Facebook but LR still shows message Album not selected...existing or newly created show up. Spent 3 days trying to figure out if its my Facebook or LR settings...
Photo of Brent Wilson

Brent Wilson

  • 2 Posts
  • 0 Reply Likes
Sorry meant to type...existing or newly created albums show up on Facebook side but not on LR setup side.
Photo of belfastbiker

belfastbiker

  • 2 Posts
  • 0 Reply Likes
Same issue here.
Photo of kyle carter

kyle carter

  • 1 Post
  • 0 Reply Likes
Ive been following this thread for about 24 hours.. while exporting and uploading jpeg files manually..

Not enjoying this.. I miss the integration.
Photo of Brett N

Brett N, Official Rep

  • 2260 Posts
  • 123 Reply Likes
Yep, definitely seeing this problem on our side as well. I'm noticing some major changes on the Facebook side of things, a very different authorization screen (I only see this screen when working with LR5, older versions just load up the Facebook news feed). Since there have been no changes to Lightroom 4 (since the 4.4 update. I also tested with LR3 and see the same behavior) we can be sure the issue is on the Facebook side of things. This means we are going to need to get their current SDK's, update our plug-in, test, and release. Not sure how long all of this will take.
Photo of Alan Gross

Alan Gross

  • 3 Posts
  • 0 Reply Likes
Thanks for the response
Photo of Heather Rutherford

Heather Rutherford

  • 1 Post
  • 0 Reply Likes
Any word on the progress related to this issue?
Photo of Jay Loden

Jay Loden

  • 4 Posts
  • 0 Reply Likes
Thanks for looking into it Brett, and I'm really glad to hear Adobe is on the case. Looking forward to an update hopefully :)
Photo of Rhalene DeGraff

Rhalene DeGraff

  • 1 Post
  • 0 Reply Likes
Glad to hear that it's not on my end. Had issue with LR4 and had to call support. They updated to version 4.4 and all of a sudden this same issue started. Hope the fix comes soon as it's so much easier to work through Lightroom.
Photo of Tim Wolf

Tim Wolf

  • 1 Post
  • 0 Reply Likes
Had all the same issues with LR 4.4 and decided to try switching plugins. Downloaded and installed J. Friedl's "Export to Facebook" LR plugin after I ntoed that his most recent update was 6/10/13. It works fine and offers additional features that the Adobe plugin does not, such as ability to publish my photo captions. The plugin is donationware, but runs free for a trial period--perhaps long enough to get us through to a fix on the other plugin--and when you are asked to register he'll take a penny as minimum payment.
http://regex.info/blog/lightroom-good...
Photo of Chris Swinney

Chris Swinney

  • 5 Posts
  • 0 Reply Likes
Just re-tried this in Lightroom 4.4 with the standard Adobe Plugin and all worked as expected. I assume there has been a chnage on the Facebook side as I have applied no update to Lightroom.
Photo of Jay Loden

Jay Loden

  • 4 Posts
  • 0 Reply Likes
Odd... I am seeing no difference this morning, so I'm not sure why it worked for you Chris.
Photo of RonBoyd

RonBoyd

  • 3 Posts
  • 0 Reply Likes
Funny, when I try to reload the Plug-in, I get to the point of "Authorizing" and get a message from Facebook informing me that "Something went wrong. We're working on getting it fixed as soon as we can."
Photo of Chris Swinney

Chris Swinney

  • 5 Posts
  • 0 Reply Likes
@RonBoyd,
Try remove the Lightroom app from Facebook, then go through the full app authorisation again. I know you have probably done this previously, but its the only thing I can think of.

BTW, I did NOT do this today (although did try a week ago). It simply started working today with no additional work from me.
Photo of RonBoyd

RonBoyd

  • 3 Posts
  • 0 Reply Likes
Same result.
Photo of Charlie Robinson

Charlie Robinson

  • 2 Posts
  • 0 Reply Likes
I can also confirm that it is working again with no changes. Also I did not need to go to facebook and remove the lightroom app. It Authorized and allowed me to select a album which in turned allowed me to save the settings and start publishing.