Lightoom: LR4.4 Facebook publish plugin no longer authorises or retrieves albums or update published collections (OSX 10.8.4)

  • 34
  • Problem
  • Updated 3 years ago
  • Acknowledged
  • (Edited)
LR 4.4, OS X 10.8.4
After the infamous facebook Tuesday night update the Facebook publish plugin no longer works.

LR will not display a fb album list, cannot create albums or publish new photos to existing albums. Editing Collection settings will no longer authorise and returns error "Can't save changes: Authorizing"

Sometimes states error "Cannot retrieve facebook album list", plugin also fails and needs reloading, diagnostics file contains :

Plug-in error log for plug-in at: /Other App Links/Imaging/Adobe Apps/Adobe Photoshop Lightroom 4.app/Contents/PlugIns/Facebook.lrplugin

**** Error 1

An error occurred while attempting to load this plug-in’s portion of the Export dialog.
?:0: attempt to index upvalue '?' (a nil value)

I have reloaded an earlier backup of the plugin to make sure it was not corrupted.

Several users have posted about this error on the Adobe community forum http://forums.adobe.com/community/lig...

Removing authorisation and plugin from fb does and reauthorising does not resolve this problem!

Tested also in LR Beta 5, same problem!!!
Photo of Mark Callf

Mark Callf

  • 4 Posts
  • 1 Reply Like

Posted 5 years ago

  • 34
Photo of Pete Green

Pete Green, Customer Advocate

  • 699 Posts
  • 126 Reply Likes
Official Response
Hey all,

Try out these suggestions from the Lightroom side while we wait for a fix on the FB side.

http://helpx.adobe.com/lightroom/kb/e...

We will also have some updates coming in LR5.2 update that will help as well.

Regards