Library Filter in LR4 bahaves differently?

  • 1
  • Problem
  • Updated 6 years ago
I normally, select "All Photographs" in the catalog and use the Library Filter to filter out the photos I want to work on.

In LR4, when I select "All Photographs", the Library Filter reports 0 Dates, 0 Cameras, 0 Lenses, etc.

The photos ARE there, as I can see them when I select a folder, or when I select an Attribute in the Filter.


Am I missing a setting somewhere or is this a LR4 issue?
Photo of Albert Debruijn

Albert Debruijn

  • 3 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 1
Photo of Benjamin Warde

Benjamin Warde, Employee

  • 483 Posts
  • 71 Reply Likes
Hi Albert,

First try this:
Go to the Map module, set the location filter to None and then go back to the Library module and try again.

If that does't work, I would suggest that you try throwing out your Lightroom preferences files. The locations of the preferences files on Win and Mac are described here:

http://kb2.adobe.com/cps/843/cpsid_84...

Throw out all Lightroom preference files (for Lr3 and Lr4, and earlier, if any) that you find in the Preferences folder. As noted in the instructions at the link above, make sure you're not throwing out your Lightroom catalog file (the catalog file has the extension "lrcat").

After throwing out your preferences file, depending on what your Lightroom catalog is called and/or where it's located, you may need to tell Lightroom where it is when you relaunch.

Let me know if this helps.

-Ben
Photo of Albert Debruijn

Albert Debruijn

  • 3 Posts
  • 0 Reply Likes
I found a "workaround" so I'm good now, although no idea what the original problem was.

I run Windows 7 on a 64 bit Core 2, 4 CPU machine with 8GB ram.

This is what I did:
Installed LR 4 and had it upgrade my catalog (some 49000 images).
I am not 100% sure when I first noticed the issue of not seeing my images.

I "fixed" my problem by creating a new catalog and then doing an "import from catalog", from my converted catalog (the one that did not show my images when selecting "All Photographs").

After that, all was well.

By the way, I relaunched LR4 with that converted catalog and determined it still had the sam eproblem.
I also tried your suggestion of going to the map module, but the filter was already set to "none" (as I thought as I have not yet played with the Map module).

I did not try throwing out all preferences as I am good now. The new catalog seems to work fine.

Albert
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1385 Posts
  • 413 Reply Likes
Try go to the map module, set the location filter to None and then go back to the the Library module. This should reset the library filtering behavior. My guess is that you have the additional filtering set in the map module.
Photo of Albert Debruijn

Albert Debruijn

  • 3 Posts
  • 0 Reply Likes
Thanks, but did not work. Setting was already at "none".