Lightroom Classic: Library artifacts and banding

  • 1
  • Problem
  • Updated 2 weeks ago
  • (Edited)
When I import my pics, standard previews and smart previews are generated. I develop my pics just fine. But when I go back to the Library module, with some pictures only, the sky is full of artefacts (Fit screen). If I zoom in in 1:1 or higher, after recalculation, those artefacts desapear. But when I go back to Fit screen I see them again. I don't see them in Develop Module.

If I build again 1:1 previews, it does solve the problem. But it's not persistant.

And the worse part is when the collection is synced, I see on LR web the pic with the artefacts.

How could I avoid this ? How do I correct the situation in LR Web without having to resync everything ?

All the pics are coming from the same camera in raw and there is no crazy edit in the sky.

I did export a set of files as per your settings with :


  • sRGB
  • AdobeRGB 1998
  • Prophoto RGB
 All pics are fully clean pics.

I downloaded directly from LR web : artefacts as I see it in LR web

I deleted the preview file and the sync.lrdata. I rebuild the preview and started the sync again. Still the same problem, notting changed. 



Thanks for your help
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
  • frustrated

Posted 1 month ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5967 Posts
  • 1312 Reply Likes
Any chance you can share a screenshot or two showing the artifacts? 
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5967 Posts
  • 1312 Reply Likes
I really need to see what your screen looks like. 
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
a print screen from LR web
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
I would like to say again the banding is not visible in LR 1:1 or higher but only in fit screen and in LR web. Export pics are fully clean 
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5967 Posts
  • 1312 Reply Likes
And a screenprint of Library module showing the banding?
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
This from the desktop (MacOS) LR Classic
Photo of Ed Wolpov

Ed Wolpov

  • 9 Posts
  • 3 Reply Likes
Rikk, this has been happening forever! There are lots of posts complaining that one has to zoom to 1:1 in order to eliminate what looks like severe jpeg blockiness. For me, this seems to happen only when in the Library module, and it's inconsistent in that it only occurs randomly. It's most noticeable in the sky or where there's smooth tones. Once the 1:1 zoom is recalculated, the artifacts are gone... for a while, but they randomly return at a later time. 
Photo of Todd Shaner

Todd Shaner, Champion

  • 1563 Posts
  • 524 Reply Likes
The artifacts observed in the LR Classic Web synced smart previews are due to use of lossy DNG file format. You can test this by exporting images that exhibit artifacts in the Web album using the below LR Classic Export module settings. To be honest after looking through my 35,000+ images catalog for files with similar sky area I could only find two that exhibit artifacts when synced to the Web with LR Classic.

https://forums.adobe.com/message/5297705#5297705



To determine the cause (and a possible correction) I suggest exporting a few files that exhibit the artifacts to full-size DNG file format as shown below. The DNG file will contain your LR Develop settings to determine if that has some bearing on the issue. Please post them to a file sharing site and place the share links in a reply here.

Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1633 Posts
  • 548 Reply Likes
You'll see this type of artifact when the standard preview is generated based on Smart Previews or at higher pyramid levels (it explains when you zoom to 1:1 the artifact went away).

Try increase your preferred standard preview size from the Catalog Settings>File Handling>Preview Size>Standard Preview Size. If it is setting to Auto, the size is determined by the largest dimension of your attached monitor. The artifact could also be amplified by the type of extreme image adjustment he applied to the image when the standard previews are not generated from the full resolution negatives.
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
I understand what you saying. But in this case there is no special extreme edit.
If it was the case, there would be still visible in 1:1 or higher. It would be visible as well when I export with the publish service as a jpeg and it's not the case at all with any pictures. 

Any how this is a big problem for :
- simply view the pics in fit screen
- kills the LR web
- kills the possibility of sharing with LR web

In the catalog settings the preview are set to Auto and preview to high quality.
By downgrading one or both of them it will degrade the viewing quality.

what is the fix ?

Thank you all for your help 
Photo of Todd Shaner

Todd Shaner, Champion

  • 1562 Posts
  • 524 Reply Likes
Try increase your preferred standard preview size from the Catalog Settings>File Handling>Preview Size>Standard Preview Size.
Simon, does the Preview Size setting affect the file that is synced to the Web, which is where the artifacts are also visible?
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1633 Posts
  • 548 Reply Likes
Hi Todd, No. The standard preview size only affect the previews generated for the library.
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1633 Posts
  • 548 Reply Likes
But in this case there is no special extreme edit. If it was the case, there would be still visible in 1:1 or higher. It would be visible as well when I export with the publish service as a jpeg and it's not the case at all with any pictures. 
That would make sense because in these cases (1:1 and publish and export), the rendering always start with the full resolution negative (to ensure the highest quality but render slower). This kind of artifact is mostly occurring when the rendering is based on the Smart Previews (like the LrWeb case) or camera raw negative cache (in essence, Smart Preview likes)

Any how this is a big problem for :
- simply view the pics in fit screen
- kills the LR web
- kills the possibility of sharing with LR web
These are the cases where the renditions are rendered from the Smart Preview or the Camera Raw (negative) Cache.

There is no easy fix without performance implications. If image quality is your top priority, during import, set the preview option to generate 1:1 preview. Or do it 1-off for affected photos by quickly zooming into 1:1 to force generation of 1:1 preview for that photo.
(Edited)
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
This kind of artifact is mostly occurring when the rendering is based on the Smart Previews (like the LrWeb case) or camera raw negative cache (in essence, Smart Preview likes)
So to avoid this I deleted the file Smart Preview. right ?
No how do I force a resync with LR web ?


I'm quite unhappy about this situation as smart preview has been created to improve performance (not only) and now you are saying in order to be able to use Portfolio / Gallery etc I should not be using smart preview
Photo of Todd Shaner

Todd Shaner, Champion

  • 1562 Posts
  • 524 Reply Likes
So to avoid this I deleted the file Smart Preview. right ?
See this post for what I believe Simon is referring to:

Develop module preview differs from Library + Exported JPGs

If using Smart Previews with  "Use Smart Previews instead of Originals for image editing" selected in LR Preferences set OR the original file is offline you are looking at and working with a lossy DNG file. Uncheck that setting and make sure the original file is present AND create 1:1 Previews. This will "fix" the artifacts issue as observed in the Library module, but not the Sync to Web images since they are lossy DNGs and nothing you can do to change that. What you can do with those specific images that exhibit artifacts in a Web album is to instead create and sync rendered JPEG files for those specific image files. See my reply below outlining that workflow.
(Edited)
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
Thanks Todd, I will try this
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
If I understand you well I could “solve” the problem by :
- not using smart preview
- disabling the cash by setting it to minimum ?
Photo of Todd Shaner

Todd Shaner, Champion

  • 1550 Posts
  • 522 Reply Likes
As Simon Chen mentioned, "If image quality is your top priority, during import, set the preview option to generate 1:1 preview. Or do it 1-off for affected photos by quickly zooming into 1:1 to force generation of 1:1 preview for that photo."
- disabling the cash by setting it to minimum ?
I assume you mean the camera raw cache,. It is only used in the Develop module so not a source of this issue. Setting to a low value is only going to cause performance issues in the Develop module. If anything increase the camera raw cache size to 20-50 GB.

Also as Simon Chen mentions, "No. The standard preview size only affect the previews generated for the library."

As mentioned the smart preview file is a lossy DNG file with fixed size of 2560 pixels long edge and NO user adjustable settings. If you're seeing artifacts in a LR Classic Web synced image file there's no much you can do.
What does appear  to work is to export the raw file to JPEG file format using the below settings and then sync the JPEG file to the Web. With your Speloncato-7501178.NEF and the XMP file settings applied I see no artifacts in the sky. It's not an ideal solution and I can't even explain why it works, but it does. As long as you have no intentions on applying Web edits to the file there shouldn't be any issues. A side benefit is that the synced JPEG file with Screen Standard Export Sharpening applied appears sharper than the synced raw file.

(Edited)
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1632 Posts
  • 545 Reply Likes
@Todd One correction, the Smart Preview is a lossy DNG file with fixed size of 2560 pixels on the long edge.
Photo of Todd Shaner

Todd Shaner, Champion

  • 1550 Posts
  • 522 Reply Likes
Thanks Simon, correction noted and changed in my post. That's what I had always thought in the past, but Web downloaded JPEGs are always 2048 px long edge. Is that an arbitrary download size determined to be more useful due to social media posting size limits (i.e. Facebook is 2048 long edge maximum)?
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1632 Posts
  • 545 Reply Likes
2048 px is the JPEG render size. The 2560px for Smart Preview is to provide some slack for possible cropping during develop.
(Edited)
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
I did realise that the same problem occurs with the Apple TV. Which is fully understandable as it's coming from the same source, LR web.

So this problem makes the real utility of Creative Cloud questionnable not to say useless...
Of course, as Todd mentioned I still could export the pics and upload them.
Yes but not good for the workflow and since I have to export them to my HD I could very well upload them somewhere else.

So I hope you are going to fix this problem ASAP because I like the idea of how it should work.

In the meantime, long story short, the problem is coming from smart preview.
They are only good for development for keeping LR speedy, and that works like a charm.

But after that I should delete them and rebuild 1:1 previews ?
LR web is using the standard size or the 1:1 if it exist ?

From what I saw when a pic is rebuild it does not resync to LR web. 
How can force it without un sync the collection and sync it again ?

thanks







Photo of Todd Shaner

Todd Shaner, Champion

  • 1550 Posts
  • 522 Reply Likes
But after that I should delete them and rebuild 1:1 previews ?
LR web is using the standard size or the 1:1 if it exist ?
As Simon Chen mentions for best results you should build 1:1 Previews before syncing image files to the Web. The Web Smart Previews are created automatically and there's no need to delete them.

From what I saw when a pic is rebuild it does not resync to LR web. 
How can force it without un sync the collection and sync it again ?
If you apply ANY Develop setting to the image files they will resync automatically. You could also select all of the image files in the collection except for one, delete them, and then use CTRL + Z Undo to restore them. Once completed delete the one image file not updated and use CTRL + Z Undo to resync it. This way if the collection is shared the share link URL does not change. Following this procedure or simply deleting the whole collection and restoring takes the same amount of time. Make sure to build the 1:1 Previews before performing this resync operation. Once completed you can delete the 1:1 Previews if not need for local LR review purposes.
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
Sorry it just doesn't work. No more smart preview. The pic on LR web is still with banding.
As previously said the 1:1 preview rebuild is not persistant.

Just to make sure I got the resync pic in LR web, I converted to B&W.
Photo of Todd Shaner

Todd Shaner, Champion

  • 1550 Posts
  • 522 Reply Likes
What I meant was you should build 1:1 previews to insure the best possible uploaded smart preview. I didn't mean to say that would "fix" the issue with specific image files. Like I said I see very few images synced to the Web that display these artifacts. If you're seeing a LOT of image files with this issue there may be other things causing it (camera or LR settings). If just a few image files have the issue export to JPEG as I suggested is the only solution currently for LR Classic. Using LR Desktop with the Mobile and Web apps shouldn't exhibit this issue since full-size original files are uploaded to Cloud storage. Adobe has made it clear that no new Web features will be added to LR Classic since the primary focus is on improving the LR Desktop app.
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
Settings and camera are definitely not the source of the problem as there is no artefacts in 1:1
Yes just a few pics, not all
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1633 Posts
  • 548 Reply Likes
One possible workaround to increase the rendered image quality on LrWeb/LrTV is to use the LrDesktop (not LrClassic) for syncing the relevant assets. LrDesktop will sync the original raws to the cloud and therefore LrWeb/LrTV would be able to generate higher quality renditions than LrClassic where only the Smart Previews are synced.
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
Ok thanks but that might help the web part.
It doesn't solve the problem in LR Classic. The banding in Fit is visible. And as said before, the 1:1 works just fine but it's not persistant in FIT.

My feeling is if I solve the problem in LR Classic, it would clearly solve the web side.
Because my problem is no a quality problem but a banding.

So my priority is to solve the LR Classic.

Thanks for your help
Photo of Todd Shaner

Todd Shaner, Champion

  • 1562 Posts
  • 524 Reply Likes
It doesn't solve the problem in LR Classic. The banding in Fit is visible. And as said before, the 1:1 works just fine but it's not persistant in FIT.
I'm not seeing any artifacts in the Library module or Develop module at Fit Zoom View with your Speloncato-7501178.NEF file and XMP file settings. In LR Preferences> Performance try unchecking 'Use GPU for Display.' Restart LR, Zoom to 1:1, and back to Fit view. Do you still see the artifacts inside LR Classic? If so post a screenshot like below of what I'm seeing.
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes

Grid
(Edited)
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes

Grid
(Edited)
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes

Fit screen
(Edited)
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
As said before no problem in 1:1 or higher
Photo of Todd Shaner

Todd Shaner, Champion

  • 1562 Posts
  • 524 Reply Likes
That's a different NEF file than the one you posted to Dropbox, which does NOT exhibit artifacts on my system as shown in my screenshot. Please post this NEF to Dropbox with an XMP settings file and I'll check it.

From your most recent screenshots it looks like you have a graphics card issue. Did you try unchecking 'Use GPU for Display.' In LR Preferences> Performance as shown below, restart LR, Zoom to 1:1, wait for build, Zoom back to Fit?

Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
Since the last pic I did some cleanup as posted :
- delete smart preview
- delete preview
- delete sync.lrcat
- build standard size preview

So the problem is not persistant, and is "moving" to different pics.
This one doesn't have a smart preview.

In my opinion if it was a GPU problem, it would affect many more pics.
But yes I did try unchecking it. Actually when I started to post to the forum it was unchecked. I checked it again.
I have a 5K iMac 2017 with a Radeon Pro 575 4GB 
Photo of Todd Shaner

Todd Shaner, Champion

  • 1562 Posts
  • 524 Reply Likes
So the problem is not persistant, and is "moving" to different pics.
The most likely cause of the "moving" target issue is a corrupted preview cache.


Go to Edit> Catalog Settings> General> Show and navigate to the LR Catalog folder. Next close LR and rename the Lightroom Previews.lrdata folder Lightroom Previews.lrdata.HOLD. Launch LR and check files with the banding issue again inside LR Classic by Zooming to 1:1, wait for 1:1 Preview to build, and then Zoom back to Fit view. Is the banding still present?
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
as I just said I deleted all even the cash files (I forgot to mention in my previous post)
Moving might not be the proper word. But since the deleting, different pics are showing the problem.

I tried with and without smart previews as well.
Photo of Todd Shaner

Todd Shaner, Champion

  • 1562 Posts
  • 524 Reply Likes
Do you use a monitor calibrator to calibrate your display? You may have an incompatible or corrupt display profile. Try setting the display profile to sRGB as outlined at the below link.

https://www.lightroomqueen.com/how-do-i-change-my-monitor-profile-to-check-whether-its-corrupted/
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
Switching from display profile doesn't affect the banding.
I always calibrate my mac's from day one.
I tried by switching to the original profile or any other in the list and back to my profile.
No change at all regarding the banding.
The only thing afcting the banding is the 1:1

I did upgrade LR today to 8.4.1but no change
Photo of Todd Shaner

Todd Shaner, Champion

  • 1562 Posts
  • 524 Reply Likes
Stupid question and sorry for not mentioning this! Every time you change the assigned display profile LR must be restarted to load that new profile. Lacking the close and restart of LR it continues to use the original assigned display profile. If you did that and the banding remains the only thing left that I can suggest is to uninstall LR and reinstall LR 8.4.1 released today. You could also upload one of the NEFs with an XMP settings file for further checking on my system.
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
ah ok, I didn't know.
I could clearly see the change in LR with contrast etc from one profile to another 
but not change about the banding.
I'll try again by restarting LR.

What I do know is this :

- develop with smart preview for performance.
- once done, remove the smart preview

With the last pic I posted the print screens here, it clearly improve the quality by reducing the banding, but it's not up to the quality in 1:1.

You very well know that this problem is a very old one which was completely killed.
Forums are full of that.
In the Develop module I see the banding when I just switch into it but I reduce the banding by itself and then I have to go into 1:1 to have a clean pic.

I find out another problem ( I will open a specific post for it).
In those deep skies I could see some kind of round banding. But they disappear with a reset. Long story short, the problem is coming from the "enable profile correction".
Problem only visible with deep dark sky.






Photo of Todd Shaner

Todd Shaner, Champion

  • 1562 Posts
  • 524 Reply Likes
You very well know that this problem is a very old one which was completely killed.
Forums are full of that.
No I don't know that! Please provide links to some sample posts discussing the problem. Like I said I'm not seeing the issue with the one NEF and XMP file pair you provided using LR Classic 8.4.1. Perhaps you can provide the NEF and XMP file used for the screenshots in your last post. That might help to identify something.

I find out another problem ( I will open a specific post for it).
In those deep skies I could see some kind of round banding. But they disappear with a reset. Long story short, the problem is coming from the "enable profile correction".
That sounds like this issue: https://console.getsatisfaction.com/photoshop_family/conversations/circular-banding-in-shadows-with-...

The solution is to apply Luminance Noise Reduction at 1:1 Zoom view until the noise is significantly reduced. If you've already done that then this is just another variance of the issue being discussed here with the solution remaining to be determined.
If you haven't done so already I suggest uninstalling LR Classic and do a full reinstall (not update) of LR 8.4.1.
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
In fit screen, how come do I have a different result between Library and Develop ?
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1633 Posts
  • 548 Reply Likes
Because Develop always load and render from the full resolution negative.
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
well if there is no more smart preview, Library should (and can only) do the same thing ?
Photo of Jerry Syder

Jerry Syder

  • 328 Posts
  • 145 Reply Likes
The way this feature was implemented(I believe), is that once selected in preferences, LR would generate a 'smart preview' size preview and use that, regardless of whether or not you chose to create smart previews on import.
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1633 Posts
  • 548 Reply Likes
That is where the presence of the Camera Raw Cache (Lightroom>Preferences>Performance>Camera Raw Cache Settings (for DNG it is the embedded Fast Load Data) is used for in the absence of Smart Previews. Those essentially serves the same purpose as 'Smart Preview'.

Photo of Jerry Syder

Jerry Syder

  • 328 Posts
  • 145 Reply Likes
And the same when 'Use Smart Previews instead of Originals for image editing' is selected under Lightroom>Preferences>Performance>Develop, right?
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
so in Develop I see Full res raw + correction stored in the catalog
in Library I see Raw from the cache ?

What I found out is that rebuilding 1:1 doesn't help the fit view in Library

So it means the source of the problem for Library is coming from the corrupted cache ?

But as said previously I deleted the cache, previews and smart preview and it dint solve the problem.
I will do it again

What I do know in my workflow is :
  1. build smart preview
  2. develop the pic 
  3. delete smart preview
Does it make sens ?
Photo of Todd Shaner

Todd Shaner, Champion

  • 1562 Posts
  • 524 Reply Likes
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
@Todd yes I did.
But is not my situation other than it's more visible with the thumbnail in the library. The pic was taken @ 100 ISO so no specific noise.
And I'm able to see the circular artefact with no edit yet.
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
That is where the presence of the Camera Raw Cache (Lightroom>Preferences>Performance>Camera Raw Cache Settings (for DNG it is the embedded Fast Load Data) is used for in the absence of Smart Previews. Those essentially serves the same purpose as 'Smart Preview'.
So it means that in the Library module we see the cache file in FIT and not the Standard Size Preview ?

Photo of Todd Shaner

Todd Shaner, Champion

  • 1562 Posts
  • 524 Reply Likes
We're in thrashing mode here trying to resolve more than one issue! Make sure you are NOT using Smart Previews by having the original files offline OR by enabling "Use Smart Previews instead of Originals for image editing" selected in LR Preferences. Are you still seeing the artifacts with this criteria? If so post the raw file and XMP settings file to a file sharing site so we can check it on our systems. Lacking that we are running around in a circle of confusion.
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
the link for the circular banding problem
https://www.dropbox.com/sh/8b5w7eokngtcg6c/AAAr4kY32mxPMRgiNzknInvNa?dl=0

The best way to see it is with the print screen of the thumbnail.


Photo of Todd Shaner

Todd Shaner, Champion

  • 1550 Posts
  • 522 Reply Likes
I see NO banding or other artifacts in any of the Limassol-7502277 image files on my system using LR 8.4.1. Since I'm not seeing the artifacts this has to be an issue with your graphics card,  monitor, or LR installation. What OS, system model, graphics card, monitor calibrator, and display are you using? Also did you try a LR uninstall and reinstall of LR 8.4.1?
(Edited)
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
don't tell me you don't see the the circular banding on the thumbnail
The smaller the better to see it
have you used the xmp ?
(Edited)
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
Yes and I even went back to 8.3.1
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
Photo of Todd Shaner

Todd Shaner, Champion

  • 1550 Posts
  • 522 Reply Likes
don't tell me you don't see the the circular banding on the thumbnail
The smaller the better to see it
have you used the xmp ?
No, there is no banding or any other artifacts in the thumbnail file or NEF file with your XMP settings applied on my system. I also viewed the files on a Windows 7 system that has a TFT 6bit+FRC monitor that should be much more prone to exhibiting smooth gradient banding. No banding or other artifacts were observed so that's two systems that don't exhibit the issue.




I noticed that your Limassol-7502277.NEF file has a large number of Spot Removal Heal spots. That shouldn't cause any issues, but it's not apparent WHY you're applying them. With them removed I don't see any dust spots or anything other than clear sky in the Heal areas. As a test try resetting the Spot Removal tool to remove all of the Heal spots, switch to the Library module and Zoom to 1:1, and see if the banding is still visible at Fit view. If so you may have a defect in your graphics card or display. Try connecting an external monitor and see if it shows the same banding. Better yet find a friend or relative who also has LR Classic and have them view the files.
Photo of Todd Shaner

Todd Shaner, Champion

  • 1550 Posts
  • 522 Reply Likes
I was able to produce circular banding in the Library module Fit view by resetting the Develop module Noise Reduction panel to its default settings. However, after zooming to 1:1 view and allowing the preview to be rebuilt the banding was no longer present. Not sure what this indicates since when you zoom to 1:1 and back to Fit view the banding is still visible. Just an FYI. Is this what you're seeing:
(click on image to see full-size)
Photo of Jao van de Lagemaat

Jao van de Lagemaat

  • 211 Posts
  • 70 Reply Likes
Try turning off the lens corrections. The circular banding you sometimes see is due to lens corrections, especially the vignette corrections. The banding is caused by numerical precision not being high enough even in the 16-bit math applied in Lightroom.
Photo of Todd Shaner

Todd Shaner, Champion

  • 1550 Posts
  • 522 Reply Likes
Jao, the issue is that I'm NOT seeing the banding using his NEFs and XMP settings file. It may be a Mac only issue as I've only checked his image files using LR 8.4.1 on Windows 10 & 7. Do me a favor and check the files on your Mac system he posted here. Thank you!

the link for the circular banding problem
https://www.dropbox.com/sh/8b5w7eokngtcg6c/AAAr4kY32mxPMRgiNzknInvNa?dl=0

The best way to see it is with the print screen of the thumbnail.

Here's another NEF and XMP file he posted concerning using Smart Previews and upload to the Web. We know why that's happening (lossy DNG), but he's also seeing the banding in the Library module at Fit view with the original NEF fle and NO Smart Preview present.

https://www.dropbox.com/sh/8b5w7eokngtcg6c/AAAr4kY32mxPMRgiNzknInvNa?dl=0
Photo of Robert Somrak

Robert Somrak, Champion

  • 398 Posts
  • 133 Reply Likes
I am not getting any banding on my 27inch Retina iMac either using the uploaded NEF with edits.
(Edited)
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
Thank you for your help

Spot removal :

Todd, I use Spot removal because there plenty of spots and not for fun...
Yes there are not easy to see in FIT but very visible in 2:1 or by activating in the tool bar "visualize spots". I did something crazy by cranking dehaze for you to see them 


Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
I was able to produce circular banding in the Library module Fit view
What you got is EXACTLY my problem number 1, the reason why I open the post.
On certain pic I get this artefacts, as you did. They disappear in 1:1 or higher and with export.
The problem is the same with or without smart preview. 
Collateral damage :
- not possible to view image in Library
- not possible to have clean image in LR Web
- not possible to have clean image in LR AppleTV
- not possible to have clean image in Portfolio
- not possible to have clean image in LR Mobile



Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
I would like to repeat the following :
- rebuild the 1:1 only helps on the spot. If you quite this pic for another one and come back to it, I've the artefacts again
- once the pic is developed I delete the smart preview
- I delete all the preview file and rebuild them from scratch. Same thing with the cash folder

All this didn't help
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
Circular banding

Same thing, to make it obvious, I cranked up dehaze.


As said before, it's visible on the thumbnail il Library, smaller the best to see it
Photo of Todd Shaner

Todd Shaner, Champion

  • 1551 Posts
  • 522 Reply Likes
The blocky artifacts in your screenshot with Dehaze cranked up is expected with very high settings. What I showed you in my screenshot is traditional stair-step banding , which is not visible in the above screenshot.

There's a very good possibility this issue is unique to a specific OS X version update specifically concerning Metal GPU support. That's why I suggested testing a few image files on a friend or relatives Windows and Mac system. However, Robert Somrak says, "I am not getting any banding on my 27inch Retina iMac either using the uploaded NEF with edits." So we have at least one Mac user who isn't seeing the artifacts."

One last thing to try is to reset LR Preferences file, which survives an uninstall/reinstall and may be corrupted.

https://www.lightroomqueen.com/how-do-i-reset-lightrooms-preferences/
(Edited)
Photo of ChrisB63

ChrisB63

  • 38 Posts
  • 0 Reply Likes
ok... That doesn't help.
There are very visible. I did crank up for you to see them.
On a 5K retina they are very visible and that is why I open this ticket.
If you don't see them, that is not going to help me.
Photo of Todd Shaner

Todd Shaner, Champion

  • 1551 Posts
  • 522 Reply Likes
Robert Somrak also has a 27" Retina iMac and he doesn't see the banding issue. Did you try the LR Preferences file reset and restart of LR to load the new file? If you tried all of my troubleshooting suggestions then I suspect at this point you have a manufacturing defect in your iMac's Retina display electronics. That's why I suggested trying an externally attached monitor to see if that might be the case. It doesn't matter if the monitor isn't 5K since the banding should be visible on any display. If this were a LR issue due to an update there would be many other posts complaining about the same issue. There are none here or in the Lightroom Classic forum.