Lens incorrectly identified since LIGHTROOM 6.3 update

  • 1
  • Problem
  • Updated 2 years ago
  • In Progress
  • (Edited)
Since updating to Lightroom 6.3, I noticed that the wrong lens profile is being applied to newly imported photos.

Prior to 6.3, the lens was correctly identified as:
Sigma 50mm F1.4 DG HSM A014

Since 6.3, the lens is being identified as:
Zeiss Milvus 1.4/50

(I notice that the Zeiss is one of the new profiles added in 6.3)

This error affects both the Lens Corrections panel of the Develop module, and the Metadata panel of the Library module.

I can manually correct the develop settings, but cannot see a way to correct the metadata, which I use for searching and grouping images.

I rolled back to 6.1.1 (again), so at least new photos are imported with the correct profile But for the hundreds of images that have already been assigned the incorrect profile, I haven't been able to find a solution. Removing and reimporting does not help, as the incorrect lens profile has been embedded in the xmp file. Deleting the xmp files is not really an option, as I would then lose all the edits.
Photo of Tom Williamson

Tom Williamson

  • 13 Posts
  • 6 Reply Likes

Posted 3 years ago

  • 1
Photo of Chris Castleberry

Chris Castleberry, Camera Raw Engineer

  • 345 Posts
  • 97 Reply Likes
Hi Tom,

Thank you for reporting this. The issue is caused by both lenses sharing the same lens ID. We have a solution in the works for a future update of Lightroom and Camera Raw. In the meantime, you will need to manually select the lens Make in order to apply the appropriate profile. Apologies for the inconvenience.

Regards,

- Chris
Photo of Tom Williamson

Tom Williamson

  • 13 Posts
  • 6 Reply Likes
Hi Chris,

Thanks for that! Great to hear that there is a solution on the way.

For the photos I have already imported, I was able to write a script to search/replace within the xmp files to fix the metadata. Please correct me if I'm wrong, but I don't think there is an official way to manually override the lens in the metadata panel from within Lightroom.

Best regards,
Tom
Photo of Chris Castleberry

Chris Castleberry, Camera Raw Engineer

  • 345 Posts
  • 97 Reply Likes
Hi Tom,

You are correct. It is not possible to overwrite the lens info from Lightroom. You may be able to use exiftool to do this.

- Chris
Photo of Jens Grimm

Jens Grimm

  • 2 Posts
  • 1 Reply Like
I have the same problem. Why doesn't implement Lightroom a function to set the lens name manually? Would also be a great help for all of us, who are using vintage lenses.
Photo of Lunah Lauridsen

Lunah Lauridsen

  • 3 Posts
  • 0 Reply Likes
Is there any solution yet? I just discovered  that a lot of my files have wrong lenses.
I use lens for filter my images, so this is NOT good. 
Hope for a solution soon. 
Photo of Chris Castleberry

Chris Castleberry, Camera Raw Engineer

  • 345 Posts
  • 97 Reply Likes
Hi folks,

I have fixed this internally on the Adobe Camera Raw side, and I'm working with the Lightroom team to determine if there is a separate fix required there. In any case, this should be addressed in a future update. Hopefully that will be sometime in the Spring.

Newly imported images in LR 6.4/CC 2015.4 and Camera Raw 9.4 should not be affected by the bug.

Thanks for being patient.

Regards,

- Chris