lens correction panel. bug with chromatic aberration correction tool

  • 1
  • Problem
  • Updated 2 years ago
 Bug is :
 I applied the chromatic aberration tool :awful desaturation bleeding where the  chromatic aberration should have been corrected.
but then I did Unchecked remove chromatic aberration box and the correction (bleeding) is still there .
See screen capture below . I also did sync all my photos and the error is on all of them.
I had to reset defringe to fix it despite the remove chromatic aberration box was unchecked.


 

lens is tokina 16-28 but it did happen with other profile
(also  if I click -enable profile correction-, the lens profile doesn't come automatically . I need to select it manually, maker and model if it is not a canon lens, is it normal ?)
Photo of alain bouvier

alain bouvier

  • 2 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2586 Posts
  • 323 Reply Likes

The bleeding is not coming from the Chromatic Aberration correction, it is coming from the Defringing correction in the Color tab that is independent of the Chromatic Aberration being enabled.  Defringing from one image rarely applies to another unless they are burst shots of the same scene.

Resetting Defringing is exactly what you should have done to fix it. 

My question would be why Defringing was adjusted so that there was "bleeding" as you call it?

(Edited)
Photo of alain bouvier

alain bouvier

  • 2 Posts
  • 0 Reply Likes
Thanks, I thought Chromatic Aberration correction and defringe were related . Now I get what did happen.