Lightroom/Camera Raw: Leica M9 Summilux 35mm lens profile is interpreted as Summicron 35 in metadata

  • 2
  • Problem
  • Updated 1 year ago
  • Solved
  • (Edited)
I have my Leica M9 lens selection set to Summilux 35mm 1.4 (the non-ashpherical selection), and in the metadata in Lightroom the photos show as taken with a Summicron 35mm VI. This is a bit annoying. :) I am assuming this is a bug, and I can't find any previous reports on this specifically.
Photo of Kenny Lövrin

Kenny Lövrin

  • 7 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 2
Photo of Chris Castleberry

Chris Castleberry, Camera Raw Engineer

  • 342 Posts
  • 88 Reply Likes
Hello. If you post a sample DNG (a link is fine) I can have a look and confirm whether it is a bug or not.

Regards,

- Chris
Photo of Kenny Lövrin

Kenny Lövrin

  • 7 Posts
  • 0 Reply Likes
Hi!

Sorry about the slow reply, but here's a link to a zip file containing a shot of how the M9 was configured, a screenshot of the metadata pane, and the DNG to check.

https://www.dropbox.com/s/fpghylo13czvhz0/summilux_metadata.zip?dl=0

I hope that helps!

Kenny
Photo of Chris Castleberry

Chris Castleberry, Camera Raw Engineer

  • 342 Posts
  • 88 Reply Likes
Hi,

As far as I can tell it appears that the camera is writing out the wrong 6-bit lens code. However, to be sure, I have an M9 body on the way to confirm whether this is the case or if we have an issue in our implementation. Stay tuned.

Thanks for your patience.

- Chris
Photo of Kenny Lövrin

Kenny Lövrin

  • 7 Posts
  • 0 Reply Likes
Alright, I kind of worried that might be the case, but thanks for looking into this!
Photo of Chris Castleberry

Chris Castleberry, Camera Raw Engineer

  • 342 Posts
  • 88 Reply Likes
Following up. I discovered that the bug is in our code and proposed/checked in a fix. Assuming our QE blesses the fix, it should be available in the next release of ACR/LR. Thanks for your patience.
Photo of Kenny Lövrin

Kenny Lövrin

  • 7 Posts
  • 0 Reply Likes
Thanks, that's good news! Does that also mean that shots already imported will be correct? (I don't know if the metadata is read on the fly or parsed into a database on import of course).
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13968 Posts
  • 1664 Reply Likes
This should be fixed in the Camera Raw 9.9 and Lightroom 6.9 release
Photo of Stefan Sierakowski

Stefan Sierakowski

  • 2 Posts
  • 0 Reply Likes
Hi.  I'm having the same problem with a Sigma 50mm f/1.4 ART.  The metadata is only showing '50mm'.  I'm currently on Lr 2015.10 and Camera Raw 9.10.  Help?!