Photoshop: Left align text and right align text in the Properties panel have the opposite effect

  • 2
  • Problem
  • Updated 4 months ago
  • Acknowledged
  • (Edited)
Left align text and right align text in the Properties panel have the opposite effect. When clicking on Left align text in the Properties panel the text is aligned to the right and vice versa.
On Mac OS Sierra (10.12.5) with PS CC 2017.1.1

Photo of Marius Petrescu

Marius Petrescu

  • 7 Posts
  • 1 Reply Like

Posted 11 months ago

  • 2
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 1047 Posts
  • 400 Reply Likes
What you see here is the general alignment on top, and the alignment of a specific paragraph at the bottom. That paragraph could be aligned differently.
(Edited)
Photo of Marius Petrescu

Marius Petrescu

  • 7 Posts
  • 1 Reply Like
I'm afraid it isn't so. Either way you find yourself, having the whole layer selected or just one specific paragraph within the layer, both buttons should do the same thing and have the same state.

Not that this should be the main reason for that, but they even have the same tooltip.

Please try press them either way you want and you'll see what happens. You can even try this on only one paragraph within a Paragraph text layer. It's really funny.
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 1047 Posts
  • 400 Reply Likes
When I start typing with alignment to the right, make a new paragraph and click on alignment to the left in the Paragraph panel, the right alignment in the properties panel does not change. Neither does the alignment of the first paragraph. That means I get the same effect that is shown in your screenshot. I assume that is intentional, because otherwise there would be little reason to have alignment options in two places...

What I do not see is that opposite effect that you report. If I click on alignment to the left in the properties panel, that is what I get. Not the opposite. Same version of Photoshop, same version of MacOS X.
Photo of Todd Shaner

Todd Shaner, Champion

  • 912 Posts
  • 279 Reply Likes
Try restoring your PS Preferences to the default settings as outlined here:

https://helpx.adobe.com/photoshop/using/preferences.html
Photo of Marius Petrescu

Marius Petrescu

  • 7 Posts
  • 1 Reply Like
Johan, I don't know how it's on your side, but to cut it short, on my side is like this:



And to answer your question I guess the text alignment buttons in the Properties panel are replicated there for the same reason the other controls like font size, colour or family are. The Properties panel is nothing but a handful of the most frequently needed controls for the currently selected object on the art board.

Having the alignment options in two places like many other options (by the way, it's more than two places, you also have these in the top toolbar when you're in text edit mode) is nothing wrong. Having them look the same, have the same tooltip but act differently, well that is very wrong.

Todd, thanks for the advice. I'll try this, but with little hope because this is like this for a while now and, meantime, I used PS on 3 different machines (all Mac OS or OSX, different versions). I just checked now, it's the same on one of my colleagues here, on a Windows 10 Pro machine, latest version of PS.

Anyway, just wanted to report the problem, not a big deal though.
(Edited)
Photo of Todd Shaner

Todd Shaner, Champion

  • 912 Posts
  • 279 Reply Likes
Marius, I can confirm the behavior as shown in your video on my Windows 7 system with PS CC 2017.1.1 and it does appear to be a bug. Resetting the Adobe Photoshop CC 2017 Prefs.psp Preferences file does not resolve the issue
Photo of Cristen Gillespie

Cristen Gillespie

  • 1074 Posts
  • 284 Reply Likes
Mac El Capitan and I'm not seeing anything wrong with alignment in either the Properties panel or in the Options bar. They're working as they should be. Something more specific going on? I've tried both the examples shown in the video.
Photo of David

David, Official Rep

  • 2701 Posts
  • 361 Reply Likes
Howdy Marius,

I cannot reproduce this either in the standard version of the app, but I've a strong suspicion that I know what's going on.

First question, if you add a period ( . ) to the right end of a string of text, does it jump to the left side?

Second, if you click Type > Language Options, you'll see Default Features is checked, but I'll be you can switch to Middle Eastern Features, right?

So, the quick fix is to go to the Paragraph panel's flyout menu and click Latin and East Asian Layout (only in the last version or two).  You can find a much more detailed explanation in my video: https://www.youtube.com/watch?v=17gM33tB1Hw

If that doesn't solve things right up for you, let me know...

Thanks,
David
Photo of Marius Petrescu

Marius Petrescu

  • 7 Posts
  • 1 Reply Like
Hi David.

First of all, I started a new document to test the period thing and guess what, the described behaviour didn't happened. Meaning both Properties and Paragraph panels showed the same state for the alignment options, like they should.
But that's what I did few days ago when capturing the video. I also made a new document and it did happened (as seen in the video).

Second, I opened an old (like few days old) document, where the behaviour do happen and added a period to the right end of a string. The period stayed there, where it should stay. No jump. And I remembered that a colleague showed me this once on his machine not understanding why it happens.

Third, I checked on those options. In Type > Language Options menu, Default Features is in deed checked. But only East Asian Features is also enabled there. The rest are disabled so I can not switch to Middle Eastern Features.

Fourth, in the Paragraph panel's flyout menu Latin and East Asian Layout is already selected. Seems that it's always been like this.

Fifth. I made a new document again. This time it did happened again. It's crazy.

In Preferences > Type I have two options under the Text Engine Options: East Asian (selected) and Middle Eastern and South Asian. Switching between them seem to have no effect, even on new documents.

Cheers!
Photo of David

David, Official Rep

  • 2701 Posts
  • 361 Reply Likes
Howdy Marius,

A couple of things here.

First, the problem is caused when the text engine is set to Middle Eastern and South Asian and the text FLOW (not alignment but flow) is set to Right-to-Left.  Switching composers is simply a quick way to solve the problem -- the actual ideal solution is to set the composer to MENA, set the text flow to Left-to-Right, and then (if you're not using MENA features) set the composer back to Latin and East Asian.  If you look at the video I posted, you can see me explain the details and controls there.

Next, this feature has changed a couple of times over the last few years.  What I'm describing here is the behavior you should see in the latest release as well as the last one.  Prior releases won't be able to switch composers on existing text layers, so in those cases you will have to take the steps detailed in my previous paragraph.

Also, all of this information is based on the common SKUs.  If you're running Arabic-enabled-English, Hebrew-enabled-English, or North African French, your settings DEFAULT to the MENA composer, although the steps in the first paragraph can still be used to override those settings.  I believe there might have been a bug in one release with the Czech version having the wrong composer by default, but that was only reported by one person and never confirmed.

Finally, based on what you're saying, that you created a new document and the period was on the left, then your setup is one of the three SKUs (above) OR you've reset your default text engine under Preferences > Type.  This video gives details on that, https://www.youtube.com/watch?v=gfuw7m5mVTk .  In a nutshell, the setting under Preferences applies to NEW documents and layers.  The setting under the Paragraph panel applies to the currently-selected layer only.  As with nearly all Photoshop features, this one is sticky.  That means if you edit a document with the MENA composer, you will automatically be set to that composer.  Similarly, if you've reset your text flow, it'll stay that way until you change it (see the video).

If you don't have any use for these features, go into Preferences > Type and switch to East Asian (or just trash your prefs).  That will make all NEW docs Euro-standard.  Then when you're working on a doc, if you notice the punctuation isn't right, check the Paragraph panel -- if you created the doc with the other composer, that change will persist, so switch the text flow to Left-to-Right and then reset the composer to East Asian.  Now, sticky or not, that document will behave according to the standards for European languages.

Hope that helps -- feel free to ask questions and if you're stuck, I'm happy to do a web-hosted screenshare to fix you up.
Thanks,
David
Photo of Marius Petrescu

Marius Petrescu

  • 7 Posts
  • 1 Reply Like
Thanks David. I'll give it a try first chance I have. Cheers.
Photo of Tuyen Nguyen

Tuyen Nguyen

  • 5 Posts
  • 0 Reply Likes
u
(Edited)
Photo of Todd Shaner

Todd Shaner, Champion

  • 912 Posts
  • 279 Reply Likes
Thanks David that fixed the text alignment issue for me on Windows 7 with PS 2017.1.1. I'm still not sure how this setting got changed, but it's fixed now.
Photo of David

David, Official Rep

  • 2701 Posts
  • 361 Reply Likes
Glad to know that's the silver bullet, Todd.  Thanks for letting me know.

The setting is stored on a per-layer basis with current docs and a per-document basis for documents created three or more years ago.  The setting shouldn't be sticky unless you fiddle with the control under Preferences > Type, though there might be an (unknown) exception.

Hope that helps,
David