Lightroom 4.1 RC can not create 16 bit tiff files for Edit In

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
  • (Edited)
LR 4.1 RC refuses to create 16 bit tiff files for Edit In function. I tried both Preferences - External Editing and set bit depth to 16 in the additional external editor section. When I reopen Preferences it has reverted to 8 bit. If I select 16 bit from the "Edit Photo with" dialog after selecting Edit In, it still creates an 8 bit tiff file for the external editor. The external editor I am using is Topaz Labs.
Photo of Martin Ohye

Martin Ohye

  • 10 Posts
  • 1 Reply Like
  • frustrated

Posted 7 years ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Champion

  • 1373 Posts
  • 337 Reply Likes
You might try renaming your preferences file and letting Lightroom build a new one.

1. Close Lightroom
2. Locate the preferences file rename it. http://helpx.adobe.com/lightroom/kb/p...
3. Reopen Lightroom
Photo of Martin Ohye

Martin Ohye

  • 10 Posts
  • 1 Reply Like
Thanks for the suggestion.
I renamed the preferences file, then opened LR and set up my external editing preferences again. I closed and re-opened LR to check what had been saved. I had set: application, color space, bit depth and compression. All settings were remembered except bit depth that had reverted to 8 bits. It looks like the settings dialog is just not storing the 16 bit selection.
In desparation I tried manually editing the preferences file, found externalEditingFormat="TIFF_None_8_ProPhotoRGB" and replaced the 8 with 16. When I reopened LR it then showed 16 in the external editing preferences and it did actually create a 16 bit file when I tried Edit In.
That was way too hard, but I can get by until the bugs get fixed. Thanks.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15211 Posts
  • 2185 Reply Likes
Official Response
This was saved in Lightroom 4.3 or later.