Photoshop: Click and drag Layer to tabbed document Doesn't Work on Mac

  • 3
  • Problem
  • Updated 1 year ago
  • In Progress
  • (Edited)
Dragging a selected image layer from the "LAYERS" panel to the tab of an unselected image and holding it over the tab does not result in that 2nd layer popping open so the first image layer can be dropped into it.  Apparently this problem occurs for some people and not others and can even be intermittent based on much time researching it trying to find a solution.  In my case, my girlfriend and I have two new MacBook pros, running two brand new PS installs, same OS on both and after days of trying can't EVER do it.  However it's demonstrated on Julieanne Kost's new Lynda.com course so it CAN be done. People on the forum asking about the same thing are getting responses from people who can do it too (we just did as well). The problem has apparently been going on for years.  PLEASE FINALLY TAKE IT SERIOUSLY!!
Photo of Russ Ravella

Russ Ravella

  • 9 Posts
  • 1 Reply Like
  • VERY frustrated

Posted 1 year ago

  • 3
Photo of David

David, Official Rep

  • 2727 Posts
  • 373 Reply Likes
Howdy Russ,

For what it's worth, this is news to me.  I just tried it myself and it didn't work, so I walked over to Julianne's office and she demoed it for me.  We spent some time trying to figure out if she has some setting different than I do, even going so far as trashing her prefs.  No luck (but I owe her lunch now!).  So I asked a colleague to try his machine.  Works fine for him.  I tried it on my nearly identical MacBook and no joy.  And it works on my Windows machine...  This leaves me with more questions than answers.

What graphics processor are you two using?  How much RAM do you have on your machine?  Which specific OS version are you and your girlfriend running?  I'm taking shots in the dark, but hopefully we can run this down.

Thanks,
David
Photo of Russ Ravella

Russ Ravella

  • 9 Posts
  • 1 Reply Like
Hi David!
WOW!!!  Thank you and Julieanne SO MUCH for taking this seriously - I can't tell you how impressed Sharon (my girlfriend) and I are with your response!!  Please thank Julieanne too - I practically fell out of my chair when I saw her response this morning!  Ok, here are the answers to your questions - graphics processor: "Intel Iris 1536 MB" (further probably useless details attached at the end of this reply so you can ignore them if not helpful); Memory: 16GB 1600 Ghz of DDR3;  MacOS: macOS 10.12.5, build 16F73 (the kernel version is: Darwin 16.6.0).  They're both 13" MacBook Pros "Retina" 's  we bought in 2014, we both downloaded PS a week ago Monday running the same version as Julieanne (CC 2017.1.1) and there's nothing else (besides Bridge and occasionally Lightroom) running at the same time that I can see.  We tried dumping our pref's too, no help.  After spending days researching this, it turns out a LOT of people are having this problem and a lot are not, just as you are seeing.  And it's apparently been going on for a long time.  From what I can see, the developer guys (genderless term according to my dictionary!) know about it and just haven't gotten to it.  Very weird!!  How can software "know" how to work here and not there, version, os, machine type, all independently !?!? 
Thank you for thinking about this David!!
Russ and Sharon
(further graphics card info: Chipset Model: Intel Iris, Type: GPU, Bus: Built-In, VRAM (Dynamic, Max): 1536 MB, Vendor: Intel (0x8086), Device ID: 0x0a2e, Revision ID: 0x0009, Metal: Supported)
Photo of David

David, Official Rep

  • 2701 Posts
  • 372 Reply Likes
Howdy Russ,

Okay, this one is a curious.  I've worked with a couple of other coworkers on this.  It works for some people and not others.  I've logged a bug and we're looking into it.  Thanks for letting us know and sorry that it's a pain.

Thanks,
David
Photo of Russ Ravella

Russ Ravella

  • 9 Posts
  • 1 Reply Like
Ok David,

Thanks for the feedback.  Since this has been going on for quite awhile based on the number of posts on the internet about it (including Adobe forum posts), it's hard to believe the developers don't already know about it and apparently don't plan to fix it.  But at least we know it isn't some screwy setting we have wrong somewhere.

Thanks,
Russ
Photo of Cristen Gillespie

Cristen Gillespie

  • 1177 Posts
  • 315 Reply Likes
@David  Would it help to collect system info from us? It works on both my laptop and ancient desktop, btw, both running El Capitan.  The way it's affecting some of us and not others makes me think of the Recent Files bug that you all are now attributing to the Creative Cloud update. Some of us feel the pain and the rest of us don't.
Photo of Cristen Gillespie

Cristen Gillespie

  • 1177 Posts
  • 315 Reply Likes
> talking white rabbit with a pocket watch>

That's called normal to us artsy types. LOL
Photo of Russ Ravella

Russ Ravella

  • 9 Posts
  • 1 Reply Like
Us physicist types too...
Photo of David

David, Official Rep

  • 2727 Posts
  • 373 Reply Likes
Howdy Cristen and Russ,

Two things, first, I cannot accept ZIPped files via email.  Could you resend unzipped?  Second, while I bailed on being a physicist my junior year, I don't recall any white rabbits checking their pocket watches...8-)

Have a nice weekend,
David
Photo of Cristen Gillespie

Cristen Gillespie

  • 1177 Posts
  • 315 Reply Likes
> while I bailed on being a physicist my junior year, I don't recall any white rabbits checking their pocket watches...8-).>

If you'd been able to notice the obvious, maybe you wouldn't have bailed. <BG>  Sent unzipped. Enjoy.
Photo of Russ Ravella

Russ Ravella

  • 9 Posts
  • 1 Reply Like
The rabbits show up in quantum field theory, a bit after the junior year. BIG rabbits with trick watches.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14049 Posts
  • 1735 Reply Likes
I'm wondering if there's any other things in play here. Do you use a Wacom tablet? Use any of the following apps or utilities:
  • iCopy
  • Synergy
  • ShareMouse
  • Notability
If you start your Mac in SafeMode does it work?

If you start with the shift key down to disable 3rd party plug-ins does it work?
Photo of David

David, Official Rep

  • 2719 Posts
  • 373 Reply Likes
For what it's worth, Jeff, I'm running a very vanilla install of 10.12.1 and seeing this.  No tablets, very few 3rd party apps, no 3rd party plugins.  Working on this, but so far, just head scratching...though the leading theory thus far is hardware.  8-(

Sorry!
David
Photo of Russ Ravella

Russ Ravella

  • 9 Posts
  • 1 Reply Like
Just a quick thought ... I don't see how anything to do with hardware could be relevant to this, other than the need to understand the details of how the h/w is running the s/w.  The problem occurs on various age/models of Macs AND PCs so there's no common h/w element involved.  For what it's worth -
Photo of Russ Ravella

Russ Ravella

  • 9 Posts
  • 1 Reply Like
For our part, the problem first occurred before I installed and used an old Wacom tablet I had on a shelf.  It persisted after I installed it. My girlfriend doesn't have one.  We don't use any of the apps or utilities you listed at all and don't have any 3rd party plugins at all.   We both joined CC and installed PS about two weeks ago on fairly virgin MacPros (little else on them).   I don't recall how to start the Mac in SafeMode anymore but I'll try it if you remind me how.
(Edited)
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13996 Posts
  • 1686 Reply Likes
Photo of Russ Ravella

Russ Ravella

  • 9 Posts
  • 1 Reply Like
Still doesn't work when the computer is started in safe mode.  The "dragged to" tab just sits there (yes, I waited long enough).  (PS an error in the last post - we're using MacBook Pros, not MacPros - not that it matters...)
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13996 Posts
  • 1686 Reply Likes
Thanks. I'll take with David and the engineer who implemented the feature in the AM to see if we can figure out why it might not be working for some customers. I'm in the same boat where it's working for me.
Photo of Russ Ravella

Russ Ravella

  • 9 Posts
  • 1 Reply Like
Thanks, appreciate it.  It's a weird one.  It happens and doesn't happen on both mac and pc, current and older OS versions of both, and current and older versions of PS.  Not a huge deal as there are ways around it but pretty strange!