Layer blending modes on PC computer staying highlighted

  • 3
  • Problem
  • Updated 6 months ago
I work with Photoshop CC 2019 on a PC computer. Whenever I change a layer blending mode, the blending mode stays highlighted until I press the enter or escape key.

I work with the same Photoshop CC 2019 on a MAC and you don't have to hit additional key with blending modes on a MAC computer.

I use very often the layer blending modes and having to press escape each time is really annoying and not very useful!

Is it possible to correct this bug for PC users?

Thank you!
Photo of Marielou Théorêt

Marielou Théorêt

  • 2 Posts
  • 0 Reply Likes
  • annoyed, frustrated...

Posted 11 months ago

  • 3
Photo of eartho

eartho, Champion

  • 1482 Posts
  • 499 Reply Likes
That seems to be how everything behaves in Ps on Win10, unfortunately. Almost every dropdown and button remains active after using it and coming from 25 years on a Mac, i too find this behavior to be incredibly annoying and frustrating. Add to that the behavior of Alt and i'm about to throw my Windows machine out the nearest window. 

Sadly, these are features, not bugs.
Photo of Marielou Théorêt

Marielou Théorêt

  • 2 Posts
  • 0 Reply Likes
Hi, 

I thought too it may be related to the way the PC computers work. But I remember working with earlier version of Photoshop, on Mac and PC systems and I don't remember having this problem before with PC. So if it did not exist then, it might be corrected today? (I know, I am very optimistic... lol...)

As for the "alt" I did a lot of research in the past months. I totally agree with your feeling to throw your PC out of the widow from the 7th floor... But yes, there is some ways to correct these problems!

Since I have to work frequently on computers with both MAC and PC, and make sure my brain would not go completely crazy, I configured my PC keyboard just like it was a Mac keyboard. (It was not easy...)

I don't know if I should start another post for this subject...?


I first reprogrammed the keys in the registery to swap the "ctrl" and "alt".  It was a delicate operation since I wanted to modify this in the "core" keyboard information of the computer. If you wish to know how, I can find the links I used for that.

As for the alt key, the way to do it is with the "AutoHotkey" application. At fisrt, I didn't like the idea of having a software running on my system. But it is really a good solution. The software is free and safe, I am very carefull for viruses and stuff like that... You then need to write a text file in autoHotkey with the following instructions :

alt ::
KeyWait, Alt
return

LAlt Up ::
if (A_PriorKey = "Alt")
return

return


You can test your script by running it with AutoHotkey. If it works, you create a .exe file that you put in your startup menu. That way the script automatically start whenever you start your computer.

The way it works is that normally, when you hit once the "alt" key, it activates the underlined letters in the menus. To deactivate, you have to hit the "alt" another time. The script says to the computer to activate the menu only if you are acutally pressing the key. When you remove your finger from the key, the alt function is no longer active...

Hope this may be helpful to you!

...Wich gives me an idea... Could I write a script that would automatically press enter each time I chose a blending mode...???


Photo of Farhan Purwanto

Farhan Purwanto

  • 4 Posts
  • 0 Reply Likes
yep, I'm also having this kind of annoyance, especially when creating illustration in Photoshop when stacking a lot of layers with different blend modes. I don't know, maybe this is kind of "feature" that allow you to cycle through the modes with the up/down arrow keys. But this is getting annoying since I didn't have this kind of problem before on windows.

I'm used to use mac OS, and that cycle feature is probably the one thing that I wanted on windows, but with it's being like this, I think I'd prefer to wait.

At least please give us option to "turn off" this thing.