Elements: Lasso/Quick Select tools do not work on macbook pro retina. (MacOS 10.10 Yosemite)

  • 2
  • Problem
  • Updated 3 years ago
  • (Edited)
All Lasso options on elements 12 not working at on macbook pro retina. I mouse click using the track pad and nothing happens. I have to press esc multiple times to get out of the lasso tool. Also crashes when try to use the quick selection tool. I have to force quit out of elements all together!.

I am latest update of photoshop elements 12 and of mac os.

I have tried the deleting of preferences and settings etc, which supposedly can be used for issues with photoshop, but still no fix. Seems pretty poor. Paid a lot of money for this!

Please help, I like to use this function a lot.
Photo of kevin plumridge

kevin plumridge

  • 9 Posts
  • 0 Reply Likes
  • very frustrated!!

Posted 3 years ago

  • 2
Photo of Vaishali

Vaishali, Employee

  • 212 Posts
  • 13 Reply Likes
Official Response

We sincerely apologize for the problem that you have been facing while using a trackpad with Photoshop Elements 11 & 12 on Mac OSX 10.10 (Yosemite).

We have been actively working with Apple to resolve this problem as quickly as possible. We're hopeful this will get completely resolved in an upcoming update of Yosemite(MAC 10.10).

In the meanwhile, you have two options to work around this problem:

1. Option1: Use a mouse instead of the trackpad

2. Option2: Install a plug-in which should workaround the problem

Plug-in installation instructions:

1. Close Photoshop Elements

2. Download this zip file to a location you can easily find (e.g. your desktop)

3. Unzip the file, WhiteWindowWorkaround.plugin, and move it to the Plug-In folder:

• For Elements 12 – //Applications/Adobe Photoshop Elements 12/Support Files/Plug-Ins/

• For Elements 11 - //Applications/Adobe Photoshop Elements 11/Support Files/Plug-Ins/

You can verify the plug-in is installed by launching the Photoshop Elements Editor and choosing Help > System Info... Scroll to the bottom of the text in the dialog and look for the plug-in name "WhiteWindowWorkaround.plugin".

Note: This plugin is a temporary workaround and should be used until this issue is addressed in Mac OSX 10.10 (Yosemite). Please remove this plugin once the issue is officially resolved by Apple.

If you are using a stylus in conjunction with a trackpad, you might see issues with your trackpad. Workaround in this particular case is to use mouse instead of the trackpad.

Hope this helps!