Lagtastic: Photoshop CC

  • 2
  • Problem
  • Updated 3 years ago
I have Photoshop CC updated in 2015 and I have been experiencing horrible brush lag for quite a while now. I've googled till my head hurts and all the tips and tricks haven't seemed to be working. I've turned the performance to basic, lowered the amount of memory it uses, changed the spacing in my brushes, turned off the font preview, etc.
I am working on a Mac book Pro, OS X Yosemite, with 16 GB memory.
I work on a Cintiq 13 HD, but that does not seem to be the problem. Even if I don't use the tablet all the brushes in photoshop have a pretty long delay.
If you have any suggestions, please please help me. My work is suffering and so is my patience.
Photo of Elia Murray

Elia Murray

  • 4 Posts
  • 0 Reply Likes
  • frustrated

Posted 3 years ago

  • 2
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
Make sure you have the 2015.0.1 update installed (check Help->System Info).
Photo of Elia Murray

Elia Murray

  • 4 Posts
  • 0 Reply Likes
Updating! Thank you!
Photo of Elia Murray

Elia Murray

  • 4 Posts
  • 0 Reply Likes
So I've updated it, and the lag is still there and still pretty extreme. Any other suggestions?
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
Next thing to try is killing the CCLibraries process (a separate process from Photoshop).
Photo of Elia Murray

Elia Murray

  • 4 Posts
  • 0 Reply Likes
How do I do that?
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
Open the Activity Monitor, select the CCLibrary process, double click, select "Quit".

It should get relaunched in a few seconds, but killing it seems to clean up some stuck state that slows things down.