Lightroom: keywords from Photoshop

  • 2
  • Problem
  • Updated 2 years ago
  • Acknowledged
  • (Edited)
Keyword fails to add when using Photoshop to edit.
My normal work flow is to do some basic edits on a raw image in Develop then I do further Editing in Photoshop CC.  In general, I rely on keywords to keep my many tens of thousands of images accessible.  Unfortunately, the keywords on the raw image fail to export to the newly created and related .psd or .tiff file.  On completing the edits in Photoshop, I save the image and return to Lightroom.  The newly created .psd/.tiff image is stacked with the raw image and it SAYS that the keyword has been attached to this new image BUT THEY ARE NOT!!!!  IT IS NECESSARY FOR ME TO UNCHECK THE KEYWORD THEN RE-CHECK THE KEYWORD FOR IT TO ACTUALLY BE THERE AND SEARCHABLE.  This sure seems like a bug to me and I hope that the next time you push through an updated version of PSCC I will see that this is fixed.  Note: before I "upgraded" from PS Elements I NEVER had this problem.
Photo of Vivian McAleavey

Vivian McAleavey

  • 9 Posts
  • 2 Reply Likes
  • frustrated

Posted 2 years ago

  • 2
Photo of Steve Gandy

Steve Gandy

  • 109 Posts
  • 36 Reply Likes
I think you will want to have metadata saved to the .xmp sidecar files. You can set that in the Camera Raw Preferences for Photoshop and the catalog settings in Lightroom. Otherwise your keywords are held in the Camera Raw database and the Lightroom catalog but not really attached directly to the file itself. Someone else may correct me on the details but I believe that this will solve your problem.
Photo of Vivian McAleavey

Vivian McAleavey

  • 9 Posts
  • 2 Reply Likes
Thanks for your suggestion.  I did verify that both PS and LR have preference selected to write metadata to the XMP sidecar.  Must be something else wrong.
Photo of John R. Ellis

John R. Ellis, Champion

  • 3871 Posts
  • 1023 Reply Likes
Which exact version of LR and Photoshop or Photoshop Elements are you running?  In each program, do Help > System Info to get the exact version.

I'm not able to observe that behavior in in LR CC 2015.9 / PS CC 2015.5.   Unfortunately, Adobe isn't likely to fix a bug until there is a precise recipe for reproducing it.   Below are the steps that I used; do they work correctly for you?  If so, can you post a similar recipe that doesn't produce correct behavior?

1. Make sure the option Catalog Settings > Metadata > Automatically Write Changes Into XMP is off.

2. Import a raw photo into the catalog.

3. Assign the keyword "Ship".

4. In Develop, change Exposure.

4. Do Photo > Edit > Edit In Adobe Photoshop CC 2015.5

5. In PS, make some edits and do File > Save.

6. In LR, observe that the saved .tif is stacked on top of the raw. 

7. Observe in the Keywording panel on the right of Library that the keyword "Ship" is assigned to the .tif.

8. Observe that in the Library Filter bar, filtering with the criterion Keywords Contain Ship matches both the raw and the .tif.
Photo of Vivian McAleavey

Vivian McAleavey

  • 9 Posts
  • 2 Reply Likes
So, maybe you can try this experiment - which is my usual procedure.  With various images selected using a keyword  (in Lightroom you have identified a group of images on which you are working) choose one of these images and Edit it in PS.  After making some changes, save and close the image.  Return to LR and is this image still part of your keyword-selected group?  Mine isn't. Even though when I go back to my complete catalog and find that image the proper keyword box is checked but in order for it to actually be included in the keyword group, I have to uncheck the keyword box and re-check it.
Photo of Alan Harper

Alan Harper

  • 430 Posts
  • 85 Reply Likes
Do you mean like this?


I followed John Ellis' recipe, except that I made it simpler
1: Assign a tag (keyword) in Lightroom
2: Set up filter bar in Lightroom to filter for that tag
3. Using Lightroom, open raw file in Photoshop
4. Save file in PS
5. Return to LR
I see the above.
Photo of John R. Ellis

John R. Ellis, Champion

  • 3871 Posts
  • 1023 Reply Likes
"With various images selected using a keyword"

How exactly are you doing that? There are three different ways of filtering by keyword:

1. In the Library Filter bar, you can use the criterion "Keywords Contains keyword".

2. 
In the Library Filter bar, you can use the Metadata browser to add the Keyword column and then select the keyword in that column.

3. You can click on the arrow to the right of the keyword in the Keyword List panel.

Posting a full resolution screenshot of the entire LR window would provide more clues as to what's happening.
Photo of Vivian McAleavey

Vivian McAleavey

  • 9 Posts
  • 2 Reply Likes
I usually click on the arrow to the right of the keyword in the Keyword List panel.  Here is a screen shot:
The point I keep trying to make is that IT APPEARS that the key word is there (above) but if you now select for the keyword group (by clicking the arrow to the right of the keyword the newly created .tif file is not included in the group.  See this screen shot:


Please try the experiment that I outlined yesterday and let me know your results.
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 1548 Posts
  • 623 Reply Likes
As others have pointed out, they don't see this. I don't see it either. That makes me think it might be a catalog corruption issue. Catalog corruption can cause all kinds of weird behavior. I've seen a catalog where filters did work in folders, but not in collections, for example.

I would suggest the following: create a brand new catalog, import just a hand full of raw files and repeat the experiment. If everything works as expected in this new catalog, you could try to resolve your issues by creating a new catalog and then using 'Import from Another Catalog' to get your images and metadata into that new catalog. With a little bit of luck that solves it.
Photo of garima aggarwal

garima aggarwal, Employee

  • 10 Posts
  • 1 Reply Like
Thanks for reporting it. We already have a bug logged for this. We will look into it.
Photo of Vivian McAleavey

Vivian McAleavey

  • 9 Posts
  • 2 Reply Likes
Thanks for the feedback Garima Aggarwal.  After all of the above chatter, it's nice to learn that it's "not just me"!  I'll be eagerly watching for the bug fix.
Photo of John R. Ellis

John R. Ellis, Champion

  • 3871 Posts
  • 1023 Reply Likes
"I usually click on the arrow to the right of the keyword in the Keyword List panel."

That detail was key to reproducing the problem.  The other ways of filtering by keyword don't exhibit the bug.   Two workarounds:

1. Use the Library Filter bar to filter by keywords.

2. Exit and restart LR after Photoshop returns, and the filtering will work correctly (until the next time you invoke Photoshop).

In the past, filtering bugs have taken months to years to get fixed (and some remain unfixed).  Let's hope this one gets fixed much sooner.
Photo of Alan Harper

Alan Harper

  • 430 Posts
  • 85 Reply Likes
Exactly John. It is a little annoying to take time to try to replicate someone's reported bug, find that you can't because it was not clearly described, and have your efforts described as "chatter."
Photo of Vivian McAleavey

Vivian McAleavey

  • 9 Posts
  • 2 Reply Likes
Please forgive my naivete!  I did not think "chatter" was a derogatory word.  No disrespect was intended!!! I have very much appreciated all of the assistance with this problem.
Photo of Vivian McAleavey

Vivian McAleavey

  • 9 Posts
  • 2 Reply Likes
Ok, thanks for the work-around.  I was able to get it to work that way, but OMG what a hassle!!!!!!  I should point out, however, that using the Library Filter bar instead of the arrow on the Keyword List panel makes no difference in my results.  It's the closing out of LR that seems to reset it.  Let's hope some miracle happens and the bug gets fixed soon.  Appreciate all your efforts on my behalf.
(Edited)
Photo of John R. Ellis

John R. Ellis, Champion

  • 3871 Posts
  • 1023 Reply Likes
Another workaround is to use the Any Tag plugin to search by one or more keywords.