Jpg files with existing GPS data loose EXIF date time stamps when imported into Lightroom

  • 1
  • Problem
  • Updated 6 years ago
Problem:

EXIF date time stamp values lost when importing jpeg files into Lightroom from Canon 5D Mark III jpeg files where GPS data was added with GisTEQ PhotoTrackr software.

I am using:

Windows 7 Ultimate SP1 64 Bit
Lightroom version 4.1 Build 829322 Camera Raw 7.1

Problem Details:

I started using the HDR feature of the Canon 5D Mark III which results in raw files and a jpeg HDR image. If I import the jpeg files directly from the 5D M3 to Lightroom EXIF date time values "Date Time Original", "Date Time Digitized" and "Date Time" are present and accounted for. However, my standard workflow is to Geo-code my images first before importing into Lightroom using GisTEQ PhotoTrackr software and the log files create by their hardware GPS device (PhotoTrackr Mini DPL900). This has worked great for a couple of years with the raw files. The software creates XMP sidecar files with the GPS data and there are no issues when importing into Lightroom. For jpeg files the GisTEQ PhotoTrackr software writes the GPS data directly into the jpg file. After geocoding the jpg files I can see the valid GPS data, all three EXIF dates are present and valid and there are no discrepancies that I can see with any other EXIF data while reading geocoded files with various apps that can read EXIF data.

When I import the jpg files with GPS data into Lightroom the GPS data is visible in the EXIF metadata view in Lightroom but all three EXIF dates ("Date Time Original", "Date Time Digitized" and "Date Time") are not displayed. If I read the EXIF data from the file after import into Lightroom with other software I still see all three dates and the GPS data so it appears the Lightroom EXIF parser has some sort of issue reading EXIF data when the GPS data exists. If I then apply a metadata preset in Lightroom (applies my name, contact data and copyright data) to one of these images and look at the jpg file with a third party program the dates are now gone from the jpg file too.
I also tried to import a jpg file before geocoding, exiting Lightroom and then geocoding the image. When Lightroom is restarted it notes that the metadata was updated outside of Lightroom and when I tell Lightroom to read the file data the EXIF dates again disappear from view. I could not find any other users of GisTEQ PhotoTrackr having EXIF problems. I also found no Lightroom information for this type of problem.
The only workaround I have found after searching for a day is to use the Lightroom metadata “Edit Capture Time...” functionality. In the Grid view if I first select the corresponding RAW file and then the matching jpg file I can then select “Change to file’s creation date” option and this takes the RAW date values and writes into the jpg file. The workaround can be very time consuming If you have many jpg’s with GPS data to do.
I would appreciate that this issue be looked at and eventually resolved if it is indeed an issue with Lightroom as I suspect it is. I would also be very thankful for anyone who can provide me a better workaround then what I currently have.

I can provide sample images of every step in the process as it will be difficult to track down the problem without that.

Thanks,
Frank
Photo of Frank Kloskowski

Frank Kloskowski

  • 6 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 1

Be the first to post a reply!