JPG always shown next to RAW

  • 1
  • Problem
  • Updated 9 months ago
After updating to Lightroom CC Classic I now have both JPG and RAW files next to each other. In the previous version only RAW files where shown. 

In Edit->Preferences->General the "Treat JPEG files next to raw files as separate photos" checkbox is unticked. I have tried to check that checkbox, restart and uncheck the checkbox again but I still have JPEG files next to my raw files again.

How do I make JPEG files not to show in Lightroom next to RAW again (without deleting or moving them)?
Photo of Mats Skoglund

Mats Skoglund

  • 10 Posts
  • 4 Reply Likes

Posted 9 months ago

  • 1
Photo of Rick Spaulding

Rick Spaulding, Champion

  • 564 Posts
  • 221 Reply Likes
Here's another post that talks about it: https://forums.adobe.com/message/9903175#9903175
Photo of Mats Skoglund

Mats Skoglund

  • 10 Posts
  • 4 Reply Likes
Not exactly. That other thread is about Lightroom CC. I got this problem after "upgrading" to Lightroom Classic.

I wonder if it can have something to do with smart previews because I turned that on and then back  off when I was experimeting with the decreased performance I got after "upgrading" to the new Classic CC?
Photo of Steve Crane

Steve Crane

  • 31 Posts
  • 20 Reply Likes
I haven't installed Lightroom Classic CC yet but saw mention about now having the ability to choose to import RAW, JPEG or both. In the previous version checking the option you mentioned used to hide the JPEGs from the import dialog. Possibly the new option has changed that and you need to make a selection of RAW only in the import dialog.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4136 Posts
  • 1473 Reply Likes
So before the catalog upgrade they were a single photo and now they show up separately? Or now new raw+jpeg pairs import as separate photos even though the checkbox is checked?
Photo of Mats Skoglund

Mats Skoglund

  • 10 Posts
  • 4 Reply Likes
It seems like the images already in the catalog is ok. It was the images imported after installing the Lightroom Classic CC that have JPWG and RAW next to each other. For now I have deleted the jpegs from the library. I will check tomorrow when I do a new import whether the issue is still there.
Photo of Carli van Booma

Carli van Booma

  • 1 Post
  • 0 Reply Likes
How about applying a library filter on the file type. I use select only Raw in the file type library file. Rg Carli
Photo of Mats Skoglund

Mats Skoglund

  • 10 Posts
  • 4 Reply Likes
I did a new Import today and now the JPEGs are not shown next to RAW files anymore. I don't know why it works now and didn't before.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4136 Posts
  • 1473 Reply Likes
Great, thanks for reporting back. Let us know if it happens again.