Photoshop 20.0.4: JPEG Export As uses hidden clipping mask

  • 1
  • Problem
  • Updated 6 months ago
  • Not a Problem
  • (Edited)


I am using PS CC, 2019 version (20.0.4, Mac). When I do "quick export as JPEG," the image utilizes a hidden clipping mask. When I release the clipping mask, but still hidden, it renders correctly. The displayed PSD looks normal in either case, that is, ignoring the hidden clipping mask.

correct version below (= clipping mask released)
Photo of Marc Jacobs

Marc Jacobs

  • 4 Posts
  • 0 Reply Likes

Posted 6 months ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15633 Posts
  • 2370 Reply Likes
Hi Marc, could you post the source PSD for us to troubleshoot? (Use a URL to Dropbox or CC files)
Photo of Marc Jacobs

Marc Jacobs

  • 4 Posts
  • 0 Reply Likes
Thanks Jeffrey,
I will do this shortly. I have it in my cc folder but can't figure how to make a share link. It's grayed out.

I do have Google, so I should be able to manage. :-)
Photo of Marc Jacobs

Marc Jacobs

  • 4 Posts
  • 0 Reply Likes
share link
https://adobe.ly/2Xfyil2
This is the first time I am sharing via cc. Please let me know if this works.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15633 Posts
  • 2370 Reply Likes
Hey Marc, thanks for the file. Unfortunately, I can't reproduce. I set my quick export settings from PNG to JPG in preferences, I opened the file you posted and tried File > Export > Quick Export. The text comes out fine (green, not red). Let me know if I'm missing as step.
Photo of Marc Jacobs

Marc Jacobs

  • 4 Posts
  • 0 Reply Likes
Hi Jeffrey:

Hmm. That's weird. I just did the same experiment with the file I put in CC. Same result. 

Ah, pilot error. 

The clipping mask had a gray eyeball, which is not the same as "not selected." I had deselected the text only, and the clipping mask went from white eyeball to gray eyeball. If I click the clipping mask and make it "no eyeball" it works as its supposed to.

I was able to duplicate the problem by going back to an unaltered file which is in Polish instead of English, and it became apparent. See image below with orange arrow.

Thank you for taking the time to debug this. Sorry for the false report.

Yours,
Marc