JPEG saved using "Export As" from Photoshop CC 2015.1 fails to import into Premiere Pro.

  • 2
  • Problem
  • Updated 3 years ago
  • (Edited)
I am exporting importing JPG files from Photoshop for use in a Premiere Pro project. Although fine when used in every other app, every JPG fails to import to PP, reporting a generic "the importer reported a generic error" message.
I did all the usual TS for both progs, no resolve.
Then I tried importing JPG's I had exported from earlier versions of PS. 100% success. Latest version (CC 2015.1.1, 64 bit, PC), 100% fail. Then I used the PS Export For Web (Legacy) option. 100% Successful import.
It appears something in the new PS Export dialog is messing up the file just enough that they can't be imported to PP. Could be a simple metadata issue. Whatever it is, it's annoying and a pain in the proverbial.
To be helpful, I figured you may want to know.
Photo of Carl Green

Carl Green

  • 3 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 2
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 814 Reply Likes
Did you save the files (Save, Save As, Save For Web), or use "Export As"?
Save, SaveAs, and SaveForWeb have not changed their JPEG code in years.
"Export As" is using different JPEG code from the rest of Photoshop, and may have issues.

But, metadata changes could cause problems as well - and that would affect all saving paths.
Photo of Carl Green

Carl Green

  • 3 Posts
  • 0 Reply Likes
Thanks for the response, Chris. I did suggest that it may be a metadata issue.

You are saying the code has not changed in PS in years, but Export had a radical overhaul in the last version, which broke several things. So much so that the Adobe team rolled out an update to fix. This is why I believe the issue lies with PS Export rather than Premiere Import.

To clarify, this issue only affects JPG files being output from the latest version of PS using this new Export dialog. All JPG's from other sources import into Premiere without issue, as do all older JPG's created using the pre-update PS output, AND notably, those created this very morning with the PS Save For Web (Legacy). So output from PS does work, but it seems that the Export dialog itself is introducing something undesirable. Make sense?
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 814 Reply Likes
As I said - ExportAs is using different JPEG code from the rest of Photoshop.

For the time being you should use SaveForWeb or SaveAs instead of ExportAs.
Photo of Carl Green

Carl Green

  • 3 Posts
  • 0 Reply Likes
You changed your reply. lol
I discovered the workaround and have incorporated it into my workflow. Save For Web (Legacy) saved the day. I passed on my observations simply to help the team with the debug process. More info is always useful, right?

All good. Thanks Chris!