Photoshop: Error: "Javascript code was missing"

  • 1
  • Problem
  • Updated 4 months ago
  • (Edited)
I get "Javascript code was missing" when running scripts. I've confirmed this on 3 separate Macs running MacOS Sierra. This error occurs with both custom scripts and Adobe provided scripts. While I've seen this bug in previous versions, it seems to be a constant in the 2017 version of Photoshop. Rebooting temporarily fixes the problem, but it will return after a short time of use. I've already spent several hours searching forms and have applied all of the permissions based solutions. No luck.
Photo of Christopher Hanck

Christopher Hanck

  • 1 Post
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Jaroslav Bereza

Jaroslav Bereza

  • 809 Posts
  • 187 Reply Likes
Can you tell me which scripts doesn't work?
I you have custom scripts it can happen. Because Adobe can change how is action manager code stuctured and this will break script.
Photo of Joe Reynolds

Joe Reynolds

  • 1 Post
  • 1 Reply Like
I had this issue and was pulling my hair out for ages... 
It turned out to be a PC on the network that had a shared folder called "users" mounted on my computer. Any shared drive that is mounted on your computer with a name that is the same as part of the core systems will give you this issue ("applications", "users", etc). Find which drive is causing you the issue by:
• Disconnecting from the network and confirming that the scripts work
• Reconnect and confirm the scripts don't work once all usual drives are connected• Step through, ejecting shared drives one at a time and checking each time until your scripts work again.
I'm sure there are other issues that can present the "Javascript code was missing" error, but this is how I fixed mine.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14550 Posts
  • 1893 Reply Likes