Lightroom: Issue with Map module in OS X 10.10 (Yosemite)

  • 62
  • Problem
  • Updated 4 years ago
  • Solved
  • (Edited)
On OS X 10.10 (Yosemite), the map in Lightroom's Map module is very slow to load. It takes several minutes before the first part of the map appears, and some parts don't load at all, saying instead "Sorry, we have no imagery here", even though the part in question is on Google Maps. When zooming in or out, it's the same, it takes very long to update.
Photo of Maya Taneda

Maya Taneda

  • 2 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 62
Photo of Benjamin Warde

Benjamin Warde, Employee

  • 483 Posts
  • 74 Reply Likes
Hi Everyone,

This bug occurs because Apple has changed something in their network stack in 10.10 that causes problems for the Lightroom Map module (specifically, with APE, the web engine that the Map module uses), particularly in low-bandwidth conditions. The "extra" network traffic that some people have observed is (so far as we can tell) just retries resulting from failures in the network stack.

We are working with Apple to get to the bottom of exactly what changed and to see if there are any reliable workarounds, and whether there is something that needs to be fixed on the OS level. Unless Apple makes changes to the OS to allow Lightroom's web engine to work properly again, the only other option is that we replace the entire web engine that's at the heart of the Map module. We are actually working on replacing the entire web engine, in case Apple cannot provide a fix, but it's a large undertaking which cannot be accomplished quickly.

Thanks,
Ben
Photo of RobertK81

RobertK81

  • 8 Posts
  • 2 Reply Likes
Thank you very much for this reply. This I think all of us can understand, and is exactly what we were looking for (besides the actual solution to the issue of course).

Thank you, and take care.
Photo of Michael ODonnell

Michael ODonnell

  • 5 Posts
  • 0 Reply Likes
Thanks for this very honest and frank response. I'm not happy but it's easier to accept this now it's acknowledged.
Photo of Allan Pedley

Allan Pedley

  • 48 Posts
  • 1 Reply Like
Thanks Benjamin

Really good hearing the issue in this way with luck you or Apple will find the issue soon

Allan
Photo of Ardash Muradian

Ardash Muradian

  • 7 Posts
  • 3 Reply Likes
I joined the Apple Beta program and updated to 10.10.2 - the Map module now works perfectly.
Photo of Wolfgang Domröse

Wolfgang Domröse

  • 2 Posts
  • 3 Reply Likes
I updated to 10.10.2. beta. Perfect now, as far as I can see.
Photo of Dave Roberts

Dave Roberts

  • 147 Posts
  • 25 Reply Likes
The point I make is that Adobe cannot fix it! Apple have fixed it but this fix is only visible to beta testers at the moment, you sign up for Yosemite beta testing if it that urgent?
Photo of Alan Harper

Alan Harper

  • 430 Posts
  • 85 Reply Likes
Just for it's worth: I installed 10.10.2 and it seems to have solved this problem. A new beta was released yesterday, and it is supposed to be relatively stable: http://9to5mac.com/2015/01/21/apple-o...