Photoshop CC 2015: Issue selecting and editing layers on MacOS 10.11

  • 1
  • Problem
  • Updated 3 years ago
  • Solved
  • (Edited)
Since my upgrade to PsCC2015 and El Capitan, I've run into a very annoying (though inconsistent) issue with layers I've drug and dropped into an image with multiple layers. When I click on said layer, then attempt to move and/or resize the object, another layer is instantly selected and I end up moving it instead. Very weird.

Let me put this another way in case I'm making no sense. Let's say I've got a file with 10 layers, including both adjustment layers and image layers I've imported into the original image. For example, a photo of a house, with separate layers for the sky, a cat and a jet flying overhead. I've also got a couple texture layers. I want to move the jet from on spot to another in the sky. I click on the jet layer in the Layers panel, then click on the jet in the image and begin to drag. But, whoops, I'm moving a texture layer! Again, I click the jet layer. As soon as I click in the image, the texture layer is selected and I move it. The only workaround I've found is to hide the texture layer, then move the jet. Even then--sometimes--the selected layer changes to another layer and I end up moving it.

Crazy? I've tweaked settings, made sure I've got the latest rev of PS, etc., etc. BTW, I'm running PS/El Capitan on a 2011 27" iMac on a 1TB SSD and 32GB RAM.

Any ideas? Thanks!
Photo of Roger Love

Roger Love

  • 2 Posts
  • 1 Reply Like

Posted 3 years ago

  • 1
Photo of eartho

eartho

  • 846 Posts
  • 229 Reply Likes
Every tool in Photoshop has a number of options in the Option bar...Select the move tool and then try looking at those and see if you can figure out why this issue is happening to you...

Given that there are only two check boxes for that tool, i imagine it shouldn't be too difficult...
Photo of Roger Love

Roger Love

  • 2 Posts
  • 1 Reply Like
Well, well. Learn something every day. I cleared the Auto-Select checkbox in the Options bar, and things seem to be working as expected.

Thank you, EA.