Is this normal? Lightroom CC Direct2DEnabled: false GPUDevice: not available

  • 2
  • Problem
  • Updated 3 years ago
I've already seen the GPU FAQ page. My friend with same Nvidia 970GTX also have the same report. Compared with my iMac 27 mid 2011. My PC ( latest 6 core overclocked at 4.3ghz with 970gtx) isn't really much faster. So, I suspect GPU rendering might not be working properly.

I have this at the end of hardware info. Is this normal?

Adapter #1: Vendor : 10de
Device : 13c2
Subsystem : 367b1458
Revision : a1
Video Memory : 4009
AudioDeviceIOBlockSize: 1024
AudioDeviceName: Realtek Digital Output(Optical) (Realtek High Definition Audio)
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 44100
Build: LR5x102
Direct2DEnabled: false
GPUDevice: not available
OGLEnabled: true

Full hardwareinfo:
Lightroom version: CC 2015 [1014445]
License: Creative Cloud
Operating system: Windows 7 Business Edition
Version: 6.1 [7601]
Application architecture: x64
System architecture: x64
Logical processor count: 12
Processor speed: 3.3 GHz
Built-in memory: 16209.7 MB
Real memory available to Lightroom: 16209.7 MB
Real memory used by Lightroom: 2205.5 MB (13.6%)
Virtual memory used by Lightroom: 2285.9 MB
Memory cache size: 1437.0 MB
Maximum thread count used by Camera Raw: 6
Camera Raw SIMD optimization: SSE2,AVX,AVX2
System DPI setting: 96 DPI
Desktop composition enabled: Yes
Displays: 1) 1920x1080
Input types: Multitouch: No, Integrated touch: No, Integrated pen: Yes, External touch: No, External pen: Yes, Keyboard: No

Graphics Processor Info:
GeForce GTX 970/PCIe/SSE2
Check OpenGL support: Passed
Vendor: NVIDIA Corporation
Version: 3.3.0 NVIDIA 350.12
Renderer: GeForce GTX 970/PCIe/SSE2
LanguageVersion: 3.30 NVIDIA via Cg compiler
pplication folder: C:\Program Files\Adobe\Adobe Lightroom
Library Path: C:\Users\Guang\Pictures\Lightroom\2014LRCAT\2014LRCAT-2.lrcat
Settings Folder: C:\Users\Guang\AppData\Roaming\Adobe\Lightroom

Installed Plugins:

1) Behance
2) Canon Tether Plugin
3) Facebook
4) Flickr
5) Leica Tether Plugin
6) Nikon Tether Plugin

Config.lua flags: None

Adapter #1: Vendor : 10de
Device : 13c2
Subsystem : 367b1458
Revision : a1
Video Memory : 4009
AudioDeviceIOBlockSize: 1024
AudioDeviceName: Realtek Digital Output(Optical) (Realtek High Definition Audio)
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 44100
Build: LR5x102
Direct2DEnabled: false
GPUDevice: not available
OGLEnabled: true
Photo of L1dimup

L1dimup

  • 17 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 2
Photo of Chris Castleberry

Chris Castleberry, Camera Raw Engineer

  • 364 Posts
  • 103 Reply Likes
Hi,

Since the internal self tests in Lr are passing, a couple of things that may help.

1. We have had some customer reports that they resolved the issue by completely uninstalling their NVIDIA GPU driver and reinstalling it. Please check with the NVIDIA support site for instructions for uninstalling/reinstalling the driver software.

2. Another customer with a similar NVIDIA card reported they were using the Riva Tuner GPU software and resolving the issue involved configuring Riva Tuner to ignore Lightroom. See the following thread for additional information.

http://feedback.photoshop.com/photosh...

Hope this helps,

- Chris
Photo of L1dimup

L1dimup

  • 17 Posts
  • 0 Reply Likes
Hi Chris,

First of all, Thanks. So this is not normal.

1. I tried doing clean install of the driver. It didn't change the report/performance.
2. I have no GPU tuner software on my PC.
Photo of Chris Castleberry

Chris Castleberry, Camera Raw Engineer

  • 364 Posts
  • 103 Reply Likes
Hi,

I'm sorry to hear your initial uninstall/reinstall did not sort the issue. One additional resource you might try:

http://www.guru3d.com/files-details/d...

If this does not work, you can disable "Use Graphics Processor" and continue working.

We are actively working with display card manufacturers, so you should check back on this forum as we may post additional information that could help resolve your GPU/ACR issue.

Regards,

- Chris
Photo of L1dimup

L1dimup

  • 17 Posts
  • 0 Reply Likes
The tool did not help.

Can you confirm that I'm not supposed to get these errors?

Direct2DEnabled: false
GPUDevice: not available
Photo of Chris Castleberry

Chris Castleberry, Camera Raw Engineer

  • 364 Posts
  • 103 Reply Likes
These entries are not related to Lr GPU acceleration for interactive image editing, so yes, this is normal.
Photo of Bruce in Philly

Bruce in Philly

  • 9 Posts
  • 0 Reply Likes
I have the same issue and Graphics Card....... EVGA GTX 970 SC card

Direct2DEnabled: false
GPUDevice: not available

I ran performance tests checked and unchecked and the performance is the exact same. My Nvidia drivers are up to date. I am not running any 3rd party anything. I have only one graphics card. List below has it all........

Bruce in Philly

Lightroom version: 6.0.1 [ 1018573 ]
License: Perpetual
Operating system: Windows 7 Business Edition
Version: 6.1 [7601]
Application architecture: x64
System architecture: x64
Logical processor count: 12
Processor speed: 3.2 GHz
Built-in memory: 32707.2 MB
Real memory available to Lightroom: 32707.2 MB
Real memory used by Lightroom: 786.8 MB (2.4%)
Virtual memory used by Lightroom: 774.6 MB
Memory cache size: 475.0 MB
Maximum thread count used by Camera Raw: 6
Camera Raw SIMD optimization: SSE2,AVX
System DPI setting: 120 DPI
Desktop composition enabled: Yes
Displays: 1) 2560x1600, 2) 1920x1080
Input types: Multitouch: No, Integrated touch: No, Integrated pen: No, External touch: No, External pen: No, Keyboard: No

Graphics Processor Info:
GeForce GTX 970/PCIe/SSE2

Check OpenGL support: Passed
Vendor: NVIDIA Corporation
Version: 3.3.0 NVIDIA 352.86
Renderer: GeForce GTX 970/PCIe/SSE2
LanguageVersion: 3.30 NVIDIA via Cg compiler

Application folder: C:\Program Files\Adobe\Adobe Lightroom
Library Path: C:\Users\Bruce\Pictures\Lightroom\Lightroom Catalog-2.lrcat
Settings Folder: C:\Users\Bruce\AppData\Roaming\Adobe\Lightroom

Installed Plugins:
1) Behance
2) Canon Tether Plugin
3) ColorChecker Passport
4) Export to Photomatix Pro
5) Facebook
6) Flickr
7) Leica Tether Plugin
8) Nikon Tether Plugin

Config.lua flags: None

Updated Toolkit: Adobe Camera Raw 9.0 for Lightroom 6.0 (build 1014445)
Updated Toolkit: Book Module 6.0 (build 1014445)
Updated Toolkit: Develop Module 6.0 (build 1014445)
Updated Toolkit: Import Module 6.0 (build 1014445)
Updated Toolkit: Library Module 6.0 (build 1014445)
Updated Toolkit: Map Module 6.0 (build 1014445)
Updated Toolkit: Monitor Module 6.0 (build 1014445)
Updated Toolkit: Print Module 6.0 (build 1014445)
Updated Toolkit: Slideshow Module 6.0 (build 1014445)
Updated Toolkit: Web Module 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.AgNetClient 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.AgWFBridge 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.Headlights 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.LibraryToolkit 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.MultiMonitorToolkit 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.archiving_toolkit 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.bridgetalk 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.catalogconverters 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.cef_toolkit 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.coretech_toolkit 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.curculio 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.discburning 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.email 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.export 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.ftpclient 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.help 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.iac 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.imageanalysis 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.layout_module_shared 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.pdf_toolkit 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.sdk 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.sec 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.socket 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.store_provider 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.substrate 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.ui 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.video_toolkit 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.xml 6.0 (build 1014445)
Updated Toolkit: com.adobe.wichitafoundation 6.0 (build 1014445)
Adapter #1: Vendor : 10de
Device : 13c2
Subsystem : 29743842
Revision : a1
Video Memory : 4008
AudioDeviceIOBlockSize: 1024
AudioDeviceName:
AudioDeviceNumberOfChannels: 0
AudioDeviceSampleRate: 44100
Build: Uninitialized
Direct2DEnabled: false
GPUDevice: not available
OGLEnabled: true
Photo of McLion

McLion

  • 24 Posts
  • 5 Reply Likes
LR is not using Direct2D, it is using OpenGL for the accelearation.
However, I don't know why the Direct2D is listed, it is misleading