Is Elements compatible with Max OS X 10.6.8 or 10.9 or with QuarkXpress 7 .5

  • 1
  • Question
  • Updated 4 years ago
I have a Mac OS X 10.6.8 (trying to upgrade to OS X 10.9); I work with QuarkXpress 7.5 (trying to upgrade to 9); and already have Photoshop 8, which I sort of hate using it - too complicated. Will Photoshop Elements work with the Mac and QuarkXpress? Thanks. I'll be so happy if I can upgrade and get everything to work together without spending a fortune:)
Photo of MARY BETH FRANCIS

MARY BETH FRANCIS

  • 3 Posts
  • 0 Reply Likes
  • confused and frustrated:)

Posted 4 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 814 Reply Likes
See https://helpx.adobe.com/x-productkb/p...

You would have to ask Quark if they have problems working with current releases of Photoshop or Elements.
Photo of MARY BETH FRANCIS

MARY BETH FRANCIS

  • 3 Posts
  • 0 Reply Likes
Thank you - it looks like Elements 11 with work with my Mac. any idea if QuarkXpress is compatible, or doesn't it matter? (I'm not a beginner but pac man was popular way back then!)