Lightroom: Invalid constraint size error

  • 6
  • Problem
  • Updated 5 years ago
  • Solved
  • (Edited)
Perform the following steps in this order.

Library module
Select an image
Choose export
Set resize mode to long edge
Set inches and enter 12 for size
Set pixels per inch
Enter 300 for resolution

On Windows 8.1 64bit I get the following error:

Invalid constraint size. Must be a number between 1 and 217. Closest value inserted.



This only happens when I try to change ppi in long edge or short edge mode. Other modes work fine.

Also if I switch from inches to pixels I can set the ppi to 300. If I then switch back to inches the 300 value will stick as long as I don't attempt to change it.
Photo of Andy Jones

Andy Jones

  • 12 Posts
  • 3 Reply Likes

Posted 5 years ago

  • 6
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7262 Posts
  • 1646 Reply Likes
Official Response
I tried it on Windows 7 and got the same result as you. Then I tried it in LR 5 and it didn't throw an error. I am going to file a bug and have it looked at. Thank you!
Photo of Paul Empson

Paul Empson

  • 2 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled LightRoom v6 - DPI export issue limits to 217 ppi.

In the Export dialogue: Resizing area... DPI selection is being restricted for a couple of output options:

In the Image Sizing area...

1: untick the Resize to Fit check box (output at image size) and I can enter 300dpi.. no problems..
2: tick the Resize to fit, Longest or Shortest edges.. and only up to 217 allowed...
3: tick Resize to Fit, Width & Height... and can set 300 dpi..

LR v6

https://d2r1vs3d9006ap.cloudfront.net...
Photo of Sam Jost

Sam Jost

  • 2 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Lightroom CC shows error with high dpi on export..

In Lightroom CC, when I export an picture, I've got the following bug (which others could reproduce):

When I select "long side" in sizing options, enter the size in cm or inch and enter 600dpi Lightroom will immediately show an error message like:
"The dpi is too high, it needs to be in the range of 1 to 275"
and sets the dpi to 275.
Higher values will produce different max for the error, but do not work, either.

I can work around this problem by selecting "width by height" or enter the pixel count instead of the cm/inch-size. But this is annoying since I use this kind of export a lot.

Cheers Sam
Photo of John R. Ellis

John R. Ellis, Champion

  • 5040 Posts
  • 1418 Reply Likes
Official Response
This was fixed in LR CC 2015.1 / 6.1: http://blogs.adobe.com/lightroomjourn...