Lightroom CC: Internal error: "?.0 attempt to index a nil value"

  • 3
  • Problem
  • Updated 8 months ago
  • (Edited)
I work on a iMac (OS X Yosemite) in Lightroom CC and try to publish a large book to Blurb. Halfway the upload, I get this "internal error" message : "?:0 attempt to index a nil value". All I can do is cancel the upload as nothing moves anymore.. any solution to publish my book ?
Photo of Dirk De Jonghe

Dirk De Jonghe

  • 1 Post
  • 0 Reply Likes

Posted 3 years ago

  • 3
Photo of Nicole Goenner

Nicole Goenner

  • 1 Post
  • 0 Reply Likes
Go to your publishing service’s website. Chances are it has already generated a placeholder for your upload. Delete it from the website. Republish. Just worked for me. 
Photo of Ronald Byram

Ronald Byram

  • 99 Posts
  • 13 Reply Likes
I am running Lightroom Classic CC and was attempting to export 200 photographs to SMug MUG when I got this error.  "An internal error has occurred: ?:0: attempt to index a nul value.
I am running on Windows 10 with ALL updates applied.  I have had this several times in past. Not sure of exact steps to create but will note them in future.
Photo of Rachel Rosenthal

Rachel Rosenthal

  • 1 Post
  • 0 Reply Likes
I finally figured out what my issue was after getting the "internal error...nil value" error message.  I  uploaded to Smugmug in batches of five until I hit a group of problematic images.  Looking carefully at the metadata of that group, seemed I had multiple images with 0 MP file size. Thumbnail was there, but no data. No idea why.  I then went through and deleted those images and restarted the upload. Everything worked seamlessly!  I've now set my view options in LR to show MP size so I can easily scan a group of photos for this issue.