Photoshop Elements: Inspiration Browser Problem

  • 1
  • Problem
  • Updated 7 years ago
  • Solved
  • (Edited)
I need help re-installing and/or opening Inspiration Browser. A few days ago, when I opened Photoshop Elements 8, I got a pop asking me to install the latest version of Inspiration Browser. I was instructed to UNINSTALL the current version of Inspiration Browser which I did. When I followed the instructions to re-install the new Inspiration, it got installed in my "Documents" file rather than my"Programs (86) Adobe " location where all of my other Adobe programs are located. Then I was unable to open it getting this message "Cannot Open. 'C:\Users\Ken\Documents\AdobePhotoshopDotCominspirationbrowser.air' because it is in the wrong type of file". I tried restoring my computer to an earlier date, but I still was unable to open Inspiration. Then I UNINSTALLED/ERASED/Sent to the recycle bin all versions/copies of both Inspiration Browser and Adobe Air in the hopes of re-installing both under "Programs(86) Adobe". The installation failed because it said that a program of that name already existed there and I would have to pick another location. Right now it is somewhere on my computer (Can't leave this page to locate it, or I will loose this forum note). I'm not sure where it is, but I am still unable to open it..Can anyone tell me in step by step fashion what I need to do to find and uninstall ALL versions/copies of these programs and then systematically re-install them. I tried to reach Adobe Technical Support, but after being on hold for more then 2 hours, I gave up. Any help you can provide would be greatly appreciated. Thanks so much in advance. Ken Manning 706-845-8103

UPDATE: I found Inspiration Browser on my computer in two locations. The first is under Control Panel>Programs. Adobe AIR Version however under "SIZE" there is nothing listed. Also found Adobe Inspiration Browser Version 3.09 but under "SIZE" there is nothing listed. In addition to this location, I found Inspiration Browser on my C: hard Drive> Program Files (x86)>Adobe>PhotoshopDotComInspirationBrowser>Adobe Elements Inspiration Browser a SFW file , size 1,181 KB, but I am unable to open it.
Photo of Ken Manning

Ken Manning

  • 2 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 1
Photo of Brett N

Brett N, Official Rep

  • 2258 Posts
  • 118 Reply Likes
Official Response
First, AdobePhotoshopDotCominspirationbrowser.air not the Inspiration Browser program. That is the installation file that you download. So it downloaded to what is likely your default download location at C:\Users\Ken\Documents\. So the application still required an installation, because all applications from from a .EXE file.

Second, when you double-click on a file, your OS (Windows) determines what application is going to open that file. This is called File Association. There is an application associated with each file type. In this case, the .AIR file should be opening with the "Adobe Air Application Installer". The error you got ("Cannot Open because it is in the wrong type of file") suggests that the File Type Associations on your computer have likely been changed and are attempting to be opened in the wrong application (one that does not support .AIR files).

In the first step, you almost had everything working and ready to go. At this point, I'm not sure what damaged you've done with removing files. It doesn't sound like you deleted folders, but instead did file searches and deleted individual files. That seems to be the reason you still have an SWF file (these are Flash playback files and are usually embedded within web pages, which is why you cannot open them), likely AdobeElementsInspirationBrowser.swf. If possible, I would suggest restoring all of the files to their original location, then right-click the .AIR file you downloaded and choose "Open With", then find the "Adobe Air Application Installer.exe" (C:\Program Files (x86)\Common Files\Adobe AIR\Versions\1.0) to run it.

Otherwise, make sure the AIR and Inspiration Browser folders have been removed before attempting to reinstall.