Incorrect colours when opening photo's in Elements 11

  • 1
  • Problem
  • Updated 4 years ago
When opening photo's in Photoshop Elements they do not have the true colours.
When I open them in ACD See I am getting the right colours.
What is wrong? How an I solve this?
I am using Photoshop Elements number 11.
Regards
Jos Merks
Photo of Jos Merks

Jos Merks

  • 2 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 812 Reply Likes
ACDSee isn't color managed.
Photoshop and Elements are color managed.

So most likely your display profile doesn't correctly match your display, or ACDSee is just making things look more saturated than they should be because of a wide gamut display.
Photo of Jos Merks

Jos Merks

  • 2 Posts
  • 0 Reply Likes
Thanks Chris,
Could well be that it is a display issue.
But why is Elements giving the wrong colours. Far more blue than it should be.
See the image in the enclosure made with print screen. You can clearly see the difference. Left is elements. Rgds Jos
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 812 Reply Likes
Because Elements is using your display profile to compensate for your display peculiarities. So if your display profile doesn't match your display - then Elements would display colors weirdly, because it is compensating for something other than your actual display.

ACDSee is just sending bits to the screen, ignoring what they actually look like and hoping they seem reasonable on your display.