In Lightroom, Why does my Publish to Facebook always think it failed and abort?

  • 5
  • Problem
  • Updated 5 years ago
  • Solved
Everytime I attempt up Publish Photos to Facebook, Lightroom reports that the operation failed. However, the photos show up on Facebook just fine.

Add one or more photos to the Facebook publish set by dragging thumbnails onto the Facebook Publish service.
Click publish.
Dialogue box tells me "Photo upload failed"; click ok
Another dialogue box tells me "Can't update this collection. Photo upload failed"; click ok

The first photo in the collection gets uploaded just fine. However, Lightroom apparently aborts after that. Lightroom still thinks all the photos are yet-to-be-published. Lightroom will consequently attempt to upload the photos anytime I try to publish to Facebook.

Mac OS X 10.7.3, Lightroom 4.0

Photo of Drew


  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 6 years ago

  • 5
Photo of JamesW


  • 2 Posts
  • 0 Reply Likes
I am getting fed up with this. Is it only me or are there other people. I am using version 4.1 everything is up to date, my interent connection is fine. I have even tried using the freidl facebook uploader. I have the same problem. I upload 10 to 15 photos, it then idles for a couple of hours and then says upload failed.
I am having to export the album and upload them either through my web browser or through iphoto.
I love this software but this photo uploader is a joke and there seems to be no one interested in sorting it out.

This reply was created from a merged topic originally titled
LR 4.1: problems uploading to facebook.
Photo of ben chia

ben chia

  • 4 Posts
  • 0 Reply Likes
I tried publishing (quite a number of) pictures to Facebook using Lightroom 4.1. However, after publishing 30 or so pictures, Lightroom will show up "Photo upload failed, but no error string was returned from Facebook. ", followed by " Can’t update this collection. Photo upload failed, but no error string was returned from Facebook.". And I had to click publish again, and the cycle repeats after 30 or so pictures again.

When I open up the plugin manager, it says Facebook plug is installed, but may not be working correctly. I tried reloading the plugin, after which it says its working correctly. But when I try to publish again, the above problem continue to persist. How can I tackle this problem?

Thing's I've tried:
I've tred re-authenticating my Facebook acc with Lightroom.
I've tried removing the Lightroom app from my Facebook, and re-authorize it with Lightroom.
I've tried removing the entire Facebook Plugin and add it back in.

Problem still persists.

This reply was created from a merged topic originally titled
LIGHTROOM: Facebook Plugin publish error.
Photo of Ronnie Deas

Ronnie Deas

  • 9 Posts
  • 0 Reply Likes
Is this the answer
4.2 RC
scroll to fixed issued in Facebook
Photo of Son Nguyen

Son Nguyen

  • 61 Posts
  • 12 Reply Likes
I haven't tried 4.2RC yet. But I've noticed that if you have a web-browser especially firefox open on facebook page, the upload will fail. I've tried it on at least 3 different computers and got the same result. Turn off LR, close the facebook page, open LR again, try to reupload and everything is working fine. So now, I never open FB page when uploading from LR. Hope this help somewhat.
Photo of Ronnie Deas

Ronnie Deas

  • 9 Posts
  • 0 Reply Likes
Thats very interesting - worth trying I think then if it works all the time.
Photo of Col Velo

Col Velo

  • 1 Post
  • 1 Reply Like
I finally got it to work by making sure that none of my browsers had Facebook opened at the time when I was trying to upload my images to Facebook from Lightroom.