Lightroom Classic: Screen preview screen turns black when I switch from 'Library' to 'Develop

  • 2
  • Problem
  • Updated 2 months ago
  • Solved
  • (Edited)
Als ik in de module 'Bibliotheek' ben en ik klik een foto aan om aan te passen 'Verwerken' wordt het voorbeeldscherm heel regelmatig zwart. Met als resultaat dat ik geen aanpassingen kan doen.

"When I am in the module 'Library' and I click on a picture to adjust 'Process' the example screen is very regularly black. As a result, I can not make any adjustments."
Photo of charles VERHEYEN

charles VERHEYEN

  • 2 Posts
  • 1 Reply Like

Posted 2 months ago

  • 2
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4868 Posts
  • 990 Reply Likes
In Voorkeuren> Prestaties schakelt u de optie GPU gebruiken uit.

Photo of charles VERHEYEN

charles VERHEYEN

  • 2 Posts
  • 1 Reply Like
Ik heb GPU uitgeschakeld en tot hier toe geeft het een prima resultaat.
Hartelijk dank.
Verheyen Charles.
Photo of Roy McLaren

Roy McLaren

  • 39 Posts
  • 4 Reply Likes

This seems to be a regularly occuring proble. I thought it was solved when I updated to Windows 10 a few months back, however problem has returned since I updated to Lightroom Classic v8.1. Is disabling GPU acceleration really a solution? Surely this has drawbacks on rendering performance, right?
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4676 Posts
  • 1796 Reply Likes
If disabling the GPU solves the problem, it means there's a problem with the GPU driver.

In many cases, going direct to the GPU manufacturer's website can find updated drivers that work fine, or occasionally there may be a setting in the GPU preferences that's conflicting with Lightroom. In either case, you can then let LR utilize the GPU again. 
Photo of Arnold Bartel

Arnold Bartel

  • 194 Posts
  • 45 Reply Likes
Try to force LR to use DirectX. I made the experience that using DirectX instead of OpenGL solves the problem (without having to disable the GPU support).
Photo of Roy McLaren

Roy McLaren

  • 39 Posts
  • 4 Reply Likes
Interesting that it only started after my recent upgrade to v8.1 maybe something threw the use DirectX setting. How do I access that setting to force Lightroom to use DirectX by the way?
Photo of Arnold Bartel

Arnold Bartel

  • 194 Posts
  • 45 Reply Likes
Follow the suggestions in https://feedback.photoshop.com/photoshop_family/topics/i-have-update-lightroom-cc-to-lightroom-class...

Go to
C:\Users\%Username%\AppData\Roaming\Adobe\CameraRaw\GPU

Open Camera Raw GPU Config

and change in  text file from opengl to directx.


and check in your LR Preference-Dialog is DirectX or OpenGL is used.

good luck!


Photo of Roy McLaren

Roy McLaren

  • 39 Posts
  • 4 Reply Likes
That seems to have done the trick. The GPU config specified crs:gpu_preferred_system="OpenGL". Changing OpenGL to DirectX seems to have eliminated problem for time being. Thanks!
Photo of Arnold Bartel

Arnold Bartel

  • 194 Posts
  • 45 Reply Likes
Photo of Roy McLaren

Roy McLaren

  • 39 Posts
  • 4 Reply Likes

OK, thanks Arnold, will check this out