Importing Photos from LR4 to PSE9

  • 1
  • Problem
  • Updated 7 years ago
I cannot import any photos from LR4 into Photoshop Elements 9. What gives? What should I do to make this work? Both Ligyhtroom and PSE recognize my camera.
Photo of Deena Spector

Deena Spector

  • 9 Posts
  • 0 Reply Likes
  • frustrated

Posted 7 years ago

  • 1
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2656 Posts
  • 341 Reply Likes
Please elaborate. i.e. what happens when you try to go from LR4 to PSE9?
1) Elements is not listed as an option for Edit In?
2) Nothing at all happens when you click on Edit in PSE?
3) You see an unintelligible error message?
4) You see an error that is understandable but is unexpected?
5) PSE opens up but no image is displayed?
6) PSE opens up and something unexpected is displayed?
Photo of Deena Spector

Deena Spector

  • 9 Posts
  • 0 Reply Likes
I get a message box that begins with "Photoshop Elements editor not compatible with Lightroom. Please update configuration."
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2656 Posts
  • 341 Reply Likes
Are you given a choice whether to update a configuration or not or is the update-configuration a failure message? LR4 told me it needed to update its configuration after I installed ACR 6.7 RC because it needed to recompile its lens and camera databases due to the new profiles added. LR4 fails to reconfigure itself because it cannot find the AdobeLightroom64.msi or some such thing because it has already been deleted out of the temporary folder at the end of the LR4 install some hours or days, earlier. I was stuck and had to re-run setup64.exe until it has extracted the msi file and then I can copy that somewhere and cancel the setup64.
Photo of Deena Spector

Deena Spector

  • 9 Posts
  • 0 Reply Likes
I certainly appreciate your help. Lightroom is telling me that my "Editor Incompatible with Lightroom 4. Please select an alternate Photoshop Elements version (if installed) or obtain a newer version."
I can send the photo to Photomatix. Guess I will do that till Adobe fixes the problem.

Thanks
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2656 Posts
  • 341 Reply Likes
It is possible that error is due to PSE9 not being able to host the new LR4-compatible version of ACR 6.7, and it never will, so an option would be to have LR4 render to a TIF or PSD file and have PSE9 open that. This thread describes how to set up LR to do that, although it is about LR3:
http://www.elementsvillage.com/forums...
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2656 Posts
  • 341 Reply Likes
Here is a longer thread on the subject:
http://www.flickr.com/groups/adobe_li...
Photo of Deena Spector

Deena Spector

  • 9 Posts
  • 0 Reply Likes
I really do appreciate your efforts. I tried Julie's fix. When I go into preferences LR does not even acknowledge I have PSE. I think I am going to try the reinstall option (or just continue to use LR3 until PSE11 comes out). Do you know if I have then have to reinstall my plugins - Topaz etc?
Thanks again.
Photo of Stuart Morley

Stuart Morley

  • 1 Post
  • 0 Reply Likes
There is a bug in LR4. At the moment you cannot import to ANY version of elements. Adobe will fix with a patch in the near future. Meanwhile, Adobe recommend you download the trial version of CS5. You don't have to use it just install. It should fix the problem until the LR4.1 upgrade
Photo of Deena Spector

Deena Spector

  • 9 Posts
  • 0 Reply Likes
Thank you