Lightroom 5: Import dialog showing all photos no matter what I chose

  • 1
  • Problem
  • Updated 4 years ago
  • (Edited)
I have problems with the importdialog in LR5 (tried 5.2 and 5.3 as well), and the problem is that every photo on my memorycard is displayed when I chose "New photos", even if I have imported them already. I have been using LR5 since it was released and this problem occured recently. Is this a bug, a setting somewhere? Hope someone have a solution because!
Photo of Thomas Gjeterud

Thomas Gjeterud

  • 2 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Rob Cole

Rob Cole

  • 4831 Posts
  • 379 Reply Likes
This sort of issue is raised regularly. Unfortunately, the problem is almost never isolated because the user and/or Adobe doesn't come up with the requisite info.

My understanding (which could be wrong) is that Lr uses:
* Filesize
* Original filename
* Capture date

to determine if file is new or already imported (and still existing).

So the obvious questions are:
* Is the filesize the same (it probably won't be if you re-saved file in mfr. software or camera firmware).
* is the original filename the same? (i.e. current name on card same as original name in Lr).
* How does capture date of photos on card compare to that recorded by Lr? (IMO, this is the most likely culprit if there is a bug).

Again, as far as I know, Adobe has never confirmed the determining factors, so take with salt...

PS - To be clear, Lr will *not* remember which files were imported if they have since been deleted, it is only comparing files on card to those still in Lr catalog.

PPS - There are no settings which govern new-photo determination.

~R.
Photo of Thomas Gjeterud

Thomas Gjeterud

  • 2 Posts
  • 0 Reply Likes
My Filesize, filename and capture date/time is the same in both LR and on the memory card. No resaving has been done either. If I just import all the files from memory card, and then select the same memorycard again all files are still displayed even if I have chose "New photo". I do not get this. Can someone from Adobe please clarify how this is determined, and what the reason for this may be?